aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2008-08-25 06:23:27 +0000
committerMike Westerhof <mwester@dls.net>2008-08-25 06:23:27 +0000
commit36c64170765ecb2b2437e9b58d9ff5e262b186a8 (patch)
tree2d5b6abe48414d8c15968fe14720786969386a36 /packages
parent69cd4b590282088c35967213d400e480150d43c8 (diff)
downloadopenembedded-36c64170765ecb2b2437e9b58d9ff5e262b186a8.tar.gz
SlugOS 5.0 - slugos-init: update to make nfs boot work correctly; cleanup
of kexec stuff (although kexec won't work with the current kernel yet).
Diffstat (limited to 'packages')
-rw-r--r--packages/slugos-init/files/boot/kexec3
-rw-r--r--packages/slugos-init/files/boot/network12
-rw-r--r--packages/slugos-init/slugos-init_5.0.bb2
3 files changed, 11 insertions, 6 deletions
diff --git a/packages/slugos-init/files/boot/kexec b/packages/slugos-init/files/boot/kexec
index dd757fd771..a60be03142 100644
--- a/packages/slugos-init/files/boot/kexec
+++ b/packages/slugos-init/files/boot/kexec
@@ -91,7 +91,6 @@ if [ -n "$1" -a -n "$2" ] ; then
t=`basename "$kpath"`
kexec_image="/mnt/$t"
fi
- umount /sys
fi
;;
@@ -105,7 +104,6 @@ if [ -n "$1" -a -n "$2" ] ; then
t=`basename "$kpath"`
kexec_image="/mnt/$t"
fi
- umount /sys
fi
;;
@@ -143,7 +141,6 @@ if [ -n "$1" -a -n "$2" ] ; then
echo "Loading kexec kernel using tftp \"$kpath\"..."
tftp -g -l "$kexec_image" -r "${kpath#*:}" "${kpath%%:*}"
fi
- umount /sys
fi
;;
diff --git a/packages/slugos-init/files/boot/network b/packages/slugos-init/files/boot/network
index 8124f19ab2..48aa9dd7d5 100644
--- a/packages/slugos-init/files/boot/network
+++ b/packages/slugos-init/files/boot/network
@@ -24,8 +24,12 @@ ifconfig lo 127.0.0.1 up
iface="$(config iface)"
test -z "$iface" && exit 1
#
-# Fire up a process in the background to load the firmware if necessary
-sysf="/sys/class/firmware/firmware-$iface"
+# Fire up a process in the background to load the firmware if necessary.
+# If this system doesn't require the NPE-B firmware, no problem, the
+# background process will simply go away in two seconds. If it requires
+# some other firmware, then modification will be required. We probably
+# should replace this with mdev or some other hotplug-based technique...
+sysf="/sys/class/firmware/$iface"
(
# Wait for the firware to be requested, if required
[ -f $sysf/loading ] || sleep 1
@@ -39,5 +43,9 @@ sysf="/sys/class/firmware/firmware-$iface"
# Trigger the firmware load proactively
ifconfig "$iface" up
#
+# Unmount /sys and /proc before we leave
+umount /sys
+umount /proc
+#
ifup "$iface"
# exit code is true only if the interface config has succeeded
diff --git a/packages/slugos-init/slugos-init_5.0.bb b/packages/slugos-init/slugos-init_5.0.bb
index 92ac7e30f3..9b7c2cd8d0 100644
--- a/packages/slugos-init/slugos-init_5.0.bb
+++ b/packages/slugos-init/slugos-init_5.0.bb
@@ -4,7 +4,7 @@ PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r1"
+PR = "r1.2"
SRC_URI = "file://boot/flash \
file://boot/disk \