aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-04-03 09:54:31 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-03 09:54:31 +0000
commit9d8ae3f654d70431baee403658229e900e17a847 (patch)
treeb9f9a91cd50a588a93cede2421b1eef6a1d7e3e5 /packages
parente16288a8cfa94af17760097a3f04ff42be47ba76 (diff)
downloadopenembedded-9d8ae3f654d70431baee403658229e900e17a847.tar.gz
altboot: Remove an error message when /bin/sh -> /bin/bash
Diffstat (limited to 'packages')
-rw-r--r--packages/altboot/altboot_0.0.0.bb2
-rw-r--r--packages/altboot/files/init.altboot10
2 files changed, 8 insertions, 4 deletions
diff --git a/packages/altboot/altboot_0.0.0.bb b/packages/altboot/altboot_0.0.0.bb
index 5981b41231..82314a8f22 100644
--- a/packages/altboot/altboot_0.0.0.bb
+++ b/packages/altboot/altboot_0.0.0.bb
@@ -6,7 +6,7 @@ MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
IGNORE_STRIP_ERRORS = "1"
-PR = "r32"
+PR = "r33"
SRC_URI = "file://altboot-menu \
diff --git a/packages/altboot/files/init.altboot b/packages/altboot/files/init.altboot
index dc3900dcca..ed95ce1c9c 100644
--- a/packages/altboot/files/init.altboot
+++ b/packages/altboot/files/init.altboot
@@ -243,9 +243,13 @@ wait_for_input() {
# above to launch the altboot menu.
- # This filters an "<ENTER>" from the user as "any key"
- ( while :; do read x< /dev/tty0 2>&1; done; ) > /dev/null 2>&1 &
- sleep 1; kill $!
+ # Bash throws an ugly error on kill
+ if ! (readlink /bin/sh | grep -q bash)
+ then
+ # This filters an "<ENTER>" from the user as "any key"
+ ( while :; do read x< /dev/tty0 2>&1; done; ) > /dev/null 2>&1 &
+ sleep 1; kill $! >/dev/null 2>&1
+ fi