aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-12-19 17:20:11 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-12-19 17:20:11 +0000
commit15e48ec580ecf616892833f754759e28da57012d (patch)
treed2e7abcb287866f3df3692ce3d9c8b612152756e /packages
parenta4f2e81674c1de8e29d4c03de851a2d133536688 (diff)
downloadopenembedded-15e48ec580ecf616892833f754759e28da57012d.tar.gz
git: fix case of the disappearing snapshots by adding a stable release
Diffstat (limited to 'packages')
-rw-r--r--packages/git/files/Makefile.patch13
-rw-r--r--packages/git/git-native_1.4.4.2.bb3
-rw-r--r--packages/git/git-native_snapshot.bb9
-rw-r--r--packages/git/git.inc15
-rw-r--r--packages/git/git_1.4.4.2.bb3
-rw-r--r--packages/git/git_snapshot.bb30
6 files changed, 21 insertions, 52 deletions
diff --git a/packages/git/files/Makefile.patch b/packages/git/files/Makefile.patch
deleted file mode 100644
index e360ae917d..0000000000
--- a/packages/git/files/Makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: git-snapshot-20051008/Makefile
-===================================================================
---- git-snapshot-20051008.orig/Makefile 2005-10-06 00:57:23.000000000 +0100
-+++ git-snapshot-20051008/Makefile 2005-10-08 22:03:50.000000000 +0100
-@@ -332,7 +332,7 @@
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-
- git-%$X: %.o $(LIB_FILE)
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) $(LDFLAGS)
-
- git-mailinfo$X : SIMPLE_LIB += $(LIB_4_ICONV)
- $(SIMPLE_PROGRAMS) : $(LIB_FILE)
diff --git a/packages/git/git-native_1.4.4.2.bb b/packages/git/git-native_1.4.4.2.bb
new file mode 100644
index 0000000000..f91fd03ab1
--- /dev/null
+++ b/packages/git/git-native_1.4.4.2.bb
@@ -0,0 +1,3 @@
+require git.inc
+inherit native
+DEPENDS = "openssl-native curl-native"
diff --git a/packages/git/git-native_snapshot.bb b/packages/git/git-native_snapshot.bb
deleted file mode 100644
index 84e6f96686..0000000000
--- a/packages/git/git-native_snapshot.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require git_snapshot.bb
-inherit native
-DEPENDS = "expat-native openssl-native curl-native"
-
-do_stage () {
- oe_runmake install bindir=${STAGING_BINDIR} \
- template_dir=${STAGING_DIR}/${BUILD_SYS}/share/git-core/templates/ \
- GIT_PYTHON_DIR=${STAGING_DIR}/${BUILD_SYS}/share/git-core/python
-}
diff --git a/packages/git/git.inc b/packages/git/git.inc
new file mode 100644
index 0000000000..384dfaaeec
--- /dev/null
+++ b/packages/git/git.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
+S = "${WORKDIR}/git-${PV}"
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+
+FILES_${PN} += "${datadir}/git-core"
+
diff --git a/packages/git/git_1.4.4.2.bb b/packages/git/git_1.4.4.2.bb
new file mode 100644
index 0000000000..37f71cfb04
--- /dev/null
+++ b/packages/git/git_1.4.4.2.bb
@@ -0,0 +1,3 @@
+require git.inc
+DEPENDS = "openssl curl"
+RDEPENDS = "perl perl-module-file-path"
diff --git a/packages/git/git_snapshot.bb b/packages/git/git_snapshot.bb
deleted file mode 100644
index c9048a4673..0000000000
--- a/packages/git/git_snapshot.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SECTION = "console/utils"
-LICENSE = "GPL"
-DESCRIPTION = "The git revision control system used by the Linux kernel developers"
-DEPENDS = "openssl curl"
-RDEPENDS = "perl \
- perl-module-file-path \
- "
-
-PR = "r2"
-
-def get_git_pkgdate(d):
- import bb
- srcdate = bb.data.getVar('SRCDATE', d, 1)
- return "-".join([srcdate[0:4], srcdate[4:6], srcdate[6:8]])
-
-PKGDATE = "${@get_git_pkgdate(d)}"
-
-SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/git/git-${PKGDATE}.tar.gz"
-PV = "1.4.3.5+snapshot${PKGDATE}"
-
-S = "${WORKDIR}/git-${PKGDATE}"
-
-FILES_${PN} += "${datadir}/git-core"
-
-do_install () {
- oe_runmake install prefix=${D} bindir=${D}${bindir} \
- template_dir=${D}${datadir}/git-core/templates \
- GIT_PYTHON_DIR=${D}${datadir}/git-core/python
-}
-