aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-05-15 22:41:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-05-15 22:41:15 +0000
commit715d0f2c86c693007951fc6560f0e14e46076cb3 (patch)
tree8b32b218d58a3e2871e534d5c77d36a7877ef997 /packages
parent51755d3df0e8ca4458fa788229bf84a02d12bf7a (diff)
parentcdd621e16e6865cda9379477754649c3d02865f6 (diff)
downloadopenembedded-715d0f2c86c693007951fc6560f0e14e46076cb3.tar.gz
merge of '1ae309a70c139143a4704b5def248a5be0b1a810'
and '327945003e321bca077ca44f526f2f0463ff8277'
Diffstat (limited to 'packages')
-rw-r--r--packages/batmand/batmand_0.3.bb29
-rw-r--r--packages/batmand/files/.mtn2git_empty0
-rw-r--r--packages/batmand/files/makefile-fix.patch13
3 files changed, 42 insertions, 0 deletions
diff --git a/packages/batmand/batmand_0.3.bb b/packages/batmand/batmand_0.3.bb
new file mode 100644
index 0000000000..c78f94d5e3
--- /dev/null
+++ b/packages/batmand/batmand_0.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "https://www.open-mesh.net/batman"
+
+PR = "r0"
+
+RDEPENDS = "kernel-module-tun"
+
+SRC_URI = "\
+ http://downloads.open-mesh.net/batman/stable/sources/batman-0.3.tar.gz \
+ file://makefile-fix.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/batman-${PV}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 batmand ${D}${bindir}
+}
diff --git a/packages/batmand/files/.mtn2git_empty b/packages/batmand/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/batmand/files/.mtn2git_empty
diff --git a/packages/batmand/files/makefile-fix.patch b/packages/batmand/files/makefile-fix.patch
new file mode 100644
index 0000000000..ff6ceb38e1
--- /dev/null
+++ b/packages/batmand/files/makefile-fix.patch
@@ -0,0 +1,13 @@
+Index: batman-0.3/Makefile
+===================================================================
+--- batman-0.3.orig/Makefile 2008-05-15 19:09:47.000000000 +0200
++++ batman-0.3/Makefile 2008-05-15 21:01:14.000000000 +0200
+@@ -17,8 +17,6 @@
+ #
+
+
+-CC = gcc
+-CFLAGS = -Wall -O1 -g3
+ EXTRA_CFLAGS = -DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA -DREVISION_VERSION=$(REVISION_VERSION)
+ LDFLAGS = -lpthread
+