aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2007-09-07 21:38:18 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2007-09-07 21:38:18 +0000
commit8cf2748d115cdfc018eb92d81072fe6422516414 (patch)
treeb1cc3de423b8fc6296e4bdd78e6bfd734d4da5bb /packages
parent6df7b6c8ef449b4d70ff6fce2871ba1bc48ad248 (diff)
parent8a00555b71e47ee86e8449a8f44b7e16c3cef1ae (diff)
downloadopenembedded-8cf2748d115cdfc018eb92d81072fe6422516414.tar.gz
merge of '76f17964c43f7ddee34e65c3b91d78a68aecd213'
and '83398e1336b5456cc5a8661377b3819a02cc3ba2'
Diffstat (limited to 'packages')
-rw-r--r--packages/dbus/dbus-1.0.2/dbus-1.init2
-rw-r--r--packages/dbus/dbus_1.0.2.bb2
-rw-r--r--packages/images/angstrom-minimal-image-with-mtd-utils.bb2
-rw-r--r--packages/linux/linux.inc19
-rw-r--r--packages/tcpdump/tcpdump_3.9.7.bb (renamed from packages/tcpdump/tcpdump_3.9.3.bb)3
5 files changed, 16 insertions, 12 deletions
diff --git a/packages/dbus/dbus-1.0.2/dbus-1.init b/packages/dbus/dbus-1.0.2/dbus-1.init
index 38e7574ad5..46e321860d 100644
--- a/packages/dbus/dbus-1.0.2/dbus-1.init
+++ b/packages/dbus/dbus-1.0.2/dbus-1.init
@@ -62,7 +62,7 @@ start_it_up()
shut_it_down()
{
if [ -d $EVENTDIR ]; then
- run-parts --reverse --arg=stop $EVENTDIR
+ run-parts --arg=stop $EVENTDIR
fi
echo -n "Stopping $DESC: "
start-stop-daemon --stop --quiet --pidfile $PIDFILE \
diff --git a/packages/dbus/dbus_1.0.2.bb b/packages/dbus/dbus_1.0.2.bb
index a660eb1586..0c97e30406 100644
--- a/packages/dbus/dbus_1.0.2.bb
+++ b/packages/dbus/dbus_1.0.2.bb
@@ -2,4 +2,4 @@ require dbus.inc
SRC_URI += " file://fix-waitpid.patch;patch=1"
-PR = "r2"
+PR = "r3"
diff --git a/packages/images/angstrom-minimal-image-with-mtd-utils.bb b/packages/images/angstrom-minimal-image-with-mtd-utils.bb
index 740c39126c..4fe33e9282 100644
--- a/packages/images/angstrom-minimal-image-with-mtd-utils.bb
+++ b/packages/images/angstrom-minimal-image-with-mtd-utils.bb
@@ -3,7 +3,7 @@
# to program the NAND flash.
require angstrom-minimal-image.bb
-RDEPENDS += "mtd-utils"
+IMAGE_INSTALL += "mtd-utils"
export IMAGE_BASENAME = "minimalist-image-mtdutils"
diff --git a/packages/linux/linux.inc b/packages/linux/linux.inc
index 8a3a36a66b..05bfc2f472 100644
--- a/packages/linux/linux.inc
+++ b/packages/linux/linux.inc
@@ -71,16 +71,21 @@ do_deploy() {
tar -cvzf ${DEPLOY_DIR_IMAGE}/modules-${KERNEL_RELEASE}-${PR}-${MACHINE}.tgz -C ${D} lib
if test "x${KERNEL_IMAGETYPE}" = "xuImage" ; then
- ${OBJCOPY} -O binary -R .note -R .comment -S vmlinux linux.bin
- rm -f linux.bin.gz
- gzip -9 linux.bin
- uboot-mkimage -A ${ARCH} -O linux -T kernel -C gzip -a ${UBOOT_ENTRYPOINT} -e ${UBOOT_ENTRYPOINT} -n "${DISTRO_NAME}/${PV}/${MACHINE}" -d linux.bin.gz ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}-${DATETIME}.bin
- rm -f linux.bin.gz
- fi
+ if test -e arch/${ARCH}/boot/compressed/vmlinux ; then
+ ${OBJCOPY} -O binary -R .note -R .comment -S arch/${ARCH}/boot/compressed/vmlinux linux.bin
+ uboot-mkimage -A ${ARCH} -O linux -T kernel -C none -a ${UBOOT_ENTRYPOINT} -e ${UBOOT_ENTRYPOINT} -n "${DISTRO_NAME}/${PV}/${MACHINE}" -d linux.bin ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}-${DATETIME}.bin
+ rm -f linux.bin
+ else
+ ${OBJCOPY} -O binary -R .note -R .comment -S vmlinux linux.bin
+ rm -f linux.bin.gz
+ gzip -9 linux.bin
+ uboot-mkimage -A ${ARCH} -O linux -T kernel -C gzip -a ${UBOOT_ENTRYPOINT} -e ${UBOOT_ENTRYPOINT} -n "${DISTRO_NAME}/${PV}/${MACHINE}" -d linux.bin.gz ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}-${DATETIME}.bin
+ rm -f linux.bin.gz
+ fi
+ fi
}
do_deploy[dirs] = "${S}"
-addtask prepatch before do_patch after do_unpack
addtask deploy before do_package after do_install
diff --git a/packages/tcpdump/tcpdump_3.9.3.bb b/packages/tcpdump/tcpdump_3.9.7.bb
index 7ffcc9a37f..ba9710d86a 100644
--- a/packages/tcpdump/tcpdump_3.9.3.bb
+++ b/packages/tcpdump/tcpdump_3.9.7.bb
@@ -3,8 +3,7 @@ HOMEPAGE = "http://www.tcpdump.org/"
LICENSE = "BSD"
SECTION = "console/network"
PRIORITY = "optional"
-DEPENDS = "libpcap-0.9.3"
-PR = "r2"
+DEPENDS = "libpcap"
SRC_URI = "http://www.tcpdump.org/release/tcpdump-${PV}.tar.gz \
file://tcpdump_configure_no_-O2.patch;patch=1"