aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-23 21:10:01 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-23 21:10:01 +0000
commit22934fa6743681429e16592ef5973e35e9f4e961 (patch)
treea6b9e077435139dbe1cdb71292a340ee63fcbed9 /packages
parent2d1b94d9d663689fa80547cac38fe341b29232f6 (diff)
parentee555b51dde02582da9cee0b902e5d14025ecde4 (diff)
downloadopenembedded-22934fa6743681429e16592ef5973e35e9f4e961.tar.gz
merge of '11e16c0631a379bd3a4c6908966eff49f46f5868'
and '34ba545afcf63a7d03f4016ad7e58bd09feaedee'
Diffstat (limited to 'packages')
-rw-r--r--packages/gizmod/.mtn2git_empty0
-rw-r--r--packages/gizmod/files/.mtn2git_empty0
-rw-r--r--packages/gizmod/files/disable-bmp.patch105
-rw-r--r--packages/gizmod/files/disable-xmms.patch113
-rw-r--r--packages/gizmod/files/fix-python-configure.patch26
-rw-r--r--packages/gizmod/gizmod_2.3.bb23
-rw-r--r--packages/musicpd/glurp_0.11.3.bb (renamed from packages/musicpd/glurp_0.11.6.bb)0
-rw-r--r--packages/musicpd/libmpd_svn.bb23
-rw-r--r--packages/musicpd/mpc_0.12.0.bb12
-rw-r--r--packages/musicpd/mpd_svn.bb36
-rw-r--r--packages/musicpd/py-libmpdclient_0.10.0.bb11
-rw-r--r--packages/quilt/quilt-native.inc2
-rw-r--r--packages/quilt/quilt.inc1
-rw-r--r--packages/quilt/quilt_0.45.bb2
14 files changed, 352 insertions, 2 deletions
diff --git a/packages/gizmod/.mtn2git_empty b/packages/gizmod/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gizmod/.mtn2git_empty
diff --git a/packages/gizmod/files/.mtn2git_empty b/packages/gizmod/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gizmod/files/.mtn2git_empty
diff --git a/packages/gizmod/files/disable-bmp.patch b/packages/gizmod/files/disable-bmp.patch
new file mode 100644
index 0000000000..89dfad3446
--- /dev/null
+++ b/packages/gizmod/files/disable-bmp.patch
@@ -0,0 +1,105 @@
+Index: gizmod-2.3/configure.ac
+===================================================================
+--- gizmod-2.3.orig/configure.ac
++++ gizmod-2.3/configure.ac
+@@ -319,76 +319,6 @@ fi
+
+ ###########################################################################
+ ##
+-## Check whether to build BMP plugin
+-##
+-
+-##################
+-## enabled?
+-########
+-
+-AC_MSG_CHECKING(Whether or not to build BMP plugin)
+-AC_ARG_ENABLE(bmp,
+- [ --enable-bmp build BMP plugin <default = no>],
+- [enable_bmp="$enableval"], enable_bmp=no)
+-AC_MSG_RESULT($enable_bmp)
+-
+-AM_CONDITIONAL(BUILD_EXTERNALPLUGIN_BMP, test x$enable_bmp = xyes)
+-AM_CONDITIONAL(BUILD_PLUGIN_BMPCONTROL, test x$enable_bmp = xyes)
+-
+-##################
+-## can we build it if it's enabled?
+-########
+-
+-if test "$enable_bmp" == "yes"; then
+-
+-BEEP_CFLAGS=""
+-BEEP_LIBS=""
+-
+-#check stuff
+-AM_PATH_GLIB_2_0(2.4.0, ,
+- AC_MSG_ERROR([GTK+ >= 2.4.0 not installed - required for BMP plugin]))
+-AM_PATH_GTK_2_0(2.4.0, ,
+- AC_MSG_ERROR([GTK+ >= 2.4.0 not installed - required for BMP plugin]))
+-
+-dnl check for beep
+-PKG_CHECK_MODULES(BEEP, [ bmp >= 0.9.7], ,
+- AC_MSG_ERROR("You need the BEEP development files to build the BEEP plugin!"))
+-
+-BEEP_PLUGIN_DIR="`$PKG_CONFIG --variable=output_plugin_dir bmp`"
+-BEEP_INPUT_PLUGIN_DIR="`$PKG_CONFIG --variable=input_plugin_dir bmp`"
+-BEEP_OUTPUT_PLUGIN_DIR="`$PKG_CONFIG --variable=output_plugin_dir bmp`"
+-BEEP_GENERAL_PLUGIN_DIR="`$PKG_CONFIG --variable=general_plugin_dir bmp`"
+-BEEP_VISUALIZATION_PLUGIN_DIR="`$PKG_CONFIG --variable=visualization_plugin_dir bmp`"
+-BEEP_EFFECT_PLUGIN_DIR="`$PKG_CONFIG --variable=effect_plugin_dir bmp`"
+-BEEP_DATA_DIR="`$PKG_CONFIG --variable=data_dir bmp`"
+-
+-AC_SUBST(BEEP_PLUGIN_DIR)
+-AC_SUBST(BEEP_INPUT_PLUGIN_DIR)
+-AC_SUBST(BEEP_OUTPUT_PLUGIN_DIR)
+-AC_SUBST(BEEP_GENERAL_PLUGIN_DIR)
+-AC_SUBST(BEEP_VISUALIZATION_PLUGIN_DIR)
+-AC_SUBST(BEEP_EFFECT_PLUGIN_DIR)
+-AC_SUBST(BEEP_DATA_DIR)
+-
+-dnl make BEEP_DATA_DIR a variable in config.h
+-AH_TEMPLATE(BEEP_DATA_DIR, "Path to bmp-touch.config")
+-AC_DEFINE_UNQUOTED(BEEP_DATA_DIR, "$BEEP_DATA_DIR")
+-
+-CPPFLAGS="$CPPFLAGS $BEEP_CFLAGS"
+-
+-AC_CHECK_HEADER(bmp/beepctrl.h, [
+- AC_DEFINE(HAVE_BEEPCTRL_H, 1, [Has bmp/beepctrl.h])
+- ], [
+- AC_MSG_ERROR([Cannot find beepctrl.h!])
+- ])
+-
+-AC_SUBST(BEEP_CFLAGS)
+-AC_SUBST(BEEP_LIBS)
+-
+-fi
+-
+-###########################################################################
+-##
+ ## Check whether to build Sound Visualization plugin
+ ##
+
+@@ -633,9 +563,7 @@ AC_CONFIG_FILES([
+ plugins/soundVisualization/Makefile
+ plugins/cpuUsage/Makefile
+ plugins/x11/Makefile
+- plugins/bmpControl/Makefile
+ plugins/externalPlugins/Makefile
+- plugins/externalPlugins/bmp/Makefile
+ plugins/lirc/Makefile
+ ])
+ AC_OUTPUT
+Index: gizmod-2.3/plugins/Makefile.am
+===================================================================
+--- gizmod-2.3.orig/plugins/Makefile.am
++++ gizmod-2.3/plugins/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 bmpControl lirc
++SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 lirc
+Index: gizmod-2.3/plugins/externalPlugins/Makefile.am
+===================================================================
+--- gizmod-2.3.orig/plugins/externalPlugins/Makefile.am
++++ gizmod-2.3/plugins/externalPlugins/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS=bmp
++SUBDIRS=
diff --git a/packages/gizmod/files/disable-xmms.patch b/packages/gizmod/files/disable-xmms.patch
new file mode 100644
index 0000000000..e8aea12b4c
--- /dev/null
+++ b/packages/gizmod/files/disable-xmms.patch
@@ -0,0 +1,113 @@
+Index: gizmod-2.3/configure.ac
+===================================================================
+--- gizmod-2.3.orig/configure.ac
++++ gizmod-2.3/configure.ac
+@@ -393,60 +393,6 @@ fi
+
+ ###########################################################################
+ ##
+-## Check whether to build XMMS plugin
+-##
+-
+-##################
+-## enabled?
+-########
+-
+-AC_MSG_CHECKING(Whether or not to build XMMS plugin)
+-AC_ARG_ENABLE(xmms,
+- [ --enable-xmms build XMMS plugin <default = yes>],
+- [enable_xmms="$enableval"], enable_xmms=yes)
+-AC_MSG_RESULT($enable_xmms)
+-
+-AM_CONDITIONAL(BUILD_EXTERNALPLUGIN_XMMS, test x$enable_xmms = xyes)
+-AM_CONDITIONAL(BUILD_PLUGIN_XMMSCONTROL, test x$enable_xmms = xyes)
+-
+-##################
+-## can we build it if it's enabled?
+-########
+-
+-if test "$enable_xmms" == "yes"; then
+-
+-XMMS_CFLAGS=""
+-XMMS_LIBS=""
+-
+-#check stuff
+-
+-AM_PATH_XMMS(1.2.4,
+- XMMS_CFLAGS=`xmms-config --cflags`
+- CPPFLAGS="$CPPFLAGS $XMMS_CFLAGS"
+- XMMS_LIBS=`xmms-config --libs`
+- ,
+- AC_MSG_ERROR([You must have the XMMS development headers installed to build the XMMS plugin!])
+-)
+-
+-AC_CHECK_HEADER(xmms/xmmsctrl.h, [
+- AC_DEFINE(HAVE_XMMSCTRL_H, 1, [Has xmms/xmmsctrl.h])
+- ], [
+- AC_MSG_ERROR([Cannot find xmmsctrl.h!])
+- ])
+-
+-AC_CHECK_HEADER(xmms/plugin.h, [
+- AC_DEFINE(HAVE_XMMSPLUGIN_H, 1, [Has xmms/xmmsplugin.h])
+- ], [
+- AC_MSG_ERROR([Cannot find xmms/plugin.h!])
+- ])
+-
+-AC_SUBST(XMMS_CFLAGS)
+-AC_SUBST(XMMS_LIBS)
+-
+-fi
+-
+-###########################################################################
+-##
+ ## Check whether to build Sound Visualization plugin
+ ##
+
+@@ -691,10 +637,8 @@ AC_CONFIG_FILES([
+ plugins/soundVisualization/Makefile
+ plugins/cpuUsage/Makefile
+ plugins/x11/Makefile
+- plugins/xmmsControl/Makefile
+ plugins/bmpControl/Makefile
+ plugins/externalPlugins/Makefile
+- plugins/externalPlugins/xmms/Makefile
+ plugins/externalPlugins/bmp/Makefile
+ plugins/lirc/Makefile
+ ])
+@@ -774,22 +718,10 @@ else
+ echo " BMP Control plugin: Disabled"
+ fi
+
+-if test "$enable_xmms" == "yes"; then
+- echo " XMMS Control plugin: Enabled"
+-else
+- echo " XMMS Control plugin: Disabled"
+-fi
+-
+ if test "$enable_bmp" == "yes"; then
+ echo " BMP Visualization plugin: Enabled"
+ else
+ echo " BMP Visualization plugin: Disabled"
+ fi
+
+-if test "$enable_xmms" == "yes"; then
+- echo " XMMS Visualization plugin: Enabled"
+-else
+- echo " XMMS Visualization plugin: Disabled"
+-fi
+-
+ echo
+Index: gizmod-2.3/plugins/Makefile.am
+===================================================================
+--- gizmod-2.3.orig/plugins/Makefile.am
++++ gizmod-2.3/plugins/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 xmmsControl bmpControl lirc
++SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 bmpControl lirc
+Index: gizmod-2.3/plugins/externalPlugins/Makefile.am
+===================================================================
+--- gizmod-2.3.orig/plugins/externalPlugins/Makefile.am
++++ gizmod-2.3/plugins/externalPlugins/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS=xmms bmp
++SUBDIRS=bmp
diff --git a/packages/gizmod/files/fix-python-configure.patch b/packages/gizmod/files/fix-python-configure.patch
new file mode 100644
index 0000000000..5cc98d35c0
--- /dev/null
+++ b/packages/gizmod/files/fix-python-configure.patch
@@ -0,0 +1,26 @@
+Index: gizmod-2.3/configure.ac
+===================================================================
+--- gizmod-2.3.orig/configure.ac
++++ gizmod-2.3/configure.ac
+@@ -134,7 +134,7 @@ AC_MSG_CHECKING(for Python linkage)
+ py_libdir="${py_prefix}/lib/python${py_ver}"
+ AC_MSG_RESULT($py_libdir)
+ AC_MSG_CHECKING(for Python includes)
+- PYTHON_INC="-I${py_prefix}/include/python${py_ver}"
++ PYTHON_INC="-I${py_prefix}/TARGET_SYS/include/python${py_ver}"
+ AC_MSG_RESULT($PYTHON_INC)
+ AC_MSG_CHECKING(for Python libs)
+ py_libs=`grep '^LIBS=' $py_libdir/config/Makefile | sed -e 's/^.*=//'`
+@@ -162,11 +162,7 @@ CFLAGS="$PYTHON_INC $CFLAGS"
+ # AC_MSG_ERROR([Cannot find python.h!])
+ # ])
+
+-AC_CHECK_FILE(${py_prefix}/include/python${py_ver}/Python.h, [
+- AC_DEFINE(HAVE_PYTHON_H, 1, [Has Python.h])
+- ], [
+- AC_MSG_ERROR([Cannot find Python.h!])
+- ])
++AC_DEFINE(HAVE_PYTHON_H, 1, [Has Python.h])
+
+ CFLAGS="$OLD_CFLAGS"
+
diff --git a/packages/gizmod/gizmod_2.3.bb b/packages/gizmod/gizmod_2.3.bb
new file mode 100644
index 0000000000..83fe1364ff
--- /dev/null
+++ b/packages/gizmod/gizmod_2.3.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Gizmo Daemon"
+HOMEPAGE = "http://gizmod.sourceforge.net"
+LICENSE = "GPLv2"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+SECTION = "console/multimedia"
+DEPENDS = "python x11"
+SRC_URI = "${SOURCEFORGE_MIRROR}/gizmod/gizmod-${PV}.tar.bz2 \
+ file://disable-xmms.patch;patch=1 \
+ file://fix-python-configure.patch;patch=1 \
+ file://disable-bmp.patch;patch=1"
+
+PR = "r0"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-xmms --disable-bmp --disable-xosd"
+
+do_configure_prepend() {
+ sed -i 's/TARGET_SYS/${TARGET_SYS}/' ${S}/configure.ac
+}
+
+FILES_${PN} += "${datadir}/gizmo/scripts ${datadir}/gizmo/plugins/*.so ${datadir}/gizmo/plugins/*.so.*"
+FILES_${PN}-dev += "${datadir}/gizmo/plugins/*.a ${datadir}/gizmo/plugins/*.la"
diff --git a/packages/musicpd/glurp_0.11.6.bb b/packages/musicpd/glurp_0.11.3.bb
index ff702325cb..ff702325cb 100644
--- a/packages/musicpd/glurp_0.11.6.bb
+++ b/packages/musicpd/glurp_0.11.3.bb
diff --git a/packages/musicpd/libmpd_svn.bb b/packages/musicpd/libmpd_svn.bb
new file mode 100644
index 0000000000..da46f87fc1
--- /dev/null
+++ b/packages/musicpd/libmpd_svn.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Music Player Daemon (mpd) library"
+HOMEPAGE = "http://www.musicpd.org"
+LICENSE = "GPLv2"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+SECTION = "lib/multimedia"
+SRCDATE = "20070120"
+PV = "0.0.0+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "svn://svn.musicpd.org/libmpd;module=trunk;proto=https"
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+do_stage_append() {
+ oe_libinstall -C src libmpd ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/libmpd
+ cd src
+ for i in *.h; do
+ install -m 0644 $i ${STAGING_INCDIR}/libmpd/$i
+ done
+ cd ..
+}
diff --git a/packages/musicpd/mpc_0.12.0.bb b/packages/musicpd/mpc_0.12.0.bb
new file mode 100644
index 0000000000..0313ec8674
--- /dev/null
+++ b/packages/musicpd/mpc_0.12.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Command-line (scriptable) Music Player Daemon (mpd) Client"
+HOMEPAGE = "http://www.musicpd.org/mpc.shtml"
+LICENSE = "GPLv2"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+SECTION = "console/multimedia"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://musicpd.org/uploads/files/mpc-${PV}.tar.gz"
+
+inherit autotools
diff --git a/packages/musicpd/mpd_svn.bb b/packages/musicpd/mpd_svn.bb
new file mode 100644
index 0000000000..da8d595f17
--- /dev/null
+++ b/packages/musicpd/mpd_svn.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Music Player Daemon (mpd)"
+HOMEPAGE = "http://www.musicpd.org"
+LICENSE = "GPLv2"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+SECTION = "console/multimedia"
+DEPENDS = "libvorbis libogg libid3tag libao zlib libmikmod libmad flac audiofile virtual/libiconv faad2"
+SRCDATE = "20070120"
+PV = "0.12.1+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "svn://svn.musicpd.org/mpd;module=trunk;proto=https"
+# file://save-volume-state.patch;patch=1"
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+# Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
+# be built, instead we use the OE built versions which should be installed
+# in staging - remove the --with and replace with --enable to use the local
+# versions.
+
+EXTRA_OECONF = "--enable-ogg \
+ --with-id3tag-libraries=${STAGING_LIBDIR} \
+ --with-id3tag-includes=${STAGING_INCDIR} \
+ --with-mad-libraries=${STAGING_LIBDIR} \
+ --with-mad-includes=${STAGING_INCDIR} \
+ --with-faad-libraries=${STAGING_LIBDIR} \
+ --with-faad-includes=${STAGING_INCDIR} \
+ --disable-jack \
+ --disable-pulse \
+ --enable-mod \
+ --disable-oggflac"
+
+do_compile_prepend() {
+ find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
+}
diff --git a/packages/musicpd/py-libmpdclient_0.10.0.bb b/packages/musicpd/py-libmpdclient_0.10.0.bb
new file mode 100644
index 0000000000..e0d7b7aa1c
--- /dev/null
+++ b/packages/musicpd/py-libmpdclient_0.10.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Python library for Music Player Daemon (mpd)"
+HOMEPAGE = "http://www.musicpd.org/py-libmpdclient.shtml"
+LICENSE = "GPLv2"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+SECTION = "lib/multimedia"
+DEPENDS = "libmpd python"
+PR = "r0"
+
+SRC_URI = "http://mercury.chem.pitt.edu/~shank/py-libmpdclient-${PV}.tar.gz"
+
+inherit distutils
diff --git a/packages/quilt/quilt-native.inc b/packages/quilt/quilt-native.inc
index b7ddd8bce8..5861b2229c 100644
--- a/packages/quilt/quilt-native.inc
+++ b/packages/quilt/quilt-native.inc
@@ -1,7 +1,7 @@
require quilt_${PV}.inc
SRC_URI_append_build-darwin = "? file://non-gnu.patch;patch=1 "
-RDEPENDS_${PN} = "diffstat-native patch-native bzip2-native"
+RDEPENDS_${PN} = "diffstat-native patch-native bzip2-native util-linux-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/quilt-${PV}"
INHIBIT_AUTOTOOLS_DEPS = "1"
diff --git a/packages/quilt/quilt.inc b/packages/quilt/quilt.inc
index b1d19daf45..ee90455fca 100644
--- a/packages/quilt/quilt.inc
+++ b/packages/quilt/quilt.inc
@@ -2,6 +2,7 @@ DESCRIPTION = "Tool to work with series of patches."
HOMEPAGE = "http://savannah.nongnu.org/projects/quilt/"
SECTION = "devel"
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "http://download.savannah.gnu.org/releases/quilt/quilt-${PV}.tar.gz "
diff --git a/packages/quilt/quilt_0.45.bb b/packages/quilt/quilt_0.45.bb
index cf96cc9bc9..d809c83518 100644
--- a/packages/quilt/quilt_0.45.bb
+++ b/packages/quilt/quilt_0.45.bb
@@ -1,4 +1,4 @@
-RDEPENDS_${PN} += "patch diffstat bzip2"
+RDEPENDS_${PN} += "patch diffstat bzip2 util-linux"
require quilt_${PV}.inc