aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-16 12:18:30 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-16 12:18:30 +0000
commit71e0493ec34652c8b7c6f27d04b1242555098cc5 (patch)
tree80060026f2c29fabc8ead72a185ac778aec01c22 /packages
parent8f588b403b68f2dcc17d066963d13ed410fb013f (diff)
downloadopenembedded-71e0493ec34652c8b7c6f27d04b1242555098cc5.tar.gz
ixp4xx:drop
Diffstat (limited to 'packages')
-rw-r--r--packages/ixp425-eth/files/.mtn2git_empty0
-rw-r--r--packages/ixp425-eth/files/2.6.13.patch41
-rw-r--r--packages/ixp425-eth/files/2.6.14.patch28
-rw-r--r--packages/ixp425-eth/files/ethhdr.patch25
-rw-r--r--packages/ixp425-eth/files/intdriven.patch98
-rw-r--r--packages/ixp425-eth/files/makefile.patch18
-rw-r--r--packages/ixp425-eth/files/mm4.patch19
-rw-r--r--packages/ixp425-eth/files/pollcontroller.patch50
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.1.bb45
-rw-r--r--packages/ixp4xx/.mtn2git_empty0
-rw-r--r--packages/ixp4xx/ixp4xx-csr/.mtn2git_empty0
-rw-r--r--packages/ixp4xx/ixp4xx-csr/badpaths.patch18
-rw-r--r--packages/ixp4xx/ixp4xx-csr/build-timing-annoyance.patch10
-rw-r--r--packages/ixp4xx/ixp4xx-csr_1.4.bb51
14 files changed, 0 insertions, 403 deletions
diff --git a/packages/ixp425-eth/files/.mtn2git_empty b/packages/ixp425-eth/files/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ixp425-eth/files/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ixp425-eth/files/2.6.13.patch b/packages/ixp425-eth/files/2.6.13.patch
deleted file mode 100644
index 7e8bea1b5d..0000000000
--- a/packages/ixp425-eth/files/2.6.13.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-# Patches for compilation with 2.6.13.2
-#
---- dir/ixp425_eth.c 2005-09-23 18:34:54.753729121 -0700
-+++ dir/ixp425_eth.c 2005-09-23 18:37:48.908688002 -0700
-@@ -659,7 +659,9 @@
- skb->pkt_type = PACKET_HOST; /* Default type */
- skb->ip_summed = 0;
- skb->priority = 0;
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13)
- skb->security = 0;
-+#endif
-
- /* Some packets may get incorrectly process by netfilter firewall software
- * if CONFIG_NETFILTER is enabled and filtering is in use. The solution is to
-@@ -2358,8 +2362,14 @@
- }
-
- /* set port MAC addr and update the dev struct if successfull */
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13)
- int dev_set_mac_address(struct net_device *dev, struct sockaddr *saddr)
- {
-+#else
-+static int set_mac_address(struct net_device *dev, void *saddrIn)
-+{
-+ struct sockaddr *saddr = saddrIn;
-+#endif
- int res;
- priv_data_t *priv = dev->priv;
- IxEthAccMacAddr npeMacAddr;
-@@ -2476,7 +2486,11 @@
- ndev->poll_controller = ixp425eth_poll_controller;
- #endif
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13)
- ndev->set_mac_address = dev_set_mac_address;
-+#else
-+ ndev->set_mac_address = set_mac_address;
-+#endif
-
- memcpy(ndev->dev_addr, &default_mac_addr[priv->port_id].macAddress,
- IX_IEEE803_MAC_ADDRESS_SIZE);
diff --git a/packages/ixp425-eth/files/2.6.14.patch b/packages/ixp425-eth/files/2.6.14.patch
deleted file mode 100644
index e93edb6e9b..0000000000
--- a/packages/ixp425-eth/files/2.6.14.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-# change in field semantic in 2.6.14
---- dir/ixp425_eth.c 2005-09-24 17:50:57.828607113 -0700
-+++ dir/ixp425_eth.c 2005-09-24 17:54:19.593303365 -0700
-@@ -668,7 +668,11 @@
- * reset the following fields in the skbuff before re-using it on the Rx-path
- */
- #ifdef CONFIG_NETFILTER
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14)
- skb->nfmark = skb->nfcache = 0;
-+#else
-+ skb->nfmark = 0;
-+#endif
- nf_conntrack_put(skb->nfct);
- skb->nfct = NULL;
- #ifdef CONFIG_NETFILTER_DEBUG
-@@ -1300,8 +1300,12 @@
- skb->len -= header_len;
-
- /* fill the pkt arrival time (set at the irq callback entry) */
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14)
- skb->stamp.tv_sec = irq_stamp.tv_sec;
- skb->stamp.tv_usec = irq_stamp.tv_usec;
-+#else
-+ skb_set_timestamp(skb, &irq_stamp);
-+#endif
-
- /* fill the input device field */
- skb->dev = dev;
diff --git a/packages/ixp425-eth/files/ethhdr.patch b/packages/ixp425-eth/files/ethhdr.patch
deleted file mode 100644
index 79c9fef34f..0000000000
--- a/packages/ixp425-eth/files/ethhdr.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- ixp425-eth-1.1-r0/ixp425_eth.c~ethhdr
-+++ ixp425-eth-1.1-r0/ixp425_eth.c
-@@ -1307,7 +1307,7 @@
- * and its constants are taken from the eth_type_trans()
- * function.
- */
-- struct ethhdr *eth = skb->mac.ethernet;
-+ struct ethhdr *eth = eth_hdr(skb);
- unsigned short hproto = ntohs(eth->h_proto);
-
- if (hproto >= 1536)
-@@ -1349,7 +1349,7 @@
- * mode is set This costs
- * a lookup inside the packet payload.
- */
-- struct ethhdr *eth = skb->mac.ethernet;
-+ struct ethhdr *eth = eth_hdr(skb);
- unsigned char *hdest = eth->h_dest;
-
- if (memcmp(hdest, dev->dev_addr, ETH_ALEN)!=0)
diff --git a/packages/ixp425-eth/files/intdriven.patch b/packages/ixp425-eth/files/intdriven.patch
deleted file mode 100644
index 88b2444b5e..0000000000
--- a/packages/ixp425-eth/files/intdriven.patch
+++ /dev/null
@@ -1,98 +0,0 @@
---- ixp425-eth-1.1-r4/ixp425_eth.c 2005-06-16 00:47:55.360598896 -0700
-+++ ixp425-eth-1.1-r4/ixp425_eth.c 2005-06-16 18:42:09.840377651 -0700
-@@ -1028,6 +1030,7 @@
- */
-
- /* PMU Timer reload : this should be done at each interrupt */
-+#if 0 /* UNUSED - used for polling */
- static void dev_pmu_timer_restart(void)
- {
- __asm__(" mcr p14,0,%0,c1,c1,0\n" /* write current counter */
-@@ -1039,6 +1042,7 @@
- " mcr p14,0,r1,c4,c1,0\n" /* enable interrupts */
- : : : "r1");
- }
-+#endif
-
- /* Internal ISR : run a few thousand times per second and calls
- * the queue manager dispatcher entry point.
-@@ -1086,6 +1088,7 @@
- /* Internal ISR : run a few thousand times per second and calls
- * the ethernet entry point.
- */
-+#if 0 /* UNUSED - used for polling */
- static irqreturn_t dev_poll_os_isr(int irg, void *dev_id, struct pt_regs *regs)
- {
- int qlevel = __get_cpu_var(softnet_data).input_pkt_queue.qlen;
-@@ -1127,8 +1130,10 @@
- ixEthTxFrameDoneQMCallback(0,0);
- return IRQ_HANDLED;
- }
-+#endif
-
- /* initialize the PMU timer */
-+#if 0 /* UNUSED - used for polling */
- static int dev_pmu_timer_init(void)
- {
- UINT32 controlRegisterMask =
-@@ -1164,6 +1169,7 @@
-
- return 0;
- }
-+#endif
-
- /* stops the timer when the module terminates */
- static void dev_pmu_timer_disable(void)
-@@ -1636,6 +1636,7 @@
- return 0;
- }
-
-+#if 0 /* UNUSED - used for polling */
- /* The QMgr dispatch entry point can be called from the
- * IXP425_INT_LVL_QM1 irq (which will trigger
- * an interrupt for every packet) or a timer (which will
-@@ -1686,7 +1687,7 @@
- */
- if (request_irq(IXP425_INT_LVL_QM1,
- dev_qmgr_os_isr,
-- SA_SHIRQ,
-+ SA_SHIRQ | SA_SAMPLE_RANDOM,
- DRV_NAME,
- (void *)IRQ_ANY_PARAMETER))
- {
-@@ -1710,6 +1711,7 @@
- }
- return 0;
- }
-+#endif
-
- /* Enable the MAC port.
- * Called on do_dev_open, dev_tx_timeout and mtu size changes
-@@ -2234,7 +2236,7 @@
- */
- if (request_irq(IXP425_INT_LVL_QM1,
- dev_qmgr_os_isr,
-- SA_SHIRQ,
-+ SA_SHIRQ | SA_SAMPLE_RANDOM,
- DRV_NAME,
- (void *)IRQ_ANY_PARAMETER))
- {
-@@ -2669,6 +2671,10 @@
-
- TRACE;
-
-+#if 0 /* DISABLE polling */
-+ /* Enable Interrupt driven driver
-+ * see http://www.nslu2-linux.org/wiki/OpenSlug/StabilizeEthernetDriver
-+ */
- if (no_csr_init == 0) /* module parameter */
- {
- /* The QMgr dispatch entry point is called from the IXP425_INT_LVL_QM1 irq
-@@ -2681,6 +2687,7 @@
- return res;
- }
- }
-+#endif
-
- TRACE;
-
diff --git a/packages/ixp425-eth/files/makefile.patch b/packages/ixp425-eth/files/makefile.patch
deleted file mode 100644
index 2e47972995..0000000000
--- a/packages/ixp425-eth/files/makefile.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- /dev/null
-+++ ixp425-eth-1.1-r0/Makefile
-@@ -0,0 +1,10 @@
-+ifneq ($(KERNELRELEASE),)
-+obj-m := ixp425_eth.o
-+
-+else
-+KDIR := /lib/modules/$(shell uname -r)/build
-+PWD := $(shell pwd)
-+
-+default modules:
-+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
-+endif
diff --git a/packages/ixp425-eth/files/mm4.patch b/packages/ixp425-eth/files/mm4.patch
deleted file mode 100644
index c40aaca998..0000000000
--- a/packages/ixp425-eth/files/mm4.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-# This corrects the type of dev_set_mac_address. The definition (prototype)
-# was *added* to include/linux/netdevice.h in the 2.6.11 mm patches, so the
-# change should not harm older builds
---- ixp425-eth-1.1-r1/ixp425_eth.c.pre-mm4 2005-03-19 14:02:32.883601440 -0800
-+++ ixp425-eth-1.1-r1/ixp425_eth.c 2005-03-19 14:03:25.849549392 -0800
-@@ -2347,12 +2347,11 @@
- }
-
- /* set port MAC addr and update the dev struct if successfull */
--int dev_set_mac_address(struct net_device *dev, void *addr)
-+int dev_set_mac_address(struct net_device *dev, struct sockaddr *saddr)
- {
- int res;
- priv_data_t *priv = dev->priv;
- IxEthAccMacAddr npeMacAddr;
-- struct sockaddr *saddr = (struct sockaddr *)addr;
-
- /* Set MAC addr in h/w */
- memcpy(&npeMacAddr.macAddress,
diff --git a/packages/ixp425-eth/files/pollcontroller.patch b/packages/ixp425-eth/files/pollcontroller.patch
deleted file mode 100644
index f95db28977..0000000000
--- a/packages/ixp425-eth/files/pollcontroller.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-# Add a poll controller to the interface - required for netconsole
---- ixp425-eth-1.1-r1/ixp425_eth.c.pre-pollcontroller 2005-03-19 14:02:32.883601440 -0800
-+++ ixp425-eth-1.1-r1/ixp425_eth.c 2005-03-19 14:03:25.849549392 -0800
-@@ -273,6 +273,11 @@
- extern void
- ixEthTxFrameDoneQMCallback(IxQMgrQId? qId, IxQMgrCallbackId? callbackId);
-
-+#ifdef CONFIG_NET_POLL_CONTROLLER
-+/* poll controller (needed for netconsole et al) */
-+static void ixp425eth_poll_controller(struct net_device *dev);
-+#endif
-+
- /* Private device data */
- typedef struct {
- unsigned int msdu_size;
-@@ -2462,6 +2467,10 @@
- ndev->set_multicast_list = dev_set_multicast_list;
- ndev->flags |= IFF_MULTICAST;
-
-+#ifdef CONFIG_NET_POLL_CONTROLLER
-+ ndev->poll_controller = ixp425eth_poll_controller;
-+#endif
-+
- ndev->set_mac_address = dev_set_mac_address;
-
- memcpy(ndev->dev_addr, &default_mac_addr[priv->port_id].macAddress,
-@@ -2491,6 +2500,23 @@
- return res;
- }
-
-+
-+#ifdef CONFIG_NET_POLL_CONTROLLER
-+/*
-+ * Polling receive - used by netconsole and other diagnostic tools
-+ * to allow network i/o with interrupts disabled.
-+ * (stolen from 8139too.c by siddy)
-+ */
-+static void ixp425eth_poll_controller(struct net_device *dev)
-+{
-+ disable_irq(dev->irq);
-+ dev_qmgr_os_isr(dev->irq, dev, NULL);
-+ enable_irq(dev->irq);
-+}
-+#endif
-+
-+
-+
- static int __devinit npe_eth_init_device(struct device *dev)
- {
- int res = -ENOMEM;
diff --git a/packages/ixp425-eth/ixp425-eth_1.1.bb b/packages/ixp425-eth/ixp425-eth_1.1.bb
deleted file mode 100644
index cbf7e106ce..0000000000
--- a/packages/ixp425-eth/ixp425-eth_1.1.bb
+++ /dev/null
@@ -1,45 +0,0 @@
-DEPENDS = "ixp4xx-csr patcher-native"
-LICENSE = "GPL"
-MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
-SRC_URI = "http://www.intel.com/design/network/swsup/ixp400LinuxEthernetDriverPatch-1_1.zip \
- http://nslu.sourceforge.net/downloads/ixp425_eth.c.patch \
- file://makefile.patch;patch=1 \
- file://ethhdr.patch;patch=1 \
- file://intdriven.patch;patch=1 \
- file://pollcontroller.patch;patch=1 \
- file://mm4.patch;patch=1"
-SRC_URI += "file://2.6.13.patch;patch=1"
-SRC_URI += "file://2.6.14.patch;patch=1"
-PR = "r10"
-
-S = "${WORKDIR}"
-
-COMPATIBLE_HOST = "^armeb-linux.*"
-
-inherit module
-
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
-do_pre_patch () {
- patcher -p 0 -i ixp425_eth_1_1_update_nf_bridge.patch
- patcher -f -p 0 -i ixp425_eth.c.patch
-}
-
-addtask pre_patch before do_patch
-
-do_compile () {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
- 'CC=${KERNEL_CC}' \
- 'LD=${KERNEL_LD}' \
- 'EXTRA_CFLAGS=-I${STAGING_INCDIR}/linux/ixp4xx-csr -I${STAGING_KERNEL_DIR}/include -DCPU=33 -DXSCALE=33'
-}
-
-do_install () {
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
- install -m 0644 ixp425_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
-}
diff --git a/packages/ixp4xx/.mtn2git_empty b/packages/ixp4xx/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ixp4xx/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ixp4xx/ixp4xx-csr/.mtn2git_empty b/packages/ixp4xx/ixp4xx-csr/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ixp4xx/ixp4xx-csr/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ixp4xx/ixp4xx-csr/badpaths.patch b/packages/ixp4xx/ixp4xx-csr/badpaths.patch
deleted file mode 100644
index c5981aa3b7..0000000000
--- a/packages/ixp4xx/ixp4xx-csr/badpaths.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- ixp400_xscale_sw/src/linux/vx.c~ugh 2003-12-12 14:58:34.000000000 -0500
-+++ ixp400_xscale_sw/src/linux/vx.c 2004-11-14 17:50:07.610969440 -0500
-@@ -31,8 +31,8 @@
- *
- * -- End Intel Copyright Notice --
- */
--#include <asm-arm/system.h>
--#include <asm-arm/semaphore.h>
-+#include <asm/system.h>
-+#include <asm/semaphore.h>
- #include <linux/kernel.h>
- #include <linux/time.h>
- #include <linux/sched.h>
diff --git a/packages/ixp4xx/ixp4xx-csr/build-timing-annoyance.patch b/packages/ixp4xx/ixp4xx-csr/build-timing-annoyance.patch
deleted file mode 100644
index 0c040ec2df..0000000000
--- a/packages/ixp4xx/ixp4xx-csr/build-timing-annoyance.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ixp400_xscale_sw/Makefile~ 2004-11-18 21:26:43.000000000 +1030
-+++ ixp400_xscale_sw/Makefile 2004-11-18 21:31:20.000000000 +1030
-@@ -1015,6 +1015,7 @@
- cp Makefile.kmod26 $(OBJ_DIR)/Makefile
- make -C $(OBJ_DIR)
- $(LD) $(LDFLAGS) $^ -o $@
-+ sleep 2
- make -C $(OBJ_DIR)
-
-
diff --git a/packages/ixp4xx/ixp4xx-csr_1.4.bb b/packages/ixp4xx/ixp4xx-csr_1.4.bb
deleted file mode 100644
index 91856a855a..0000000000
--- a/packages/ixp4xx/ixp4xx-csr_1.4.bb
+++ /dev/null
@@ -1,51 +0,0 @@
-MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
-HOMEPAGE = "http://www.intel.com/design/network/products/npfamily/download_ixp400.htm"
-LICENSE = "${PN}"
-LICENSE_HOMEPAGE = "http://www.intel.com/design/network/swsup/ixp400AccessLibrary-1_4.htm"
-SRC_URI = "http://www.intel.com/design/network/swsup/ixp400AccessLibrary-1_4.zip \
- http://www.wnk.at/ixp400_accesslib_kernel26/data/patch_accesslib_kernel26_20040811.diff;patch=1 \
- file://badpaths.patch;patch=1 \
- file://build-timing-annoyance.patch;patch=1"
-S = "${WORKDIR}/ixp400_xscale_sw"
-PR = "r4"
-
-COMPATIBLE_HOST = "^armeb-linux.*"
-
-inherit module
-
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
-#LINUX_MACH_CFLAGS := -D__LINUX_ARM_ARCH__=5 -mcpu=xscale -mtune=xscale
-CFLAGS = "-fno-common -D__KERNEL__ -DMODULE -D__linux -DCPU=33 -DXSCALE=33 \
- -D__LINUX_ARM_ARCH__=5 \
- -I${S}/src/linux -I${S}/src/include \
- ${BUILD_OPTIMIZATION} \
- -I${STAGING_KERNEL_DIR}/include"
-
-EXTRA_OEMAKE = "'CFLAGS=${CFLAGS}' \
- 'CC=${KERNEL_CC}' \
- 'LD=${KERNEL_LD}' \
- 'IX_TARGET=linuxbe' \
- 'LINUX_SRC=${STAGING_KERNEL_DIR}' \
- 'ARCH=${ARCH}'"
-#EXTRA_OEMAKE = "'LINUX_SRC=${STAGING_KERNEL_DIR}' 'IX_TARGET=${IX_TARGET}' \
-# 'ARCH=${TARGET_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}'"
-
-do_compile () {
- oe_runmake ixp400.ko
-}
-
-do_stage () {
- install -d ${STAGING_INCDIR}/linux/ixp4xx-csr
- install -m 0644 src/include/*.h ${STAGING_INCDIR}/linux/ixp4xx-csr/
- cp -rf --dereference src/linux/* ${STAGING_INCDIR}/linux/ixp4xx-csr/
-}
-
-do_install () {
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/drivers/ixp400
- install -m 0644 lib/linuxbe/ixp400.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/drivers/ixp400/
-}