aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-14 14:40:27 +0000
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-14 14:40:27 +0000
commit62109fc5eb81e2e50a351e01384e88467f93326d (patch)
treef78f7544ac3db41fda39d9146ece413a72758c19 /packages
parent8cca824bd98bf3f10fdf3f40d88a69f39635323b (diff)
downloadopenembedded-62109fc5eb81e2e50a351e01384e88467f93326d.tar.gz
dtn: bump for python 2.6
Diffstat (limited to 'packages')
-rw-r--r--packages/dtnrg/dtn_2.5.0.bb31
1 files changed, 10 insertions, 21 deletions
diff --git a/packages/dtnrg/dtn_2.5.0.bb b/packages/dtnrg/dtn_2.5.0.bb
index 3878829ce5..eff2e2e5b9 100644
--- a/packages/dtnrg/dtn_2.5.0.bb
+++ b/packages/dtnrg/dtn_2.5.0.bb
@@ -3,11 +3,14 @@ HOMEPAGE = "http://www.dtnrg.org/wiki"
SECTION = "libs"
DEPENDS = "db openssl python-native xerces-c"
LICENSE = "Apache"
-SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz \
- file://configure_fix.patch;patch=1"
-PR = "r3"
+PR = "r4"
-inherit autotools
+SRC_URI = "\
+ http://www.dtnrg.org/docs/code/dtn_${PV}.tgz \
+ file://configure_fix.patch;patch=1 \
+"
+
+inherit autotools distutils-base
EXTRA_OECONF = "\
--with-python=${STAGING_BINDIR_NATIVE}/python \
@@ -29,22 +32,8 @@ EXTRA_OECONF = "\
--with-openssl=${STAGING_DIR_HOST}${layout_exec_prefix} \
"
-def dtn_python_dir(d):
- import os, bb
- staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
- if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
- if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
- if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
- raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
-
-PYTHON_DIR = "${@dtn_python_dir(d)}"
-
-# use this syntax once everyone has at least bitbake 1.8.9
-#export BUILD_SYS
-#export HOST_SYS
-
-export BUILD_SYS:="${BUILD_SYS}"
-export HOST_SYS:="${HOST_SYS}"
+export BUILD_SYS
+export HOST_SYS
do_configure_prepend() {
for i in aclocal/*.ac oasys/aclocal/*.ac; do
@@ -62,7 +51,7 @@ PACKAGES =+ "${PN}-lib"
FILES_${PN}-lib = "${libdir}/*.so*"
PACKAGES += "python-dtn"
DESCRIPTION_python-dtn = "Python bindings to the DTN API"
-PR_python-dtn = "ml2"
+PR_python-dtn = "ml3"
FILES_python-dtn = "${libdir}/${PYTHON_DIR}"
RDEPENDS_python-dtn = "python-core dtn-lib"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"