aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@koansoftware.com>2009-01-13 18:19:39 +0100
committerMarcin Juszkiewicz <hrw@koansoftware.com>2009-01-16 15:50:22 +0100
commit74c7fba31d7f8e9431534a0c78db3ba224f416ec (patch)
tree8a25e88048784390fc89cc8ff33e66f8f2cbbf8f /packages
parent56ed3d7fecee0aa8ae39f85b414cb8c8a4c56459 (diff)
downloadopenembedded-74c7fba31d7f8e9431534a0c78db3ba224f416ec.tar.gz
busybox/mdev: support devices with ads7846 touchscreen and wrong modalias
Diffstat (limited to 'packages')
-rw-r--r--packages/busybox/busybox_1.13.2.bb2
-rw-r--r--packages/busybox/files/find-touchscreen.sh6
2 files changed, 5 insertions, 3 deletions
diff --git a/packages/busybox/busybox_1.13.2.bb b/packages/busybox/busybox_1.13.2.bb
index 7a5731514c..1451e4a511 100644
--- a/packages/busybox/busybox_1.13.2.bb
+++ b/packages/busybox/busybox_1.13.2.bb
@@ -1,6 +1,6 @@
require busybox.inc
-PR = "r2"
+PR = "r3"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
diff --git a/packages/busybox/files/find-touchscreen.sh b/packages/busybox/files/find-touchscreen.sh
index 34835e7f1c..1582ea891c 100644
--- a/packages/busybox/files/find-touchscreen.sh
+++ b/packages/busybox/files/find-touchscreen.sh
@@ -1,7 +1,9 @@
#!/bin/sh
-
-
if [ `egrep "input:.*-e0.*,3,.*a0,1,.*18,.*" /sys/class/input/$MDEV/device/modalias|wc -l` -gt 0 ]; then
ln -sf /dev/input/$MDEV /dev/input/touchscreen0
fi
+
+if [ `egrep "ads7846" /sys/class/input/$MDEV/device/modalias|wc -l` -gt 0 ]; then
+ ln -sf /dev/input/$MDEV /dev/input/touchscreen0
+fi