aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-10-11 10:11:30 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-11 10:11:30 +0000
commit0f2f623da0cccd2eae320f9353bd915cc59a5af3 (patch)
tree5beddc21c77f8bd559dc0eabf099c90cb8c732b6 /packages
parentc8fd411998c580890374c1d11ce53871ffe6092b (diff)
parent2707ca240b69538f1dfebe668c913aec8cd6842c (diff)
downloadopenembedded-0f2f623da0cccd2eae320f9353bd915cc59a5af3.tar.gz
merge of 190f2a680fcbd7ef0c24337df43378bded12f048
and 665676b78fde532560ccfc82e50fa0416cee55c5
Diffstat (limited to 'packages')
-rw-r--r--packages/appweb/appweb-2.0.4/.mtn2git_empty0
-rw-r--r--packages/appweb/appweb-2.0.4/init.d.patch14
-rw-r--r--packages/appweb/appweb-2.0.4/makerules.patch30
-rw-r--r--packages/appweb/appweb_2.0.4.bb117
-rw-r--r--packages/e17/e-wm_0.16.999.015.bb1
-rw-r--r--packages/geda/files/.mtn2git_empty0
-rw-r--r--packages/geda/files/gEDA.desktop8
-rw-r--r--packages/geda/geda-gsymcheck_20050820.bb12
-rw-r--r--packages/geda/geda_20050820.bb10
-rw-r--r--packages/gnome/goffice_0.1.0.bb21
-rw-r--r--packages/gnumeric/gnumeric_1.6.0.bb18
-rw-r--r--packages/libgsf/libgsf_1.13.2.bb17
-rw-r--r--packages/libopieobex/libopieobex0_1.2.1.bb1
-rw-r--r--packages/php/php-5.0.5/.mtn2git_empty0
-rw-r--r--packages/php/php-5.0.5/autotools.patch90
-rw-r--r--packages/php/php-5.0.5/endianness.patch10
-rw-r--r--packages/php/php_5.0.5.bb62
17 files changed, 409 insertions, 2 deletions
diff --git a/packages/appweb/appweb-2.0.4/.mtn2git_empty b/packages/appweb/appweb-2.0.4/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/appweb/appweb-2.0.4/.mtn2git_empty
diff --git a/packages/appweb/appweb-2.0.4/init.d.patch b/packages/appweb/appweb-2.0.4/init.d.patch
new file mode 100644
index 0000000000..d646b1f434
--- /dev/null
+++ b/packages/appweb/appweb-2.0.4/init.d.patch
@@ -0,0 +1,14 @@
+--- appWeb-2.0.4/appWeb/package/files/LINUX/appWeb.files~ 2005-10-10 22:16:58.000000000 -0700
++++ appWeb-2.0.4/appWeb/package/files/LINUX/appWeb.files 2005-10-10 22:16:43.000000000 -0700
+@@ -23,9 +23,9 @@
+ SrcD=${BLD_TOP}/${BLD_PRODUCT}/package/LINUX
+ if [ "${BLD_ROOT_PREFIX}" = "/" ]
+ then
+- DestD=/etc/rc.d
++ DestD=/etc
+ else
+- DestD=${BLD_ROOT_PREFIX}/etc/rc.d
++ DestD=${BLD_ROOT_PREFIX}/etc
+ fi
+
+ makeDir "${DestD}"
diff --git a/packages/appweb/appweb-2.0.4/makerules.patch b/packages/appweb/appweb-2.0.4/makerules.patch
new file mode 100644
index 0000000000..422154da17
--- /dev/null
+++ b/packages/appweb/appweb-2.0.4/makerules.patch
@@ -0,0 +1,30 @@
+--- appWeb-2.0.4/make.rules~ 2005-07-05 09:09:38.000000000 -0700
++++ appWeb-2.0.4/make.rules 2005-10-10 21:55:10.000000000 -0700
+@@ -61,25 +61,20 @@
+ for i in $$D "" ; \
+ do [ -z "$$i" ] && continue ;\
+ [ -d "$$i" ] || continue ;\
+- home=`pwd` ; \
+- cd "$$i" >/dev/null ; \
+- if [ -f Makefile ] ; then \
++ if [ -f $$i/Makefile ] ; then \
+ echo ; \
+- echo " cd $$i" ; \
+ set +e ; \
+ unset COMPILE_SHARED EXPORT_OBJECTS _LDPATH ; \
+ set -e ; \
+ echo -e "\n \# $(MAKE) $$T" ; \
+- $(MAKE) --no-print-directory -S $$T ; \
++ $(MAKE) -C $$i --no-print-directory -S $$T ; \
+ code=$$? ; \
+ if [ $$code != 0 ] ; then \
+ echo "\#WARNING: Makefile error in `pwd`" ; \
+ exit 255 ; \
+ fi ; \
+ echo ; \
+- echo " cd $$home" ; \
+ fi ; \
+- cd "$$home" >/dev/null ;\
+ done
+
+ DO_RECURSE=[ -z "$$D" ] || $(RECURSE)
diff --git a/packages/appweb/appweb_2.0.4.bb b/packages/appweb/appweb_2.0.4.bb
new file mode 100644
index 0000000000..a559b13ef3
--- /dev/null
+++ b/packages/appweb/appweb_2.0.4.bb
@@ -0,0 +1,117 @@
+DESCRIPTION = "AppWeb is an embedded HTTP Web server that has been designed with security in mind."
+SECTION = "console/network"
+LICENSE = "GPL"
+SRC_URI = "http://www.mbedthis.com/software/appWeb-src-${PV}-1.tar.gz \
+ file://makerules.patch;patch=1 \
+ file://init.d.patch;patch=1"
+S = "${WORKDIR}/appWeb-${PV}"
+
+APPWEB_HOST = "${@get_appweb_host(d, bb)}"
+APPWEB_BUILD = "${BUILD_SYS}"
+
+def get_appweb_host(d, bb):
+ host = bb.data.getVar('HOST_SYS', d, 1)
+ return host.replace('-linux-uclibc', '-linux')
+
+
+# --buildNumber=NUMBER Set the build number part of the version (1.0.0.X).
+# --name=NAME Set the full product name (BLD_NAME define).
+# --port=PORT Set the default HTTP port to use for the product.
+# --product=NAME Set the one word (no spaces) name of the product.
+# --setLibVersion=X.X.X Set the shared library version number.
+# --setVersion=X.X.X Set the product version number.
+# --sslPort=PORT Set the default SSL port to use for the product.
+# --type=BUILD Set the build type (DEBUG|RELEASE).
+#
+# --enable-access-log Enable logging of requests to the AppWeb access log.
+# --enable-assert Build with assert checking.
+# --enable-config Build with the ability to parse Apache-style config
+# --enable-cookie Build with cookie handling support.
+# --enable-digest-auth Build with digest authentication support.
+# --enable-fast-malloc Build with the Mbedthis fast malloc.
+# --enable-if-modified Build with HTTP If-Modified checking.
+# --enable-keep-alive Build with HTTP Keep-Alive support.
+# --enable-log Build with the AppWeb trace log facility.
+# --enable-modules Build with the dynamically loaded modules capability.
+# --enable-multi-thread Build AppWeb multi-threaded.
+# --disable-multi-thread Build AppWeb single threaded.
+# --enable-rom-fs Build with the ability to load web pages from ROM.
+# --enable-run-as-service Build with the ability to run as a service/daemon.
+# --disable-run-as-service Do not include the ability to run as a service.
+# --enable-safe-strings Enforce safe string handling.
+# --enable-session Build with HTTP session support.
+# --enable-shared Build an appWeb shared library and program. [default]
+# --enable-shared-libc Link with the shared versions of libc.
+# --disable-shared-libc Link with the static versions of libc.
+# --enable-squeeze Build in squeeze mode for minimal memory footprint.
+# --disable-squeeze Build for speed.
+# --enable-static Build a static appWeb library and program. [default]
+# --disable-static Do not build a static appWeb library and program.
+#
+# --with-admin Include the admin handler.
+# --with-auth Include the authorization handler.
+# --with-c_api Include the C API.
+# --with-cgi Include the CGI handler.
+# --with-gacompat Include GoAhead WebServer API compatibility.
+# --with-copy Build support for the copy handler.
+# --with-egi Include the EGI handler.
+# --with-esp Include the ESP handler.
+# --with-ssl Build support for the SSL protocol.
+# --with-upload Build with the file upload handler
+# --with-xdb Build with XDB
+# Supported PACKAGE names: openssl, php4, php5
+# --with-PACKAGE=[builtin|, module]
+# Include support for the PACKAGE. Link into appWeb
+# statically and/or build as a module
+# --with-PACKAGE-dir=DIR Set the source directory of the package
+# --with-PACKAGE-libs=libs Set a list of libraries to use when linking with
+# the PACKAGE
+# --without-PACKAGE Do not include support for the PACKAGE
+EXTRA_OECONF = "--prefix=${prefix} \
+ --docDir=${docdir}/${P} \
+ --incDir=${includedir} \
+ --libDir=${libdir} \
+ --sbinDir=${sbindir} \
+ --webDir=${localstatedir}/www \
+ --build=${APPWEB_BUILD} \
+ --host=${APPWEB_HOST} \
+ --enable-keep-alive \
+ --enable-multi-thread \
+ --with-cgi=builtin \
+ --enable-cookie \
+ --enable-config-parse \
+ --enable-config-save \
+ --enable-digest-auth \
+ --without-ssl"
+
+export IFLAGS = "${CPPFLAGS}"
+export CC_FOR_BUILD = "${BUILD_CC}"
+export LD_FOR_BUILD = "${BUILD_LD}"
+
+LD_LIBRARY_PATH_prepend = "${S}/lib:"
+LD_LIBRARY_PATH[export] = "1"
+do_configure () {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile () {
+ oe_runmake build
+ oe_runmake compile
+}
+
+do_stage () {
+ :
+}
+
+do_install () {
+ oe_runmake 'ROOT_DIR=${D}' install-all
+}
+
+#do_install () {
+# install -d ${D}${sbindir} ${D}${sysconfdir}/appWeb/lib \
+# ${D}${libexecdir}/appWeb ${D}${libdir}
+# install -m 0755 appWeb/appWeb ${D}${sbindir}/
+# install -m 0644 appWeb/appWeb.conf ${D}${sysconfdir}/appWeb/
+# install -m 0755 bin/${APPWEB_OS}/* ${D}${libexecdir}/appWeb/
+# install -m 0755 lib/lib*.so* ${D}${sysconfdir}/appWeb/lib/
+#}
diff --git a/packages/e17/e-wm_0.16.999.015.bb b/packages/e17/e-wm_0.16.999.015.bb
index 7a7291a156..c39b2ab9e1 100644
--- a/packages/e17/e-wm_0.16.999.015.bb
+++ b/packages/e17/e-wm_0.16.999.015.bb
@@ -36,6 +36,7 @@ FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir}"
do_compile_prepend() {
find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+ find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
mv "${WORKDIR}/themes/default_entry.edc" "${S}/data/themes/"
mv "${WORKDIR}/themes/images/focus.png" "${S}/data/themes/images/"
mv "${WORKDIR}/themes/images/entry.png" "${S}/data/themes/images/"
diff --git a/packages/geda/files/.mtn2git_empty b/packages/geda/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/geda/files/.mtn2git_empty
diff --git a/packages/geda/files/gEDA.desktop b/packages/geda/files/gEDA.desktop
new file mode 100644
index 0000000000..6f6f0c6e38
--- /dev/null
+++ b/packages/geda/files/gEDA.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=gEDA
+Comment=GPL suite of Electronic Design Automation tools
+Exec=geda
+Terminal=0
+Type=Application
+Icon=/usr/share/gEDA/bitmap/gschem-net.xpm
+Categories=Utility
diff --git a/packages/geda/geda-gsymcheck_20050820.bb b/packages/geda/geda-gsymcheck_20050820.bb
new file mode 100644
index 0000000000..aec9007906
--- /dev/null
+++ b/packages/geda/geda-gsymcheck_20050820.bb
@@ -0,0 +1,12 @@
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+PR = "r0"
+FILES_${PN} += "${datadir}/gEDA"
+
+DEPENDS = "gtk+ libgeda"
+
+SRC_URI = "http://www.geda.seul.org/devel/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
diff --git a/packages/geda/geda_20050820.bb b/packages/geda/geda_20050820.bb
index 65356724d5..84918d63b2 100644
--- a/packages/geda/geda_20050820.bb
+++ b/packages/geda/geda_20050820.bb
@@ -3,11 +3,17 @@ MAINTAINER = "Koen Kooi <koen@handhelds.org>"
LICENSE = "GPLv2"
HOMEPAGE = "http://geda.seul.org"
FILES_${PN} += "${datadir}/gEDA"
-PR ="r1"
+PR ="r2"
DEPENDS = "libgeda gtk+"
RRECOMMENDS = "geda-utils geda-gattrib geda-gnetlist geda-gschem geda-gsymcheck geda-symbols"
-SRC_URI = "http://www.geda.seul.org/devel/${PV}/${P}.tar.gz"
+SRC_URI = "http://www.geda.seul.org/devel/${PV}/${P}.tar.gz \
+ file://gEDA.desktop"
inherit autotools pkgconfig
+
+do_install_append() {
+install -d ${D}${datadir}/applications/
+install -m 644 ${WORKDIR}/gEDA.desktop ${D}${datadir}/applications/
+}
diff --git a/packages/gnome/goffice_0.1.0.bb b/packages/gnome/goffice_0.1.0.bb
new file mode 100644
index 0000000000..db26a617a5
--- /dev/null
+++ b/packages/gnome/goffice_0.1.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION="Gnome Office Library"
+LICENSE="GPLv2"
+PR="r0"
+
+DEPENDS="glib-2.0 gtk+ pango libgnomeprint libgsf libglade libxml2 libart-lgpl"
+
+inherit gnome pkgconfig
+
+
+
+do_stage() {
+ gnome_stage_includes
+ oe_libinstall -so -C goffice libgoffice-1 ${STAGING_LIBDIR}
+}
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+
diff --git a/packages/gnumeric/gnumeric_1.6.0.bb b/packages/gnumeric/gnumeric_1.6.0.bb
new file mode 100644
index 0000000000..3f19f36757
--- /dev/null
+++ b/packages/gnumeric/gnumeric_1.6.0.bb
@@ -0,0 +1,18 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+S = "${WORKDIR}/gnumeric-${PV}"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+DEPENDS = "libgsf gtk+ libxml2 goffice libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui libbonoboui"
+DESCRIPTION = "Gnumeric spreadsheet for GNOME"
+
+inherit gnome flow-lossage
+
+SRC_URI += "file://remove-docs.patch;patch=1"
+
+EXTRA_OECONF=" --without-perl "
+
+python populate_packages_prepend () {
+ gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
+
+ do_split_packages(d, gnumeric_libdir, '(.*)', 'gnumeric-plugin-%s', 'Gnumeric plugin for %s', allow_dirs=True)
+}
diff --git a/packages/libgsf/libgsf_1.13.2.bb b/packages/libgsf/libgsf_1.13.2.bb
new file mode 100644
index 0000000000..caeb4e4dc9
--- /dev/null
+++ b/packages/libgsf/libgsf_1.13.2.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+SECTION = "libs"
+PR = "r1"
+
+DEPENDS= "libxml2 glib-2.0 zlib gtk-doc libbonobo gnome-vfs"
+
+PACKAGES =+ "${PN}-gnome ${PN}-gnome-dev "
+
+FILES_${PN}-gnome = "${libdir}/libgsf-gnome-1.so.*"
+FILES_${PN}-gnome-dev = "${libdir}/libgsf-gnome-1.* ${includedir}/libgsf-1/gsf-gnome"
+
+inherit autotools pkgconfig gnome
+
+
+do_stage() {
+autotools_stage_all
+}
diff --git a/packages/libopieobex/libopieobex0_1.2.1.bb b/packages/libopieobex/libopieobex0_1.2.1.bb
index 2e6b38b848..d80a2a664f 100644
--- a/packages/libopieobex/libopieobex0_1.2.1.bb
+++ b/packages/libopieobex/libopieobex0_1.2.1.bb
@@ -1,4 +1,5 @@
include libopieobex0.inc
+
PR = "r1"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/obex \
diff --git a/packages/php/php-5.0.5/.mtn2git_empty b/packages/php/php-5.0.5/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/php/php-5.0.5/.mtn2git_empty
diff --git a/packages/php/php-5.0.5/autotools.patch b/packages/php/php-5.0.5/autotools.patch
new file mode 100644
index 0000000000..7e466a425e
--- /dev/null
+++ b/packages/php/php-5.0.5/autotools.patch
@@ -0,0 +1,90 @@
+diff -Nur php-5.0.5~/acinclude.m4 php-5.0.5/acinclude.m4
+--- php-5.0.5~/acinclude.m4 2005-10-10 19:56:46.000000000 -0700
++++ php-5.0.5/acinclude.m4 2005-10-10 19:56:55.000000000 -0700
+@@ -781,10 +781,10 @@
+ OVERALL_TARGET=[]ifelse($1,,php,$1)
+ php_c_pre='$(CC)'
+ php_c_meta='$(COMMON_FLAGS) $(CFLAGS_CLEAN) $(EXTRA_CFLAGS)'
+- php_c_post=' && echo > $[@]'
++ php_c_post=' && echo "[#] Generated by PHP badness - GNU libtool" > $[@] && echo "pic_object=none" >> $[@] && echo "non_pic_object=$[@]" | sed -e "s,=.*/,=,; s,\.lo,\.o,g" >> $[@]'
+ php_cxx_pre='$(CXX)'
+ php_cxx_meta='$(COMMON_FLAGS) $(CXXFLAGS_CLEAN) $(EXTRA_CXXFLAGS)'
+- php_cxx_post=' && echo > $[@]'
++ php_cxx_post=' && echo "[#] Generated by PHP badness - GNU libtool" > $[@] && echo "pic_object=none" >> $[@] && echo "non_pic_object=$[@]" | sed -e "s,=.*/,=,; s,\.lo,\.o,g" >> $[@]'
+ php_lo=o
+
+ case $with_pic in
+@@ -1531,6 +1531,7 @@
+
+ dnl even newer glibcs have a different seeker definition...
+
++ AC_CACHE_CHECK([if cookie io functions use off64_t], php_cv_lib_cookie_io_functions_use_off64_t,
+ AC_TRY_RUN([
+ #define _GNU_SOURCE
+ #include <stdio.h>
+@@ -1560,8 +1561,8 @@
+ }
+
+ ],
+- [ cookie_io_functions_use_off64_t=yes ],
+- [ ] )
++ [ php_cv_lib_cookie_io_functions_use_off64_t=yes ],
++ [ php_cv_lib_cookie_io_functions_use_off64_t=no ] ))
+
+ else
+ dnl older glibc versions (up to 2.1.2 ?)
+diff -Nur php-5.0.5~/configure.in php-5.0.5/configure.in
+--- php-5.0.5~/configure.in 2005-10-10 19:56:46.000000000 -0700
++++ php-5.0.5/configure.in 2005-10-10 19:56:55.000000000 -0700
+@@ -247,7 +247,7 @@
+ sinclude(Zend/acinclude.m4)
+ sinclude(Zend/Zend.m4)
+ sinclude(TSRM/tsrm.m4)
+-
++sinclude(TSRM/threads.m4)
+
+
+ divert(2)
+diff -Nur php-5.0.5~/scripts/phpize.m4 php-5.0.5/scripts/phpize.m4
+--- php-5.0.5~/scripts/phpize.m4 2005-10-10 19:56:46.000000000 -0700
++++ php-5.0.5/scripts/phpize.m4 2005-10-10 19:56:55.000000000 -0700
+@@ -1,7 +1,5 @@
+ dnl This file becomes configure.in for self-contained extensions.
+
+-AC_INIT(config.m4)
+-
+ PHP_INIT_BUILD_SYSTEM
+
+ AC_DEFUN([PHP_WITH_PHP_CONFIG],[
+@@ -55,8 +53,6 @@
+ PHP_PROG_RE2C
+ AC_PROG_AWK
+
+-sinclude(config.m4)
+-
+ enable_static=no
+ enable_shared=yes
+
+diff -Nur php-5.0.5~/TSRM/threads.m4 php-5.0.5/TSRM/threads.m4
+--- php-5.0.5~/TSRM/threads.m4 2005-10-10 19:56:40.000000000 -0700
++++ php-5.0.5/TSRM/threads.m4 2005-10-10 19:57:11.000000000 -0700
+@@ -86,7 +86,7 @@
+ pthreads_working=no
+ ], [
+ dnl For cross compiling running this test is of no use. NetWare supports pthreads
+- pthreads_working=no
++ pthreads_working=yes
+ case $host_alias in
+ *netware*)
+ pthreads_working=yes
+diff -Nur php-5.0.5~/TSRM/tsrm.m4 php-5.0.5/TSRM/tsrm.m4
+--- php-5.0.5~/TSRM/tsrm.m4 2005-10-10 19:56:40.000000000 -0700
++++ php-5.0.5/TSRM/tsrm.m4 2005-10-10 19:56:55.000000000 -0700
+@@ -68,7 +68,6 @@
+ ])
+
+ sinclude(threads.m4)
+-sinclude(TSRM/threads.m4)
+
+ AC_DEFUN([TSRM_CHECK_PTHREADS],[
+
diff --git a/packages/php/php-5.0.5/endianness.patch b/packages/php/php-5.0.5/endianness.patch
new file mode 100644
index 0000000000..0231727c33
--- /dev/null
+++ b/packages/php/php-5.0.5/endianness.patch
@@ -0,0 +1,10 @@
+--- php-5.0.5/Zend/zend_strtod.c~ 2005-10-10 19:58:06.000000000 -0700
++++ php-5.0.5/Zend/zend_strtod.c 2005-10-10 20:21:35.000000000 -0700
+@@ -130,6 +130,7 @@
+ * but the word order is big endian.
+ */
+ #define IEEE_BIG_ENDIAN
++#undef IEEE_LITTLE_ENDIAN
+ #endif
+
+ #ifdef __vax__
diff --git a/packages/php/php_5.0.5.bb b/packages/php/php_5.0.5.bb
new file mode 100644
index 0000000000..953f9c08e0
--- /dev/null
+++ b/packages/php/php_5.0.5.bb
@@ -0,0 +1,62 @@
+SECTION = "console/network"
+DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+LICENSE = "PHP"
+DEPENDS = "zlib libxml2 mysql"
+SRC_URI = "http://de3.php.net/distributions/php-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1 \
+ file://endianness.patch;patch=1"
+S = "${WORKDIR}/php-${PV}"
+
+# NOTE: You MUST remove --without-schemas from the libxml2 bb file (and recompile and reinstall it) to compile and use php5
+
+inherit autotools
+
+CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+EXTRA_OECONF = "--with-cgi --enable-sockets --enable-pcntl \
+ --with-mysql=${STAGING_LIBDIR}/.. \
+ --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
+ --without-libpng --without-libjpeg \
+ --with-config-file-path=${sysconfdir}/php5 \
+ --cache-file=config.cache \
+ --disable-debug \
+ --disable-rpath \
+ --enable-bcmath \
+ --enable-calendar \
+ --enable-maintainer-zts \
+ --enable-embed=shared \
+ --enable-force-cgi-redirect \
+ --enable-ftp \
+ --enable-inline-optimization \
+ --enable-magic-quotes \
+ --enable-memory-limit \
+ --enable-pic \
+ --enable-safe-mode \
+ --enable-sockets \
+ --enable-track-vars \
+ --enable-trans-sid \
+ --enable-wddx \
+ --sysconfdir=/etc/appWeb \
+ --with-exec-dir=/etc/appWeb/exec \
+ --with-db \
+ --with-regex=system \
+ --with-pear \
+ --with-xml \
+ --with-xmlrpc \
+ --with-zlib \
+ --without-iconv"
+
+EXTRA_OECONF += " --without-pear"
+# Uncomment the following two lines, and comment the above to enable PEAR
+#EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR}/php"
+#DEPENDS += " php-native"
+
+acpaths = ""
+
+do_configure_prepend() {
+ find ${S} -type f | xargs sed -i 's:/usr/lib:${STAGING_LIBDIR}:'
+}
+
+do_install () {
+ oe_runmake 'INSTALL_ROOT=${D}' install
+}