aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-17 00:39:39 +0000
committerChris Larson <clarson@kergoth.com>2004-12-17 00:39:39 +0000
commit24321190ac707cbe3a4ff3a0b93356ba0b3d019f (patch)
tree8b70d97522cbb4b02cd2e201311189f258f1d273 /packages
parent5487ae98510f37b0813e9d501fb9314c28ca3abc (diff)
downloadopenembedded-24321190ac707cbe3a4ff3a0b93356ba0b3d019f.tar.gz
Fix meta-e-x11 to DEPENDS on virtual/libiconv, not libiconv, so world builds stop getting screwed up by libiconv overwriting the c library's iconv headers.
BKrev: 41c22acbee71PrHVdYVasCQDVsqVsA
Diffstat (limited to 'packages')
-rw-r--r--packages/meta/meta-e-x11.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/meta/meta-e-x11.bb b/packages/meta/meta-e-x11.bb
index e69de29bb2..e6685ab007 100644
--- a/packages/meta/meta-e-x11.bb
+++ b/packages/meta/meta-e-x11.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Meta-package for Enlightenment X11 Without FrameBuffer"
+MAINTAINER = "That Crazy fool emte <emte@labotomy.net>"
+PACKAGES = "e e-libs e-base"
+
+FEED_URIS += "x11##http://openzaurus.org/official/unstable/3.5.2/feed/x11 \
+ e##http://openzaurus.org/official/unstable/3.5.2/feed/e"
+
+ALLOW_EMPTY = 1
+
+# task-e-libs = "virtual/libiconv imlib2 edb eet evas ecore epeg epsilon embryo edje esmart emotion etox ewl"
+# epsilon is currently broke for cross compiling without a patch, raster is looking at it
+
+task-e-libs = "virtual/libiconv imlib2 edb eet evas ecore epeg embryo edje esmart emotion etox ewl"
+
+task-e-base = ""
+
+RDEPENDS_e-libs = "${task-e-libs}"
+DEPENDS += "${task-e-libs}"
+
+RDEPENDS_e-base = "${task-e-base}"
+DEPENDS += "${task-e-base}"