aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/abiword/abiword_2.8.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-30 10:27:27 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-30 10:27:27 +0100
commit5da5ee1a5708f9a30c61636f29548acd3a4ae02c (patch)
tree2f2b3aaac843254321a65a210494c7c728ba6d05 /recipes/abiword/abiword_2.8.1.bb
parentb2010b603e066e5a39667a83f4675c59ddf2efd8 (diff)
downloadopenembedded-5da5ee1a5708f9a30c61636f29548acd3a4ae02c.tar.gz
openembedded-5da5ee1a5708f9a30c61636f29548acd3a4ae02c.tar.bz2
openembedded-5da5ee1a5708f9a30c61636f29548acd3a4ae02c.zip
abiword: replace 2.8.0 with 2.8.1, some crashes fixed and libtool macros updated
Diffstat (limited to 'recipes/abiword/abiword_2.8.1.bb')
-rw-r--r--recipes/abiword/abiword_2.8.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/abiword/abiword_2.8.1.bb b/recipes/abiword/abiword_2.8.1.bb
new file mode 100644
index 0000000000..24e20a4e55
--- /dev/null
+++ b/recipes/abiword/abiword_2.8.1.bb
@@ -0,0 +1,46 @@
+require abiword-2.5.inc
+
+SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+
+do_configure() {
+ autotools_do_configure
+}
+
+EXTRA_OECONF = " --disable-static \
+ --enable-plugins \
+ --enable-collab-backend-xmpp \
+ --enable-collab-backend-tcp \
+ --enable-collab-backend-service \
+"
+
+RCONFLICTS = "abiword-embedded"
+
+FILES_${PN} += "${datadir}/mime-info ${datadir}/abiword-${SHRT_VER}/ui ${datadir}/abiword-${SHRT_VER}/xsl* ${datadir}/abiword-${SHRT_VER}/mime-info ${datadir}/abiword-${SHRT_VER}/Pr*.xml"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+
+PACKAGES_DYNAMIC = "abiword-meta abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
+ do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+
+ metapkg = "abiword-meta"
+ bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
+ bb.data.setVar('FILES_' + metapkg, "", d)
+ blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
+ metapkg_rdepends = []
+ packages = bb.data.getVar('PACKAGES', d, 1).split()
+ for pkg in packages[1:]:
+ if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
+ print "Modifying ", pkg
+ metapkg_rdepends.append(pkg)
+ bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
+ bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
+ packages.append(metapkg)
+ bb.data.setVar('PACKAGES', ' '.join(packages), d)
+}
+
+FILES_${PN}-dev += "${libdir}/abiword-${SHRT_VER}/plugins/*.la"
+FILES_${PN}-dbg += "${libdir}/abiword-${SHRT_VER}/plugins/.debug"
+