aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/abiword
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-29 14:06:54 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-29 14:11:16 +0100
commitd6f6d5222f7b0f7d130909bea546ca1108511d14 (patch)
treeb72e205c5d054170ab9cce8c2a2f1a8f51dec969 /recipes/abiword
parenteac32cefd91a4b494d457e55e362120f1cbebe91 (diff)
downloadopenembedded-d6f6d5222f7b0f7d130909bea546ca1108511d14.tar.gz
abiword: add 2.8.0
Diffstat (limited to 'recipes/abiword')
-rw-r--r--recipes/abiword/abiword-2.5.inc4
-rw-r--r--recipes/abiword/abiword_2.8.0.bb46
2 files changed, 48 insertions, 2 deletions
diff --git a/recipes/abiword/abiword-2.5.inc b/recipes/abiword/abiword-2.5.inc
index 09f61d0534..b577770513 100644
--- a/recipes/abiword/abiword-2.5.inc
+++ b/recipes/abiword/abiword-2.5.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) W
HOMEPAGE = "http://www.abiword.org""
SECTION = "x11/office"
LICENSE = "GPLv2"
-DEPENDS = "perl-native wv libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng libxml2"
+DEPENDS = "asio goffice perl-native wv libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng libxml2"
RDEPENDS = "enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
@@ -29,7 +29,7 @@ FILES_${PN} += " \
${datadir}/abiword-${SHRT_VER}/templates/Memo.awt \
${datadir}/abiword-${SHRT_VER}/templates/Press-Release.awt "
-inherit autotools pkgconfig
+inherit autotools gtk-icon-cache pkgconfig mime
PARALLEL_MAKE = ""
diff --git a/recipes/abiword/abiword_2.8.0.bb b/recipes/abiword/abiword_2.8.0.bb
new file mode 100644
index 0000000000..24e20a4e55
--- /dev/null
+++ b/recipes/abiword/abiword_2.8.0.bb
@@ -0,0 +1,46 @@
+require abiword-2.5.inc
+
+SRC_URI = "http://www.abisource.com/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+
+do_configure() {
+ autotools_do_configure
+}
+
+EXTRA_OECONF = " --disable-static \
+ --enable-plugins \
+ --enable-collab-backend-xmpp \
+ --enable-collab-backend-tcp \
+ --enable-collab-backend-service \
+"
+
+RCONFLICTS = "abiword-embedded"
+
+FILES_${PN} += "${datadir}/mime-info ${datadir}/abiword-${SHRT_VER}/ui ${datadir}/abiword-${SHRT_VER}/xsl* ${datadir}/abiword-${SHRT_VER}/mime-info ${datadir}/abiword-${SHRT_VER}/Pr*.xml"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+
+PACKAGES_DYNAMIC = "abiword-meta abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
+ do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+
+ metapkg = "abiword-meta"
+ bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
+ bb.data.setVar('FILES_' + metapkg, "", d)
+ blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
+ metapkg_rdepends = []
+ packages = bb.data.getVar('PACKAGES', d, 1).split()
+ for pkg in packages[1:]:
+ if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
+ print "Modifying ", pkg
+ metapkg_rdepends.append(pkg)
+ bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
+ bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
+ packages.append(metapkg)
+ bb.data.setVar('PACKAGES', ' '.join(packages), d)
+}
+
+FILES_${PN}-dev += "${libdir}/abiword-${SHRT_VER}/plugins/*.la"
+FILES_${PN}-dbg += "${libdir}/abiword-${SHRT_VER}/plugins/.debug"
+