aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/abiword
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/abiword
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/abiword')
-rw-r--r--recipes/abiword/abiword-2.5.inc61
-rw-r--r--recipes/abiword/abiword-embedded_2.4.6.bb12
-rw-r--r--recipes/abiword/abiword-embedded_2.5.2.bb10
-rw-r--r--recipes/abiword/abiword-embedded_2.6.4.bb8
-rw-r--r--recipes/abiword/abiword-plugins_2.4.6.bb27
-rw-r--r--recipes/abiword/abiword-plugins_2.5.1.bb40
-rw-r--r--recipes/abiword/abiword-plugins_2.5.2.bb41
-rw-r--r--recipes/abiword/abiword-plugins_2.6.0.bb44
-rw-r--r--recipes/abiword/abiword-plugins_2.6.4.bb62
-rw-r--r--recipes/abiword/abiword.inc49
-rw-r--r--recipes/abiword/abiword_2.4.6.bb4
-rw-r--r--recipes/abiword/abiword_2.5.1.bb7
-rw-r--r--recipes/abiword/abiword_2.5.2.bb7
-rw-r--r--recipes/abiword/abiword_2.6.0.bb3
-rw-r--r--recipes/abiword/abiword_2.6.3.bb10
-rw-r--r--recipes/abiword/abiword_2.6.4.bb10
-rw-r--r--recipes/abiword/files/abiword-cxx-for-ld-fix.patch12
-rw-r--r--recipes/abiword/files/abiword-plugin-pdf-poppler.patch11
-rwxr-xr-xrecipes/abiword/files/cdump.pl32
19 files changed, 450 insertions, 0 deletions
diff --git a/recipes/abiword/abiword-2.5.inc b/recipes/abiword/abiword-2.5.inc
new file mode 100644
index 0000000000..09f61d0534
--- /dev/null
+++ b/recipes/abiword/abiword-2.5.inc
@@ -0,0 +1,61 @@
+DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org""
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "perl-native wv libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng libxml2"
+RDEPENDS = "enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+
+#want 2.x from 2.x.y for the installation directory
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+FILES_${PN} += " \
+ ${datadir}/icons/* \
+ ${datadir}/abiword-${SHRT_VER}/glade \
+ ${datadir}/abiword-${SHRT_VER}/scripts \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en_GB \
+# ${datadir}/abiword-${SHRT_VER}/templates/A4.awt \
+# ${datadir}/abiword-${SHRT_VER}/templates/US-Letter.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
+ ${datadir}/abiword-${SHRT_VER}/templates/Employee-Directory.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Business-Report.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Fax-Coversheet.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Resume.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Two-Columns.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Memo.awt \
+ ${datadir}/abiword-${SHRT_VER}/templates/Press-Release.awt "
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = " --disable-pspell \
+ --enable-enchant \
+ --with-sys-wv"
+
+# AbiWord configure.ac does not play nicely with autoreconf
+# so use the autogen.sh script that comes with AbiWord
+#
+do_configure() {
+ cd ${S}
+ export NOCONFIGURE="no"; ./autogen.sh
+ oe_runconf
+}
+
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates "
+
+FILES_abiword-clipart += "${datadir}/abiword-${SHRT_VER}/clipart"
+FILES_abiword-icons += "${datadir}/abiword-${SHRT_VER}/icons"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/AbiWord/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/AbiWord/system.profile*"
+FILES_abiword-templates += "${datadir}/abiword-${SHRT_VER}/templates"
diff --git a/recipes/abiword/abiword-embedded_2.4.6.bb b/recipes/abiword/abiword-embedded_2.4.6.bb
new file mode 100644
index 0000000000..9381bbd8a7
--- /dev/null
+++ b/recipes/abiword/abiword-embedded_2.4.6.bb
@@ -0,0 +1,12 @@
+require abiword.inc
+
+EXTRA_OECONF += "--enable-embedded"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
+
+do_compile_prepend() {
+ cp ${S}/src/af/xap/unix/hildon/xap_EmbeddedFeatures.h ${S}/src/af/xap/unix/
+ cp ${S}/src/wp/ap/unix/hildon/ap_EmbeddedFeatures.h ${S}/src/wp/ap/unix/
+}
+
diff --git a/recipes/abiword/abiword-embedded_2.5.2.bb b/recipes/abiword/abiword-embedded_2.5.2.bb
new file mode 100644
index 0000000000..47cf9e03c0
--- /dev/null
+++ b/recipes/abiword/abiword-embedded_2.5.2.bb
@@ -0,0 +1,10 @@
+require abiword-2.5.inc
+
+EXTRA_OECONF += "--enable-embedded"
+
+S = "${WORKDIR}/abiword-${PV}"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
+
+
diff --git a/recipes/abiword/abiword-embedded_2.6.4.bb b/recipes/abiword/abiword-embedded_2.6.4.bb
new file mode 100644
index 0000000000..98e69515fa
--- /dev/null
+++ b/recipes/abiword/abiword-embedded_2.6.4.bb
@@ -0,0 +1,8 @@
+require abiword-2.5.inc
+
+EXTRA_OECONF += "--enable-embedded"
+
+S = "${WORKDIR}/abiword-${PV}"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
diff --git a/recipes/abiword/abiword-plugins_2.4.6.bb b/recipes/abiword/abiword-plugins_2.4.6.bb
new file mode 100644
index 0000000000..41652828bf
--- /dev/null
+++ b/recipes/abiword/abiword-plugins_2.4.6.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word""
+HOMEPAGE = "http://www.abiword.org""
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "libwpd librsvg goffice poppler"
+RDEPENDS = "abiword"
+
+PR = "r1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-plugin-pdf-poppler.patch;patch=1;pnum=2"
+S = "${WORKDIR}/abiword-${PV}/abiword-plugins"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--without-libwmf --without-inter7eps"
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.4/plugins', d)
+
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+}
+
diff --git a/recipes/abiword/abiword-plugins_2.5.1.bb b/recipes/abiword/abiword-plugins_2.5.1.bb
new file mode 100644
index 0000000000..eb626aba91
--- /dev/null
+++ b/recipes/abiword/abiword-plugins_2.5.1.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+ http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ "
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = " --without-libwmf \
+ --without-inter7eps \
+ --with-abiword=${WORKDIR}/abiword-${PV} \
+ "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.5/plugins', d)
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.5/plugins/.debug"
+
diff --git a/recipes/abiword/abiword-plugins_2.5.2.bb b/recipes/abiword/abiword-plugins_2.5.2.bb
new file mode 100644
index 0000000000..89a0527401
--- /dev/null
+++ b/recipes/abiword/abiword-plugins_2.5.2.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "boost loudmouth libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+PR = "r1"
+
+DEFAULT_PREFERENCE = "1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+ http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ "
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = " --without-libwmf \
+ --without-inter7eps \
+ --with-abiword=${WORKDIR}/abiword-${PV} \
+ --with-boost=${STAGING_INCDIR}/../ \
+ "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.5/plugins', d)
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.5/plugins/.debug"
+
diff --git a/recipes/abiword/abiword-plugins_2.6.0.bb b/recipes/abiword/abiword-plugins_2.6.0.bb
new file mode 100644
index 0000000000..f6cdcc56b0
--- /dev/null
+++ b/recipes/abiword/abiword-plugins_2.6.0.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "boost loudmouth libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+ http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-cxx-for-ld-fix.patch;patch=1 \
+ "
+
+DEFAULT_PREFERENCE = "2"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+# Ugly hack to find libstdc++
+export LD="${CXX}"
+
+EXTRA_OECONF = " --without-libwmf \
+ --without-inter7eps \
+ --with-abiword=${WORKDIR}/abiword-${PV} \
+ --with-boost=${STAGING_DIR_HOST} \
+ --with-boost-thread=boost_thread-mt \
+ "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.6/plugins', d)
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.6/plugins/.debug"
+
diff --git a/recipes/abiword/abiword-plugins_2.6.4.bb b/recipes/abiword/abiword-plugins_2.6.4.bb
new file mode 100644
index 0000000000..31ed978abe
--- /dev/null
+++ b/recipes/abiword/abiword-plugins_2.6.4.bb
@@ -0,0 +1,62 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "asio boost loudmouth libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+PR = "r1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+ http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+# file://abiword-cxx-for-ld-fix.patch;patch=1 \
+ "
+
+DEFAULT_PREFERENCE = "2"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+#export LDFLAGS += " -lstdc++ "
+
+EXTRA_OECONF = " --enable-shared=yes \
+ --enable-static \
+ --without-libwmf \
+ --without-inter7eps \
+ --with-abiword=${WORKDIR}/abiword-${PV} \
+ --with-boost=${STAGING_DIR_HOST} \
+ --with-boost-thread=boost_thread-mt \
+ "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.6/plugins', d)
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+
+ metapkg = "abiword-plugins"
+ bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
+ bb.data.setVar('FILES_' + metapkg, "", d)
+ blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
+ metapkg_rdepends = []
+ packages = bb.data.getVar('PACKAGES', d, 1).split()
+ for pkg in packages[1:]:
+ if not pkg in blacklist and not pkg in metapkg_rdepends:
+ print "Modifying ", pkg
+ metapkg_rdepends.append(pkg)
+ bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
+ bb.data.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package', d)
+ packages.append(metapkg)
+ bb.data.setVar('PACKAGES', ' '.join(packages), d)
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.6/plugins/.debug"
+
diff --git a/recipes/abiword/abiword.inc b/recipes/abiword/abiword.inc
new file mode 100644
index 0000000000..58f712aca9
--- /dev/null
+++ b/recipes/abiword/abiword.inc
@@ -0,0 +1,49 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org""
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "perl-native libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng libxml2"
+RDEPENDS = "enchant "
+RDEPENDS_linux += "glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+PR = "r2"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+S = "${WORKDIR}/abiword-${PV}/abi"
+
+FILES_${PN} += " \
+ ${datadir}/icons/* \
+ ${datadir}/AbiSuite-2.4/AbiWord/glade \
+ ${datadir}/AbiSuite-2.4/AbiWord/scripts \
+ ${datadir}/AbiSuite-2.4/AbiWord/system.profile-en \
+ ${datadir}/AbiSuite-2.4/AbiWord/system.profile-en_GB \
+# ${datadir}/AbiSuite-2.4/templates/A4.awt \
+# ${datadir}/AbiSuite-2.4/templates/US-Letter.awt \
+ ${datadir}/AbiSuite-2.4/templates/normal.awt \
+ ${datadir}/AbiSuite-2.4/templates/normal.awt-en_GB \
+ ${datadir}/AbiSuite-2.4/templates/Employee-Directory.awt \
+ ${datadir}/AbiSuite-2.4/templates/Business-Report.awt \
+ ${datadir}/AbiSuite-2.4/templates/Fax-Coversheet.awt \
+ ${datadir}/AbiSuite-2.4/templates/Resume.awt \
+ ${datadir}/AbiSuite-2.4/templates/Two-Columns.awt \
+ ${datadir}/AbiSuite-2.4/templates/Memo.awt \
+ ${datadir}/AbiSuite-2.4/templates/Press-Release.awt "
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = "--disable-pspell --enable-enchant"
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates "
+
+FILES_abiword-clipart += "${datadir}/AbiSuite-2.4/clipart"
+FILES_abiword-icons += "${datadir}/AbiSuite-2.4/icons"
+FILES_abiword-strings += "${datadir}/AbiSuite-2.4/AbiWord/strings"
+FILES_abiword-systemprofiles += "${datadir}/AbiSuite-2.4/AbiWord/system.profile*"
+FILES_abiword-templates += "${datadir}/AbiSuite-2.4/templates"
diff --git a/recipes/abiword/abiword_2.4.6.bb b/recipes/abiword/abiword_2.4.6.bb
new file mode 100644
index 0000000000..b97556b735
--- /dev/null
+++ b/recipes/abiword/abiword_2.4.6.bb
@@ -0,0 +1,4 @@
+require abiword.inc
+
+RCONFLICTS = "abiword-embedded"
+
diff --git a/recipes/abiword/abiword_2.5.1.bb b/recipes/abiword/abiword_2.5.1.bb
new file mode 100644
index 0000000000..9741ad6413
--- /dev/null
+++ b/recipes/abiword/abiword_2.5.1.bb
@@ -0,0 +1,7 @@
+require abiword-2.5.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PR = "r2"
+
+RCONFLICTS = "abiword-embedded"
diff --git a/recipes/abiword/abiword_2.5.2.bb b/recipes/abiword/abiword_2.5.2.bb
new file mode 100644
index 0000000000..5fcc1dd1a2
--- /dev/null
+++ b/recipes/abiword/abiword_2.5.2.bb
@@ -0,0 +1,7 @@
+require abiword-2.5.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+PR = "r1"
+
+RCONFLICTS = "abiword-embedded"
diff --git a/recipes/abiword/abiword_2.6.0.bb b/recipes/abiword/abiword_2.6.0.bb
new file mode 100644
index 0000000000..e2db4a09cb
--- /dev/null
+++ b/recipes/abiword/abiword_2.6.0.bb
@@ -0,0 +1,3 @@
+require abiword-2.5.inc
+
+RCONFLICTS = "abiword-embedded"
diff --git a/recipes/abiword/abiword_2.6.3.bb b/recipes/abiword/abiword_2.6.3.bb
new file mode 100644
index 0000000000..fe6399226f
--- /dev/null
+++ b/recipes/abiword/abiword_2.6.3.bb
@@ -0,0 +1,10 @@
+require abiword-2.5.inc
+
+PR = "r1"
+
+RCONFLICTS = "abiword-embedded"
+
+FILES_${PN} += "${datadir}/mime-info"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+
diff --git a/recipes/abiword/abiword_2.6.4.bb b/recipes/abiword/abiword_2.6.4.bb
new file mode 100644
index 0000000000..0dd2602571
--- /dev/null
+++ b/recipes/abiword/abiword_2.6.4.bb
@@ -0,0 +1,10 @@
+require abiword-2.5.inc
+
+PR = "r2"
+
+RCONFLICTS = "abiword-embedded"
+
+FILES_${PN} += "${datadir}/mime-info"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+
diff --git a/recipes/abiword/files/abiword-cxx-for-ld-fix.patch b/recipes/abiword/files/abiword-cxx-for-ld-fix.patch
new file mode 100644
index 0000000000..e49b1e92e5
--- /dev/null
+++ b/recipes/abiword/files/abiword-cxx-for-ld-fix.patch
@@ -0,0 +1,12 @@
+libstc++ isn't in staging anymore, so we must use g++ for linking
+
+--- /tmp/configure.ac 2008-03-31 11:39:13.130631737 +0200
++++ abiword-plugins-2.6.0/configure.ac 2008-03-31 11:39:22.754586487 +0200
+@@ -14,6 +14,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
++AC_LANG_CPLUSPLUS
+
+ AM_INIT_AUTOMAKE
+
diff --git a/recipes/abiword/files/abiword-plugin-pdf-poppler.patch b/recipes/abiword/files/abiword-plugin-pdf-poppler.patch
new file mode 100644
index 0000000000..c8ef3256b8
--- /dev/null
+++ b/recipes/abiword/files/abiword-plugin-pdf-poppler.patch
@@ -0,0 +1,11 @@
+--- abiword-2.4.4/abiword-plugins/wp/impexp/pdf/xp/ie_imp_PDF.cpp.orig 2006-04-17 11:36:05.000000000 +0100
++++ abiword-2.4.4/abiword-plugins/wp/impexp/pdf/xp/ie_imp_PDF.cpp 2006-04-17 11:37:00.000000000 +0100
+@@ -75,7 +75,7 @@
+ UT_tmpnam(temporary_file);
+
+ TextOutputDev *textOut = new TextOutputDev(temporary_file, gFalse, gFalse, gFalse);
+- doc->displayPages(textOut, 1, doc->getNumPages(), 72, 72, 0, gTrue, gFalse);
++ doc->displayPages(textOut, 1, doc->getNumPages(), 72, 72, 0, gFalse, gTrue, gFalse);
+ delete textOut;
+
+ IE_Imp_Text txt_imp(getDoc(), "UTF-8");
diff --git a/recipes/abiword/files/cdump.pl b/recipes/abiword/files/cdump.pl
new file mode 100755
index 0000000000..76f9c8841b
--- /dev/null
+++ b/recipes/abiword/files/cdump.pl
@@ -0,0 +1,32 @@
+#!/usr/bin/perl
+
+# This script replace the cdump tool we used to build the ap_wp_Splash.cpp
+# Because the cdump tool has to be run as a part of building the AW package,
+# it breaks cross-compilation. A perl script seemed like a generic solution
+
+
+if ($#ARGV != 1 )
+{
+ print "Usage: $0 datafile arrayname $#ARGV $ARGV[0] $ARGV[1]\n";
+ exit(-1);
+}
+
+open FROM, "<$ARGV[0]" or die "Could not open file $ARGV[0]";
+binmode FROM;
+
+print "unsigned char $ARGV[1] [] = {\n";
+
+while ($len = read(FROM, $buf, 16))
+{
+ foreach(split(//,$buf))
+ {
+ printf("0x%02x,", ord($_));
+ }
+
+ print "\n";
+}
+
+
+printf "};\nunsigned long $ARGV[1]_sizeof = sizeof($ARGV[1]);\n";
+
+close FROM; \ No newline at end of file