aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aceofpenguins
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 08:35:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:05 +0100
commit7412e6f91e73982a0a8ae90476e71bcbda513391 (patch)
treeba3311c6fde5cc16d2b3e934c10b9b3248a29c5b /recipes/aceofpenguins
parenta3779a461c13c349cc4f29da4e5b6a713f0f0879 (diff)
downloadopenembedded-7412e6f91e73982a0a8ae90476e71bcbda513391.tar.gz
aceofpenguins: new recipe from SHR
Diffstat (limited to 'recipes/aceofpenguins')
-rw-r--r--recipes/aceofpenguins/aceofpenguins-launcher_0.3.bb21
-rw-r--r--recipes/aceofpenguins/aceofpenguins_1.2.bb18
-rw-r--r--recipes/aceofpenguins/files/gcc4.patch23
3 files changed, 62 insertions, 0 deletions
diff --git a/recipes/aceofpenguins/aceofpenguins-launcher_0.3.bb b/recipes/aceofpenguins/aceofpenguins-launcher_0.3.bb
new file mode 100644
index 0000000000..265b8c6651
--- /dev/null
+++ b/recipes/aceofpenguins/aceofpenguins-launcher_0.3.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "EFL launcher for ace-of-penguins"
+HOMEPAGE = "http://shr-project.org"
+SHR_RELEASE ?= "shr"
+LICENSE ?= "GPL"
+DEPENDS = "python-native python-elementary"
+RDEPENDS = "aceofpenguins"
+SECTION = "x11/application"
+
+PACKAGE_ARCH = "all"
+
+PR = "r0"
+
+inherit setuptools
+
+SRC_URI = "http://downloads.vdm-design.de/aceofpenguins-launcher-${PV}.tar.gz"
+
+S = "${WORKDIR}/aceofpenguins-launcher"
+
+FILES_${PN} += "${prefix}/share/pixmaps"
+FILES_${PN} += "${prefix}/share/applications"
+
diff --git a/recipes/aceofpenguins/aceofpenguins_1.2.bb b/recipes/aceofpenguins/aceofpenguins_1.2.bb
new file mode 100644
index 0000000000..9410eb9653
--- /dev/null
+++ b/recipes/aceofpenguins/aceofpenguins_1.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "The Ace of Penguins is a set of Unix/X solitaire games based on the ones available for Windows(tm) but with a number of enhancements that my wife says make my versions better :-) \
+The latest version includes clones of freecell, golf, mastermind, merlin, minesweeper, pegged, solitaire, taipei (with editor!), and thornq (by Martin Thornquist)."
+AUTHOR = "dj@delorie.com"
+HOMEPAGE = "http://www.delorie.com/store/ace/"
+SECTION = "games"
+DEPENDS = "libpng zlib libxpm"
+PR = "r1"
+
+SRC_URI = "\
+ http://www.delorie.com/store/ace/ace-${PV}.tar.gz\
+ file://gcc4.patch;patch=1\
+"
+S = "${WORKDIR}/ace-${PV}"
+
+inherit autotools
+
+# Workaround QA issue
+TARGET_CC_ARCH += "${LDFLAGS}" \ No newline at end of file
diff --git a/recipes/aceofpenguins/files/gcc4.patch b/recipes/aceofpenguins/files/gcc4.patch
new file mode 100644
index 0000000000..431c44e933
--- /dev/null
+++ b/recipes/aceofpenguins/files/gcc4.patch
@@ -0,0 +1,23 @@
+--- ace-of-penguins-1.2.orig/games/golf.c
++++ ace-of-penguins-1.2/games/golf.c
+@@ -31,7 +31,7 @@
+
+ Stack *deck, *discard, *stacks[7];
+
+-static int table_width, table_height;
++int table_width, table_height;
+
+ int supress_arrows = 0;
+
+--- ace-of-penguins-1.2.orig/games/solitaire.c
++++ ace-of-penguins-1.2/games/solitaire.c
+@@ -337,7 +337,7 @@
+ return something_moved;
+ }
+
+-static void
++void
+ check_for_end_of_game()
+ {
+ while (auto_move());
+