aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aceofpenguins
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2010-02-18 10:40:10 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-18 14:34:14 +0100
commitb4c79ba094920454ded4a068df538bb526edaa25 (patch)
tree920b0f53cca3ca1b2b689ac62a182995161aeec6 /recipes/aceofpenguins
parent357e89f526a8b50f71e9cc815d4eeee8b78cb8d3 (diff)
downloadopenembedded-b4c79ba094920454ded4a068df538bb526edaa25.tar.gz
aceofpenguins: fix crosscompilation
* libpng and zlib from buildhost were used * now builds with libpng-native and zlib-native Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/aceofpenguins')
-rw-r--r--recipes/aceofpenguins/aceofpenguins_1.2.bb11
-rw-r--r--recipes/aceofpenguins/files/fix-crosscompile.patch13
2 files changed, 21 insertions, 3 deletions
diff --git a/recipes/aceofpenguins/aceofpenguins_1.2.bb b/recipes/aceofpenguins/aceofpenguins_1.2.bb
index 9410eb9653..c4b98e4fb0 100644
--- a/recipes/aceofpenguins/aceofpenguins_1.2.bb
+++ b/recipes/aceofpenguins/aceofpenguins_1.2.bb
@@ -3,16 +3,21 @@ The latest version includes clones of freecell, golf, mastermind, merlin, minesw
AUTHOR = "dj@delorie.com"
HOMEPAGE = "http://www.delorie.com/store/ace/"
SECTION = "games"
-DEPENDS = "libpng zlib libxpm"
-PR = "r1"
+DEPENDS = "libpng-native zlib-native libxpm"
+PR = "r2"
SRC_URI = "\
http://www.delorie.com/store/ace/ace-${PV}.tar.gz\
file://gcc4.patch;patch=1\
+ file://fix-crosscompile.patch;patch=1\
"
S = "${WORKDIR}/ace-${PV}"
inherit autotools
+do_compile_prepend() {
+ export LD_LIBRARY_PATH="${STAGING_NATIVE_DIR}"
+}
+
# Workaround QA issue
-TARGET_CC_ARCH += "${LDFLAGS}" \ No newline at end of file
+TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/recipes/aceofpenguins/files/fix-crosscompile.patch b/recipes/aceofpenguins/files/fix-crosscompile.patch
new file mode 100644
index 0000000000..ff3ac0ffa8
--- /dev/null
+++ b/recipes/aceofpenguins/files/fix-crosscompile.patch
@@ -0,0 +1,13 @@
+diff -Nurd ace-1.2/lib/Makefile.am ace-1.2.new//lib/Makefile.am
+--- ace-1.2/lib/Makefile.am 2010-02-18 12:21:30.000000000 +0100
++++ ace-1.2.new//lib/Makefile.am 2010-02-18 12:21:30.000000000 +0100
+@@ -22,7 +22,7 @@
+ ./make-imglib -n cards -i $(srcdir)/png -d images.d $(srcdir)/images.in images.c
+
+ make-imglib : make-imglib.c
+- $(BUILD_CC) $(srcdir)/make-imglib.c -o make-imglib -lpng -lz
++ $(BUILD_CC) $(srcdir)/make-imglib.c -o make-imglib $(BUILD_CFLAGS) $(BUILD_LDFLAGS) -lpng -lz
+
+ text2c : text2c.c
+- $(BUILD_CC) $(srcdir)/text2c.c -o text2c -lpng -lz
++ $(BUILD_CC) $(srcdir)/text2c.c -o text2c $(BUILD_CFLAGS) $(BUILD_LDFLAGS) -lpng -lz