summaryrefslogtreecommitdiffstats
path: root/recipes/agg
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-10-18 15:36:32 +0200
committerLeon Woestenberg <leon@sidebranch.com>2009-10-18 21:08:42 +0200
commitabe88d6b39d4ce0201964d7d54d8090233b2cc5d (patch)
treea817cbaf7d6748881e41df3aa8ec35f5c19e72f8 /recipes/agg
parent213bf9c00e99b81df64d302932944bdbc6f9ed65 (diff)
downloadopenembedded-abe88d6b39d4ce0201964d7d54d8090233b2cc5d.tar.gz
agg-2.5: Fix typoin CFLAGS. Provide X paths to configure.
There is a typo in the CFLAGS. Additionally a fix is needed to have the X library paths configured correctly. Fixed and tested for MACHINE=beagleboard. Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
Diffstat (limited to 'recipes/agg')
-rw-r--r--recipes/agg/agg_2.5.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes/agg/agg_2.5.bb b/recipes/agg/agg_2.5.bb
index ba76a7b4c6..1129ea50db 100644
--- a/recipes/agg/agg_2.5.bb
+++ b/recipes/agg/agg_2.5.bb
@@ -5,7 +5,7 @@ SECTION = "libs"
LICENSE = "AGG License"
DEPENDS = "virtual/libx11 virtual/libsdl freetype"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.antigrain.com/${P}.tar.gz"
S = "${WORKDIR}/${P}"
@@ -14,7 +14,7 @@ inherit autotools pkgconfig
export SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config
-CFLAGS += " -I{$STAGING_INCDIR} "
+CFLAGS += " -I${STAGING_INCDIR} "
PACKAGES =+ "${PN}-sdl ${PN}-x11"
@@ -25,6 +25,8 @@ FILES_${PN} = "${libdir}/libagg.so.* \
LEAD_SONAME = "libagg.so"
+EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/usr/include --x-libraries=${STAGING_INCDIR}/usr/lib"
+
do_stage() {
oe_libinstall -a -so libagg ${STAGING_LIBDIR}
oe_libinstall -a -so libaggfontfreetype ${STAGING_LIBDIR}