aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aircrack/aircrack_2.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/aircrack/aircrack_2.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/aircrack/aircrack_2.1.bb')
-rw-r--r--recipes/aircrack/aircrack_2.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/aircrack/aircrack_2.1.bb b/recipes/aircrack/aircrack_2.1.bb
new file mode 100644
index 0000000000..f4e6485351
--- /dev/null
+++ b/recipes/aircrack/aircrack_2.1.bb
@@ -0,0 +1,22 @@
+SECTION = "console/network"
+DESCRIPTION = "Aircrack is a set of tools for wep key statistical cracking"
+HOMEPAGE = "http://www.cr0.net:8040/code/network/aircrack/"
+LICENSE = "GPLv2"
+DEPENDS = ""
+PV="2.1"
+PR ="r0"
+
+SRC_URI = "http://www.cr0.net:8040/code/network/aircrack-2.1.tgz \
+file://silent_patch.diff;patch=1;pnum=0"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${libdir}/${PN}
+ install -m 0755 802ether ${D}/${sbindir}
+ install -m 0755 airodump ${D}/${sbindir}
+ install -m 0755 aircrack ${D}/${sbindir}
+ install -m 0755 aireplay ${D}/${sbindir}
+ install -m 0755 hopper.sh ${D}/${sbindir}
+}