aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/alsa/alsa-utils_1.0.20.bb
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-11-30 12:02:24 +1030
committerStefan Schmidt <stefan@buglabs.net>2010-12-02 16:47:17 +0100
commit0e5b4a705b2767efa5e5eee3f3e3c85bc376fe9f (patch)
treedb6bf849583c189e182301ae19c642c695649e47 /recipes/alsa/alsa-utils_1.0.20.bb
parentcb3d42b5032c4e3959d5789022d1552e77a8e571 (diff)
downloadopenembedded-0e5b4a705b2767efa5e5eee3f3e3c85bc376fe9f.tar.gz
alsa-utils_1.0.20.bb: Fix build when DISTRO_FEATURES lacks largefile.
mipsel-oe-linux-uclibc-gcc -march=mips32 -DHAVE_CONFIG_H -I. -I../include -I../include -isystem/mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include -isystem/mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -I/mnt/oe/tmp/sysroots/mipsel-oe-linux-uclibc/include -MT aplay.o -MD -MP -MF .deps/aplay.Tpo -c -o aplay.o aplay.c aplay.c:116:16: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'pbrec_count' aplay.c: In function 'test_wavefile': aplay.c:877:14: error: 'pbrec_count' undeclared (first use in this function) aplay.c:877:14: note: each undeclared identifier is reported only once for each function it appears in aplay.c: In function 'test_au': aplay.c:908:2: error: 'pbrec_count' undeclared (first use in this function) aplay.c: In function 'voc_play': aplay.c:1751:2: error: 'off64_t' undeclared (first use in this function) aplay.c:1751:10: error: expected ';' before 'filepos' aplay.c:1881:9: error: 'filepos' undeclared (first use in this function) aplay.c: At top level: aplay.c:1968:16: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'calc_count' aplay.c: In function 'end_voc': aplay.c:2137:2: error: 'off64_t' undeclared (first use in this function) aplay.c:2137:10: error: expected ';' before 'length_seek' aplay.c:2146:2: error: 'length_seek' undeclared (first use in this function) aplay.c:2150:8: error: 'fdcount' undeclared (first use in this function) aplay.c: In function 'end_wave': aplay.c:2166:2: error: 'off64_t' undeclared (first use in this function) aplay.c:2166:10: error: expected ';' before 'length_seek' aplay.c:2167:10: error: expected ';' before 'filelen' aplay.c:2170:2: error: 'length_seek' undeclared (first use in this function) aplay.c:2174:14: error: 'fdcount' undeclared (first use in this function) aplay.c:2175:2: error: 'filelen' undeclared (first use in this function) aplay.c: In function 'end_au': aplay.c:2188:2: error: 'off64_t' undeclared (first use in this function) aplay.c:2188:10: error: expected ';' before 'length_seek' aplay.c:2190:2: error: 'length_seek' undeclared (first use in this function) aplay.c:2191:17: error: 'fdcount' undeclared (first use in this function) aplay.c: At top level: aplay.c:2221:48: error: expected declaration specifiers or '...' before 'off64_t' aplay.c: In function 'playback_go': aplay.c:2224:2: error: 'off64_t' undeclared (first use in this function) aplay.c:2224:10: error: expected ';' before 'written' aplay.c:2225:10: error: expected ';' before 'c' aplay.c:2230:33: error: 'written' undeclared (first use in this function) aplay.c:2230:43: error: 'count' undeclared (first use in this function) aplay.c:2242:4: error: 'c' undeclared (first use in this function) aplay.c:2254:4: error: 'fdcount' undeclared (first use in this function) aplay.c: In function 'playback': aplay.c:2283:2: error: 'pbrec_count' undeclared (first use in this function) aplay.c:2284:2: error: 'fdcount' undeclared (first use in this function) aplay.c:2303:3: warning: passing argument 4 of 'playback_go' makes pointer from integer without a cast aplay.c:2221:13: note: expected 'char *' but argument is of type 'int' aplay.c:2303:3: error: too many arguments to function 'playback_go' aplay.c:2221:13: note: declared here aplay.c:2320:3: warning: passing argument 4 of 'playback_go' makes pointer from integer without a cast aplay.c:2221:13: note: expected 'char *' but argument is of type 'int' aplay.c:2320:3: error: too many arguments to function 'playback_go' aplay.c:2221:13: note: declared here aplay.c:2325:3: error: too many arguments to function 'playback_go' aplay.c:2221:13: note: declared here aplay.c: In function 'capture': aplay.c:2376:2: error: 'off64_t' undeclared (first use in this function) aplay.c:2376:10: error: expected ';' before 'count' aplay.c:2379:2: error: 'count' undeclared (first use in this function) aplay.c:2424:3: error: 'rest' undeclared (first use in this function) aplay.c:2433:3: error: 'fdcount' undeclared (first use in this function) aplay.c:2435:33: error: expected ')' before 'chunk_bytes' aplay.c: At top level: aplay.c:2461:74: error: expected declaration specifiers or '...' before 'off64_t' aplay.c: In function 'playbackv_go': aplay.c:2480:9: error: 'count' undeclared (first use in this function) aplay.c: At top level: aplay.c:2513:58: error: expected declaration specifiers or '...' before 'off64_t' aplay.c: In function 'capturev_go': aplay.c:2529:9: error: 'count' undeclared (first use in this function) aplay.c:2546:3: error: 'fdcount' undeclared (first use in this function) aplay.c: In function 'playbackv': aplay.c:2587:2: error: 'pbrec_count' undeclared (first use in this function) aplay.c:2588:2: error: too many arguments to function 'playbackv_go' aplay.c:2461:13: note: declared here aplay.c: In function 'capturev': aplay.c:2640:2: error: 'pbrec_count' undeclared (first use in this function) aplay.c:2641:2: error: too many arguments to function 'capturev_go' aplay.c:2513:13: note: declared here make[1]: *** [aplay.o] Error 1 Signed-off-by: Graham Gower <graham.gower@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/alsa/alsa-utils_1.0.20.bb')
-rw-r--r--recipes/alsa/alsa-utils_1.0.20.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/alsa/alsa-utils_1.0.20.bb b/recipes/alsa/alsa-utils_1.0.20.bb
index ee0467e285..74e9d136a8 100644
--- a/recipes/alsa/alsa-utils_1.0.20.bb
+++ b/recipes/alsa/alsa-utils_1.0.20.bb
@@ -3,10 +3,11 @@ HOMEPAGE = "http://www.alsa-project.org"
SECTION = "console/utils"
LICENSE = "GPLv2"
DEPENDS = "alsa-lib ncurses"
-PR = "r4"
+PR = "r5"
SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \
file://alsa-utils-remove-xmlto-1.0.19plus.patch \
+ file://nolargefile.patch \
"
inherit gettext autotools