aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/amule
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/amule
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/amule')
-rw-r--r--recipes/amule/amule_2.1.3.bb27
-rw-r--r--recipes/amule/files/parser.patch20
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes/amule/amule_2.1.3.bb b/recipes/amule/amule_2.1.3.bb
new file mode 100644
index 0000000000..1fa4d3cfc9
--- /dev/null
+++ b/recipes/amule/amule_2.1.3.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "aMule is an eMule-like client for the eD2k \
+and Kademlia networks, supporting multiple platforms."
+HOMEPAGE = "http://www.amule.org"
+LICENSE = "GPL"
+SECTION = "web"
+PRIORITY = "optional"
+DEPENDS = "wxbase"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/amule/aMule-${PV}.tar.bz2 \
+ file://parser.patch;patch=1"
+
+S = "${WORKDIR}/aMule-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-amulecmd \
+ --enable-webserver \
+ --disable-monolithic \
+ --enable-amule-daemon \
+ --disable-nls"
+# --enable-optimize"
+
+FILES_${PN} += " \
+ ${libdir}/xchat"
+
+LDFLAGS += "-ldl"
diff --git a/recipes/amule/files/parser.patch b/recipes/amule/files/parser.patch
new file mode 100644
index 0000000000..ee77c42380
--- /dev/null
+++ b/recipes/amule/files/parser.patch
@@ -0,0 +1,20 @@
+diff -ur aMule-2.1.0_orig/src/Parser.cpp aMule-2.1.0/src/Parser.cpp
+--- aMule-2.1.0_orig/src/Parser.cpp 2005-12-20 05:13:25.000000000 +0100
++++ aMule-2.1.0/src/Parser.cpp 2006-01-29 15:16:45.000000000 +0100
+@@ -203,14 +203,14 @@
+ # define YYMALLOC malloc
+ # if (! defined (malloc) && ! defined (YYINCLUDED_STDLIB_H) \
+ && (defined (__STDC__) || defined (__cplusplus)))
+-void *malloc (YYSIZE_T); /* INFRINGES ON USER NAME SPACE */
++/*void *malloc (YYSIZE_T);*/ /* INFRINGES ON USER NAME SPACE */
+ # endif
+ # endif
+ # ifndef YYFREE
+ # define YYFREE free
+ # if (! defined (free) && ! defined (YYINCLUDED_STDLIB_H) \
+ && (defined (__STDC__) || defined (__cplusplus)))
+-void free (void *); /* INFRINGES ON USER NAME SPACE */
++/*void free (void *);*/ /* INFRINGES ON USER NAME SPACE */
+ # endif
+ # endif
+ # ifdef __cplusplus