aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/angstrom
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/angstrom
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/angstrom')
-rw-r--r--recipes/angstrom/angstrom-bootmanager.bb2
-rw-r--r--recipes/angstrom/angstrom-gnome-icon-theme-enable.bb2
-rw-r--r--recipes/angstrom/angstrom-x11-base-depends.bb2
-rw-r--r--recipes/angstrom/angstrom-x11vnc-xinit.bb2
-rw-r--r--recipes/angstrom/angstrom-zeroconf-audio.bb2
-rw-r--r--recipes/angstrom/epiphany-firefox-replacement.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes/angstrom/angstrom-bootmanager.bb b/recipes/angstrom/angstrom-bootmanager.bb
index 5c5ee90f02..6cae115368 100644
--- a/recipes/angstrom/angstrom-bootmanager.bb
+++ b/recipes/angstrom/angstrom-bootmanager.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "A graphical Boot Manager for the Ångström Linux Distribution"
AUTHOR = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
SECTION = "base"
DEPENDS = "evas-fb ecore-fb esmart-fb imlib2-fb edje efl++-fb"
-#RDEPENDS = "libefl++0"
+#RDEPENDS_${PN} = "libefl++0"
ALLOW_EMPTY = "1"
diff --git a/recipes/angstrom/angstrom-gnome-icon-theme-enable.bb b/recipes/angstrom/angstrom-gnome-icon-theme-enable.bb
index 423dd00588..bb6306e59a 100644
--- a/recipes/angstrom/angstrom-gnome-icon-theme-enable.bb
+++ b/recipes/angstrom/angstrom-gnome-icon-theme-enable.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Enable gnome-icon-theme in gtkrc"
LICENSE = "MIT"
-RDEPENDS = "gnome-icon-theme"
+RDEPENDS_${PN} = "gnome-icon-theme"
ALLOW_EMPTY_${PN} = "1"
PACKAGE_ARCH = "all"
diff --git a/recipes/angstrom/angstrom-x11-base-depends.bb b/recipes/angstrom/angstrom-x11-base-depends.bb
index 0395c62450..ec55f60087 100644
--- a/recipes/angstrom/angstrom-x11-base-depends.bb
+++ b/recipes/angstrom/angstrom-x11-base-depends.bb
@@ -9,7 +9,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
DEPENDS = "virtual/xserver"
-RDEPENDS = "\
+RDEPENDS_${PN} = "\
${XSERVER} \
dbus-x11 \
ttf-dejavu-sans \
diff --git a/recipes/angstrom/angstrom-x11vnc-xinit.bb b/recipes/angstrom/angstrom-x11vnc-xinit.bb
index ee21d81e03..d4d9d432a6 100644
--- a/recipes/angstrom/angstrom-x11vnc-xinit.bb
+++ b/recipes/angstrom/angstrom-x11vnc-xinit.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Script to start a passwordless vnc of the current X session"
LICENSE = "MIT"
-RDEPENDS = "x11vnc"
+RDEPENDS_${PN} = "x11vnc"
do_install() {
install -d ${D}/${sysconfdir}/X11/Xinit.d
diff --git a/recipes/angstrom/angstrom-zeroconf-audio.bb b/recipes/angstrom/angstrom-zeroconf-audio.bb
index 2256b6ac4f..66290504e2 100644
--- a/recipes/angstrom/angstrom-zeroconf-audio.bb
+++ b/recipes/angstrom/angstrom-zeroconf-audio.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Meta package to enable zeroconf audio with pulseaudio"
DEPENDS = "avahi pulseaudio"
-RDEPENDS = " \
+RDEPENDS_${PN} = " \
avahi-daemon \
pulseaudio-server \
pulseaudio-module-alsa-sink \
diff --git a/recipes/angstrom/epiphany-firefox-replacement.bb b/recipes/angstrom/epiphany-firefox-replacement.bb
index 2ced2c9c06..50de217f82 100644
--- a/recipes/angstrom/epiphany-firefox-replacement.bb
+++ b/recipes/angstrom/epiphany-firefox-replacement.bb
@@ -1,6 +1,6 @@
# This is a hack because $*#($*($# e17 doesn't check if firefox is present and puts it in the menu blindly
-RDEPENDS = "epiphany"
+RDEPENDS_${PN} = "epiphany"
RCONFLICTS = "firefox"
do_install() {