summaryrefslogtreecommitdiffstats
path: root/recipes/angstrom
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-06-18 15:44:32 +0200
committerKoen Kooi <koen@openembedded.org>2010-06-18 15:44:32 +0200
commit3981cd6da91e02a51717456565026576fbc1b2cb (patch)
treec6ac07c414086f1e3813b023595ee9d852b85ebf /recipes/angstrom
parent1d7eeddd2a2d06d16f526f0eaeb6fb38595589c1 (diff)
downloadopenembedded-3981cd6da91e02a51717456565026576fbc1b2cb.tar.gz
angstrom-version: add lsb_release script
Diffstat (limited to 'recipes/angstrom')
-rw-r--r--recipes/angstrom/angstrom-version.bb7
-rwxr-xr-xrecipes/angstrom/angstrom-version/lsb_release43
2 files changed, 49 insertions, 1 deletions
diff --git a/recipes/angstrom/angstrom-version.bb b/recipes/angstrom/angstrom-version.bb
index 1728c0dff8..a2f1335f9d 100644
--- a/recipes/angstrom/angstrom-version.bb
+++ b/recipes/angstrom/angstrom-version.bb
@@ -1,9 +1,11 @@
LICENSE = "MIT"
PV = "${DISTRO_VERSION}"
-PR = "r3"
+PR = "r4"
PE = "1"
+SRC_URI = "file://lsb_release"
+
PACKAGES = "${PN}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -17,4 +19,7 @@ do_install() {
echo "Built from branch: ${METADATA_BRANCH}" >> ${D}${sysconfdir}/angstrom-version
echo "Revision: ${METADATA_REVISION}" >> ${D}${sysconfdir}/angstrom-version
echo "Target system: ${TARGET_SYS}" >> ${D}${sysconfdir}/angstrom-version
+
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/lsb_release ${D}${bindir}/
}
diff --git a/recipes/angstrom/angstrom-version/lsb_release b/recipes/angstrom/angstrom-version/lsb_release
new file mode 100755
index 0000000000..11b48141f5
--- /dev/null
+++ b/recipes/angstrom/angstrom-version/lsb_release
@@ -0,0 +1,43 @@
+#!/bin/sh
+VERSION="$(cat /etc/angstrom-version | head -n1 | awk '{print $2}')"
+CODENAME="foo"
+
+case $1 in
+"-v")
+ echo "No LSB modules are available."
+ ;;
+"-i")
+ echo "Distributor ID: Angstrom"
+ ;;
+"-d")
+ echo "Description: Angstrom GNU/Linux $VERSION ($CODENAME)"
+ ;;
+"-r")
+ echo "Release: $VERSION"
+ ;;
+"-c")
+ echo "Codename: $CODENAME"
+ ;;
+"-a")
+ echo "Distributor ID: Angstrom"
+ echo "Description: Angstrom GNU/Linux $VERSION ($CODENAME)"
+ echo "Release: $VERSION"
+ echo "Codename: $CODENAME"
+ ;;
+"-s")
+ echo "No LSB modules are available."
+ ;;
+*)
+ echo "Usage: lsb_release [options]"
+ echo ""
+ echo "Options:"
+ echo " -h, --help show this help message and exit"
+ echo " -v, --version show LSB modules this system supports"
+ echo " -i, --id show distributor ID"
+ echo " -d, --description show description of this distribution"
+ echo " -r, --release show release number of this distribution"
+ echo " -c, --codename show code name of this distribution"
+ echo " -a, --all show all of the above information"
+ echo " -s, --short show requested information in short format"
+;;
+esac