aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/anthy/anthy-native/native-helpers.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/anthy/anthy-native/native-helpers.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/anthy/anthy-native/native-helpers.patch')
-rw-r--r--recipes/anthy/anthy-native/native-helpers.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes/anthy/anthy-native/native-helpers.patch b/recipes/anthy/anthy-native/native-helpers.patch
new file mode 100644
index 0000000000..291b66b37b
--- /dev/null
+++ b/recipes/anthy/anthy-native/native-helpers.patch
@@ -0,0 +1,50 @@
+upstream: not applicable
+author: pH5
+comment: Stage the native anthy helpers mkfiledic, mkdepgraph, mkworddic,
+comment: calctrans and proccorpus.
+
+--- anthy-7811/mkanthydic/Makefile.am~ 2006-05-13 18:28:35.000000000 +0900
++++ anthy-7811/mkanthydic/Makefile.am 2006-06-18 10:56:25.770000000 +0900
+@@ -3,7 +3,7 @@
+ CLEANFILES = anthy.dic
+ INCLUDES = -I$(top_srcdir)/include -DSRCDIR=\"$(srcdir)\"
+
+-noinst_PROGRAMS = mkfiledic
++bin_PROGRAMS = mkfiledic
+ mkfiledic_SOURCES = mkfiledic.c
+ mkfiledic_LDADD = ../src-diclib/libdiclib.la
+
+--- anthy-7811/depgraph/Makefile.am~ 2006-06-02 00:20:54.000000000 +0900
++++ anthy-7811/depgraph/Makefile.am 2006-06-18 10:57:19.420000000 +0900
+@@ -9,7 +9,7 @@
+ EXTRA_DIST = indepword.txt $(DEPWORDS)
+
+ # Generate the dictionary
+-noinst_PROGRAMS = mkdepgraph
++bin_PROGRAMS = mkdepgraph
+ mkdepgraph_SOURCES = mkdepgraph.c
+ mkdepgraph_LDADD = ../src-main/libanthy.la ../src-worddic/libanthydic.la
+
+--- anthy-7811/mkworddic/Makefile.am~ 2006-05-13 18:29:07.000000000 +0900
++++ anthy-7811/mkworddic/Makefile.am 2006-06-18 11:21:56.300000000 +0900
+@@ -16,7 +16,8 @@
+ udict dict.args.in
+
+ # Generate the dictionary
+-noinst_PROGRAMS = mkworddic
++#noinst_PROGRAMS = mkworddic
++bin_PROGRAMS = mkworddic
+ mkworddic_SOURCES = mkdic.c writewords.c mkudic.c calcfreq.c mkdic.h
+ mkworddic_LDADD = ../src-worddic/libanthydic.la
+
+--- anthy-9100e.orig/calctrans/Makefile.am 2008-05-08 15:04:13.000000000 +0200
++++ anthy-9100e/calctrans/Makefile.am 2008-05-08 15:04:24.000000000 +0200
+@@ -3,7 +3,7 @@
+ corpus.3.txt corpus.4.txt corpus.5.txt\
+ corpus_info weak_words
+
+-noinst_PROGRAMS = calctrans proccorpus
++bin_PROGRAMS = calctrans proccorpus
+ INCLUDES = -I$(top_srcdir)/
+
+ calctrans_SOURCES = calctrans.c input_set.c input_set.h corpus.c