summaryrefslogtreecommitdiffstats
path: root/recipes/apr
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2010-09-13 14:15:35 -0400
committerCliff Brake <cbrake@bec-systems.com>2010-09-13 14:15:35 -0400
commit4ee358534793381d2e87b01781079a3354fd5c1c (patch)
tree729f8b0ce4bdbcd8a16f561fb68da0d66c3a3eb8 /recipes/apr
parentbeb17e26ee9b4bc0cf334c3b30560c6eb66b1299 (diff)
parenteda06ec3dde6169a46797f876a82499c4fff8f62 (diff)
downloadopenembedded-324a7c75ac7f591e950836686bfe14332ce6586b.tar.gz
Merge branch 'org.openembedded.dev' into testing-nexttesting_2010-09-13
Diffstat (limited to 'recipes/apr')
-rw-r--r--recipes/apr/apr-1.3.5/cleanup.patch42
-rw-r--r--recipes/apr/apr-util_1.2.12.bb7
-rw-r--r--recipes/apr/apr-util_1.3.4.bb4
-rw-r--r--recipes/apr/apr_1.2.12.bb6
-rw-r--r--recipes/apr/apr_1.3.5.bb4
5 files changed, 53 insertions, 10 deletions
diff --git a/recipes/apr/apr-1.3.5/cleanup.patch b/recipes/apr/apr-1.3.5/cleanup.patch
new file mode 100644
index 0000000000..53623a2666
--- /dev/null
+++ b/recipes/apr/apr-1.3.5/cleanup.patch
@@ -0,0 +1,42 @@
+Index: apr-1.3.5/build/buildcheck.sh
+===================================================================
+--- apr-1.3.5.orig/build/buildcheck.sh 2009-02-23 20:37:18.000000000 -0700
++++ apr-1.3.5/build/buildcheck.sh 2010-09-09 11:09:08.000000000 -0700
+@@ -31,36 +31,4 @@
+ else
+ echo "buildconf: autoconf version $ac_version (ok)"
+ fi
+-
+-# Sample libtool --version outputs:
+-# ltmain.sh (GNU libtool) 1.3.3 (1.385.2.181 1999/07/02 15:49:11)
+-# ltmain.sh (GNU libtool 1.1361 2004/01/02 23:10:52) 1.5a
+-# output is multiline from 1.5 onwards
+-
+-# Require libtool 1.4 or newer
+-libtool=`build/PrintPath glibtool1 glibtool libtool libtool15 libtool14`
+-lt_pversion=`$libtool --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
+-if test -z "$lt_pversion"; then
+-echo "buildconf: libtool not found."
+-echo " You need libtool version 1.4 or newer installed"
+-echo " to build APR from SVN."
+-exit 1
+-fi
+-lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'`
+-IFS=.; set $lt_version; IFS=' '
+-lt_status="good"
+-if test "$1" = "1"; then
+- if test "$2" -lt "4"; then
+- lt_status="bad"
+- fi
+-fi
+-if test $lt_status = "good"; then
+- echo "buildconf: libtool version $lt_pversion (ok)"
+- exit 0
+-fi
+-
+-echo "buildconf: libtool version $lt_pversion found."
+-echo " You need libtool version 1.4 or newer installed"
+-echo " to build APR from SVN."
+-
+-exit 1
++exit 0
diff --git a/recipes/apr/apr-util_1.2.12.bb b/recipes/apr/apr-util_1.2.12.bb
index 698a3f0ca7..18e4ad3b97 100644
--- a/recipes/apr/apr-util_1.2.12.bb
+++ b/recipes/apr/apr-util_1.2.12.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r3"
+PR = "r4"
inherit autotools lib_package binconfig
@@ -19,12 +19,11 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
-EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
-export LIBTOOL="${S}/${TARGET_PREFIX}libtool"
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
do_configure_prepend() {
- cp ${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool ${S}/
cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
libtoolize --force
diff --git a/recipes/apr/apr-util_1.3.4.bb b/recipes/apr/apr-util_1.3.4.bb
index c0ac30c5e1..cc6781b254 100644
--- a/recipes/apr/apr-util_1.3.4.bb
+++ b/recipes/apr/apr-util_1.3.4.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r5"
+PR = "r6"
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
file://configfix.patch \
@@ -29,7 +29,7 @@ do_configure_prepend() {
do_configure_append() {
sed -i -e s:apr_builders=/usr/share/build-1:apr_builders=${STAGING_DATADIR}/build-1:g ${S}/build/rules.mk
sed -i /^LIBTOOL/d ${S}/build/rules.mk
- echo LIBTOOL="${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool --tag=CC" >> ${S}/build/rules.mk
+ echo LIBTOOL="${TARGET_PREFIX}libtool --tag=CC" >> ${S}/build/rules.mk
}
diff --git a/recipes/apr/apr_1.2.12.bb b/recipes/apr/apr_1.2.12.bb
index dd4493f571..775578a4c0 100644
--- a/recipes/apr/apr_1.2.12.bb
+++ b/recipes/apr/apr_1.2.12.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
SECTION = "libs"
LICENSE = "Apache License, Version 2.0"
-PR = "r1"
+PR = "r2"
# apache mirrors?
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
@@ -11,7 +11,9 @@ SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
inherit autotools lib_package binconfig
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
-EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
+
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
do_configure_prepend() {
rm -f ${S}/build/libtool.m4
diff --git a/recipes/apr/apr_1.3.5.bb b/recipes/apr/apr_1.3.5.bb
index a8362e4165..955334f279 100644
--- a/recipes/apr/apr_1.3.5.bb
+++ b/recipes/apr/apr_1.3.5.bb
@@ -2,11 +2,11 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
SECTION = "libs"
LICENSE = "Apache License, Version 2.0"
-PR = "r4"
+PR = "r5"
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2;name=apr135tarbz2 \
file://configure_fixes.patch \
-# file://cleanup.patch \
+ file://cleanup.patch \
file://configfix.patch"
inherit autotools lib_package binconfig