aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apt/apt_0.7.20.2.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/apt/apt_0.7.20.2.bb
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
openembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.bz2
openembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.zip
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/apt/apt_0.7.20.2.bb')
-rw-r--r--recipes/apt/apt_0.7.20.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/apt/apt_0.7.20.2.bb b/recipes/apt/apt_0.7.20.2.bb
index 09dbbc44a9..e635841027 100644
--- a/recipes/apt/apt_0.7.20.2.bb
+++ b/recipes/apt/apt_0.7.20.2.bb
@@ -1,5 +1,5 @@
DEPENDS = "curl db"
-RDEPENDS = "dpkg"
+RDEPENDS_${PN} = "dpkg"
require apt.inc