aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 10:39:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 20:16:13 +0200
commit16f464bd8cff6b6a27d9bfe691f7adc875d01ac2 (patch)
treed235ad1dba36225ca211cc7c606ecaab4ff883c5 /recipes/apt
parent44985d56bc556786812a0a02d6219afd31a7381d (diff)
downloadopenembedded-16f464bd8cff6b6a27d9bfe691f7adc875d01ac2.tar.gz
recipes: move checksums to recipes from checksums.ini, part 2 manual adjustement
* all: multiple checked items in SRC_URI (needs name= param) * other fixes like non-existent URL, checksums moved ot .inc or included .bb (ie for -native) * ... * tested with micro/micro-uclibc/Angstrom/SHR with SOURCE_MIRROR_FETCH="True" (ignoring COMPATIBLE_* * also tested -c fetch with s/SRC_URI_append_[^ ]*/SRC_URI_append/g and s/SRC_URI_[^ ]*/SRC_URI_append/g to catch all URLs used only for distro/machine/virtual override (see http://build.shr-project.org/tests/jama/SRC_URI.removeOverrides.patch) * in case I downloaded different checksum then what was in checksums.ini I used the old one from checksums.ini and put my checksum in comment * I'll send to ML list of recipes which cannot be downloaded (weren't converted) and where I got different checksums Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/apt')
-rw-r--r--recipes/apt/apt-native_0.7.14.bb3
-rw-r--r--recipes/apt/apt-native_0.7.19.bb3
-rw-r--r--recipes/apt/apt-native_0.7.2.bb3
-rw-r--r--recipes/apt/apt_0.6.25.bb3
-rw-r--r--recipes/apt/apt_0.7.14.bb3
-rw-r--r--recipes/apt/apt_0.7.19.bb4
-rw-r--r--recipes/apt/apt_0.7.2.bb3
7 files changed, 22 insertions, 0 deletions
diff --git a/recipes/apt/apt-native_0.7.14.bb b/recipes/apt/apt-native_0.7.14.bb
index 7628bc9741..38a75eb1f7 100644
--- a/recipes/apt/apt-native_0.7.14.bb
+++ b/recipes/apt/apt-native_0.7.14.bb
@@ -4,3 +4,6 @@ PR = "r3"
SRC_URI += "file://nodoc.patch;patch=1 \
file://noconfigure.patch;patch=1 \
file://no-curl.patch;patch=1"
+
+SRC_URI[md5sum] = "19efa18fb1ef20c58b9b44e94258b814"
+SRC_URI[sha256sum] = "8fc06effaf8a4e4333308eedcdc6840f1c8056f2e924210f151dfc076bcd4045"
diff --git a/recipes/apt/apt-native_0.7.19.bb b/recipes/apt/apt-native_0.7.19.bb
index 7628bc9741..3331c93d15 100644
--- a/recipes/apt/apt-native_0.7.19.bb
+++ b/recipes/apt/apt-native_0.7.19.bb
@@ -4,3 +4,6 @@ PR = "r3"
SRC_URI += "file://nodoc.patch;patch=1 \
file://noconfigure.patch;patch=1 \
file://no-curl.patch;patch=1"
+
+SRC_URI[md5sum] = "0ef50176aea36cb0cce633a9b62dc7eb"
+SRC_URI[sha256sum] = "c928f5eb2baffb50e7ccf02d07a16daf867945c8aa542d500bbbbaff7bbcef42"
diff --git a/recipes/apt/apt-native_0.7.2.bb b/recipes/apt/apt-native_0.7.2.bb
index 4b6897fa44..1d85762c22 100644
--- a/recipes/apt/apt-native_0.7.2.bb
+++ b/recipes/apt/apt-native_0.7.2.bb
@@ -3,3 +3,6 @@ PR = "r4"
SRC_URI += "file://nodoc.patch;patch=1 \
file://noconfigure.patch;patch=1"
+
+SRC_URI[md5sum] = "c66f943203fa24e85ed8c48f6ac5ad1e"
+SRC_URI[sha256sum] = "e7d58e2b202713b4df8cd5fd58bc20ba8d31c0da6e5e3b3c89a138dbf0b24ad9"
diff --git a/recipes/apt/apt_0.6.25.bb b/recipes/apt/apt_0.6.25.bb
index 23c9829f21..e75f5588ac 100644
--- a/recipes/apt/apt_0.6.25.bb
+++ b/recipes/apt/apt_0.6.25.bb
@@ -9,3 +9,6 @@ require apt-package.inc
FILES_${PN} += "${bindir}/apt-key"
apt-manpages += "doc/apt-key.8"
+
+SRC_URI[md5sum] = "6569fd95e829036c141a5ccaf8e5948c"
+SRC_URI[sha256sum] = "fa00ce910ab6f0987c4a210962be357d4f013fc89ef72b015f39ae8649522b59"
diff --git a/recipes/apt/apt_0.7.14.bb b/recipes/apt/apt_0.7.14.bb
index f64fa0019a..5b121b0df6 100644
--- a/recipes/apt/apt_0.7.14.bb
+++ b/recipes/apt/apt_0.7.14.bb
@@ -24,3 +24,6 @@ do_stage() {
install -m 0644 include/apt-pkg/*.h ${STAGING_INCDIR}/apt-pkg/
}
+
+SRC_URI[md5sum] = "19efa18fb1ef20c58b9b44e94258b814"
+SRC_URI[sha256sum] = "8fc06effaf8a4e4333308eedcdc6840f1c8056f2e924210f151dfc076bcd4045"
diff --git a/recipes/apt/apt_0.7.19.bb b/recipes/apt/apt_0.7.19.bb
index f64fa0019a..15f127dbbe 100644
--- a/recipes/apt/apt_0.7.19.bb
+++ b/recipes/apt/apt_0.7.19.bb
@@ -24,3 +24,7 @@ do_stage() {
install -m 0644 include/apt-pkg/*.h ${STAGING_INCDIR}/apt-pkg/
}
+
+SRC_URI[md5sum] = "0ef50176aea36cb0cce633a9b62dc7eb"
+SRC_URI[sha256sum] = "c928f5eb2baffb50e7ccf02d07a16daf867945c8aa542d500bbbbaff7bbcef42"
+
diff --git a/recipes/apt/apt_0.7.2.bb b/recipes/apt/apt_0.7.2.bb
index 7f6bb81f6e..5db2cb9b86 100644
--- a/recipes/apt/apt_0.7.2.bb
+++ b/recipes/apt/apt_0.7.2.bb
@@ -7,3 +7,6 @@ require apt-package.inc
FILES_${PN} += "${bindir}/apt-key"
apt-manpages += "doc/apt-key.8"
+
+SRC_URI[md5sum] = "c66f943203fa24e85ed8c48f6ac5ad1e"
+SRC_URI[sha256sum] = "e7d58e2b202713b4df8cd5fd58bc20ba8d31c0da6e5e3b3c89a138dbf0b24ad9"