aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apt
diff options
context:
space:
mode:
authorLynn Lin <Lin_Lynn@emc.com>2010-06-21 18:25:51 +0800
committerLynn Lin <Lin_Lynn@emc.com>2010-06-23 19:14:01 +0800
commit709663f88c8b03a14c51b5135bea373fc80efb87 (patch)
tree81f0b58279f90a5437fc5789bec0f4b0bd451db0 /recipes/apt
parent4d20a9779111f4dc2634511114d6b245a6601eb9 (diff)
downloadopenembedded-709663f88c8b03a14c51b5135bea373fc80efb87.tar.gz
apt-native: fix gcc-4.4 compile error
Diffstat (limited to 'recipes/apt')
-rw-r--r--recipes/apt/apt-0.7.20.2/fix-gcc-4.4-compile.patch39
-rw-r--r--recipes/apt/apt-native_0.7.20.2.bb5
2 files changed, 42 insertions, 2 deletions
diff --git a/recipes/apt/apt-0.7.20.2/fix-gcc-4.4-compile.patch b/recipes/apt/apt-0.7.20.2/fix-gcc-4.4-compile.patch
new file mode 100644
index 0000000000..eb4d5e4c16
--- /dev/null
+++ b/recipes/apt/apt-0.7.20.2/fix-gcc-4.4-compile.patch
@@ -0,0 +1,39 @@
+diff -rc apt-0.7.20.2.orig/apt-pkg/acquire.cc apt-0.7.20.2/apt-pkg/acquire.cc
+*** apt-0.7.20.2.orig/apt-pkg/acquire.cc 2010-06-21 18:14:15.815760996 +0800
+--- apt-0.7.20.2/apt-pkg/acquire.cc 2010-06-21 18:15:30.865760994 +0800
+***************
+*** 24,29 ****
+--- 24,30 ----
+
+ #include <iostream>
+ #include <sstream>
++ #include <cstdio>
+
+ #include <dirent.h>
+ #include <sys/time.h>
+diff -rc apt-0.7.20.2.orig/apt-pkg/contrib/sha256.h apt-0.7.20.2/apt-pkg/contrib/sha256.h
+*** apt-0.7.20.2.orig/apt-pkg/contrib/sha256.h 2010-06-21 18:14:15.815760996 +0800
+--- apt-0.7.20.2/apt-pkg/contrib/sha256.h 2010-06-21 18:14:59.565760993 +0800
+***************
+*** 17,22 ****
+--- 17,23 ----
+ #include <string>
+ #include <cstring>
+ #include <algorithm>
++ #include <stdint.h>
+
+ using std::string;
+ using std::min;
+diff -rc apt-0.7.20.2.orig/apt-pkg/deb/dpkgpm.cc apt-0.7.20.2/apt-pkg/deb/dpkgpm.cc
+*** apt-0.7.20.2.orig/apt-pkg/deb/dpkgpm.cc 2010-06-21 18:14:15.815760996 +0800
+--- apt-0.7.20.2/apt-pkg/deb/dpkgpm.cc 2010-06-21 18:16:12.045760992 +0800
+***************
+*** 22,27 ****
+--- 22,28 ----
+ #include <sys/select.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
++ #include <sys/stat.h>
+ #include <signal.h>
+ #include <errno.h>
+ #include <stdio.h>
diff --git a/recipes/apt/apt-native_0.7.20.2.bb b/recipes/apt/apt-native_0.7.20.2.bb
index a6d5277c32..fb7a9a5cf0 100644
--- a/recipes/apt/apt-native_0.7.20.2.bb
+++ b/recipes/apt/apt-native_0.7.20.2.bb
@@ -1,9 +1,10 @@
require apt-native.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://nodoc.patch \
file://noconfigure.patch \
- file://no-curl.patch"
+ file://no-curl.patch \
+ file://fix-gcc-4.4-compile.patch"
SRC_URI[md5sum] = "e6ee1b594f6ed5fab5cb593ee46cfc21"
SRC_URI[sha256sum] = "4dc935a520c65705795ada5942b658f6e86b22eefc7032342267272bd6566b05"