aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aspell
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/aspell
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/aspell')
-rw-r--r--recipes/aspell/aspell-lang.inc20
-rw-r--r--recipes/aspell/aspell-native_0.60.5.bb6
-rw-r--r--recipes/aspell/aspell6-en_6.0-0.bb14
-rw-r--r--recipes/aspell/aspell6-pl_6.0-20061121-0.bb17
-rw-r--r--recipes/aspell/aspell_0.60.5.bb19
-rw-r--r--recipes/aspell/aspell_0.60.6.bb19
6 files changed, 95 insertions, 0 deletions
diff --git a/recipes/aspell/aspell-lang.inc b/recipes/aspell/aspell-lang.inc
new file mode 100644
index 0000000000..8c58136f0e
--- /dev/null
+++ b/recipes/aspell/aspell-lang.inc
@@ -0,0 +1,20 @@
+FILES_${PN} = "/usr/lib/aspell* /usr/share/aspell*"
+
+DEPENDS = "aspell-native"
+
+do_configure() {
+ cd ${S}
+ DESTDIR=${D} ./configure --vars ASPELL=${STAGING_BINDIR_NATIVE}/aspell
+}
+
+do_compile() {
+ sed -i -e "s|dictdir.*lib|dictdir = ${libdir}|" Makefile
+ sed -i -e "s|datadir.*lib|datadir = ${libdir}|" Makefile
+ oe_runmake
+}
+
+do_install() {
+ unset datadir
+ oe_runmake install
+}
+
diff --git a/recipes/aspell/aspell-native_0.60.5.bb b/recipes/aspell/aspell-native_0.60.5.bb
new file mode 100644
index 0000000000..174821ce46
--- /dev/null
+++ b/recipes/aspell/aspell-native_0.60.5.bb
@@ -0,0 +1,6 @@
+require aspell_${PV}.bb
+
+inherit native
+
+S = "${WORKDIR}/aspell-${PV}"
+
diff --git a/recipes/aspell/aspell6-en_6.0-0.bb b/recipes/aspell/aspell6-en_6.0-0.bb
new file mode 100644
index 0000000000..a8bf72d824
--- /dev/null
+++ b/recipes/aspell/aspell6-en_6.0-0.bb
@@ -0,0 +1,14 @@
+LICENSE = "Copyright file"
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/dict/en/aspell6-en-${PV}.tar.bz2"
+PR ="r1"
+
+require aspell-lang.inc
+
+FILES_${PN} += "${docdir}/Copyright"
+FILES_${PN}-doc = ""
+
+do_install_append() {
+ install -d ${D}${docdir}
+ install ${S}/Copyright ${D}${docdir}
+}
+
diff --git a/recipes/aspell/aspell6-pl_6.0-20061121-0.bb b/recipes/aspell/aspell6-pl_6.0-20061121-0.bb
new file mode 100644
index 0000000000..8b2fb57555
--- /dev/null
+++ b/recipes/aspell/aspell6-pl_6.0-20061121-0.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPLv2"
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/dict/pl/aspell6-pl-6.0_20061121-0.tar.bz2"
+PR ="r1"
+
+require aspell-lang.inc
+
+S = "${WORKDIR}/aspell6-pl-6.0_20061121-0"
+
+FILES_${PN} += "${docdir}/Copyright"
+FILES_${PN}-doc = ""
+
+do_install_append() {
+ install -d ${D}${docdir}
+ install ${S}/Copyright ${D}${docdir}
+}
+
+
diff --git a/recipes/aspell/aspell_0.60.5.bb b/recipes/aspell/aspell_0.60.5.bb
new file mode 100644
index 0000000000..66b21f9e52
--- /dev/null
+++ b/recipes/aspell/aspell_0.60.5.bb
@@ -0,0 +1,19 @@
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz"
+DESCRIPTION = "GNU Aspell spell-checker"
+SECTION = "console/utils"
+LICENSE="LGPL"
+
+PACKAGES += "libaspell libpspell libpspell-dev aspell-utils"
+
+FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*"
+FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
+FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
+FILES_${PN} = "${bindir}/aspell"
+FILES_libpspell = "${libdir}/libpspell.so.*"
+FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/aspell/aspell_0.60.6.bb b/recipes/aspell/aspell_0.60.6.bb
new file mode 100644
index 0000000000..66b21f9e52
--- /dev/null
+++ b/recipes/aspell/aspell_0.60.6.bb
@@ -0,0 +1,19 @@
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz"
+DESCRIPTION = "GNU Aspell spell-checker"
+SECTION = "console/utils"
+LICENSE="LGPL"
+
+PACKAGES += "libaspell libpspell libpspell-dev aspell-utils"
+
+FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*"
+FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
+FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
+FILES_${PN} = "${bindir}/aspell"
+FILES_libpspell = "${libdir}/libpspell.so.*"
+FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}