aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/at91bootstrap/at91bootstrap_3.0.bb
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2011-02-01 05:18:01 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-12 09:08:45 -0700
commit05e9d40d09040ebaeb5b25ee4f35d1940a9160c0 (patch)
treec4623d93edbabb5c2d0f6676d98c524400d15eb2 /recipes/at91bootstrap/at91bootstrap_3.0.bb
parentdbc5638c7e18a03067d7132bc258b8b9a833bba1 (diff)
downloadopenembedded-05e9d40d09040ebaeb5b25ee4f35d1940a9160c0.tar.gz
Add support for at91bootstrap-3.0
AT91bootstrap 3.0 support booting from SD-Card. It must be renamed to BOOT.BIN It needs to be in the DOS rootfs. The DOS fs should NOT be partitioned like a linux boot disk. I.E: keep original cylinders etc. The SD-Card must not contain "funny" characters like '&' and '.' at91bootstrap will try to load UBOOT.BIN, if u-boot is desired. For the AT91SAM9M10/G45 it supports dual boot. If the "LEFT" button is pressed, at91bootstrap will load PROGRAM.BIN Signed-off-by: Ulf Samuelsson <ulf.samuelsson@atmel.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/at91bootstrap/at91bootstrap_3.0.bb')
-rw-r--r--recipes/at91bootstrap/at91bootstrap_3.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/at91bootstrap/at91bootstrap_3.0.bb b/recipes/at91bootstrap/at91bootstrap_3.0.bb
new file mode 100644
index 0000000000..82a91c6261
--- /dev/null
+++ b/recipes/at91bootstrap/at91bootstrap_3.0.bb
@@ -0,0 +1,35 @@
+require at91bootstrap_3.0.inc
+PR = "r3"
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_at91sam9g45ek = "3"
+DEFAULT_PREFERENCE_at91sam9g45ekes = "3"
+DEFAULT_PREFERENCE_at91sam9m10ek = "3"
+DEFAULT_PREFERENCE_at91sam9m10ekes = "3"
+
+SRC_URI = "ftp://ftp.linux4sam.org/pub/Android4SAM/9m10g45/v1.1/patches/bootstrap30.tar.gz \
+ "
+
+SRC_URI_append = " \
+ file://0001-Update-.gitignore.patch;apply=yes \
+ file://0002-Add-KConfig-support-for-booting-U-Boot.patch;apply=yes \
+ file://0003-Generate-a-BOOT.BIN-file-instead-of-boot.bin.patch;apply=yes \
+ file://0004-Add-support-for-dual-boot.patch;apply=yes \
+ file://0005-Remove-old-afeb9260-files.patch;apply=yes \
+ file://0006-Use-BOARD-instead-of-BOARDNAME-to-define-directory.patch;apply=yes \
+ file://0007-Add-board-support-for-alternate-boot.patch;apply=yes \
+ file://0008-Clean-up-printouts.patch;apply=yes \
+ file://0009-Update-configs.patch;apply=yes \
+ file://0010-Update-build-scripts.patch;apply=yes \
+ file://0011-Fix-Cut-n-Paste-error.patch;apply=yes \
+ file://0013-Fix-Cut-n-Paste-error-in-Makefile.patch;apply=yes \
+ file://0014-Add-support-for-alternate-jump-address.patch;apply=yes \
+ file://0015-Make-MAKENEW-useful.patch;apply=yes \
+ file://0016-Update-configs.patch;apply=yes \
+ "
+
+# S = "${WORKDIR}/${PN}-${PV}"
+S = "${WORKDIR}/bootstrap30"
+
+SRC_URI[md5sum] = "a70f09198555d343de376014f9681f32"
+SRC_URI[sha256sum] = "90eccf7d639f4cf11ec8a3e0654aeb7e43382fd3bcbe9f234f9e9faeb1ed0ccd"
+