aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/at
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-08-22 18:53:18 +0400
committerRoman I Khimov <khimov@altell.ru>2010-08-22 20:03:20 +0400
commit82327c5e204720137d2b4039563f980b457bdad3 (patch)
tree7ecda678069e32bdc9a972015d3fc5de3fd0acce /recipes/at
parent351e6c061c3c13480fdb93a8773211644cccc2c9 (diff)
downloadopenembedded-82327c5e204720137d2b4039563f980b457bdad3.tar.gz
at 3.1.12: fix ocassional parallel make failures
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/at')
-rw-r--r--recipes/at/at-3.1.12/at-parallel-make-fix.patch13
-rw-r--r--recipes/at/at_3.1.12.bb3
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes/at/at-3.1.12/at-parallel-make-fix.patch b/recipes/at/at-3.1.12/at-parallel-make-fix.patch
new file mode 100644
index 0000000000..c456416bd0
--- /dev/null
+++ b/recipes/at/at-3.1.12/at-parallel-make-fix.patch
@@ -0,0 +1,13 @@
+Index: at-3.1.12/Makefile.in
+===================================================================
+--- at-3.1.12.orig/Makefile.in 2010-08-22 18:48:13.000000000 +0400
++++ at-3.1.12/Makefile.in 2010-08-22 18:48:38.000000000 +0400
+@@ -80,7 +80,7 @@
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+
+-lex.yy.c: parsetime.l
++lex.yy.c: parsetime.l y.tab.h
+ $(LEX) -i parsetime.l
+
+ atrun: atrun.in
diff --git a/recipes/at/at_3.1.12.bb b/recipes/at/at_3.1.12.bb
index 781937adb5..e9080a691d 100644
--- a/recipes/at/at_3.1.12.bb
+++ b/recipes/at/at_3.1.12.bb
@@ -5,7 +5,7 @@ DEPENDS = "flex-native flex"
RCONFLICTS_${PN} = "atd"
RREPLACES_${PN} = "atd"
-PR = "r1"
+PR = "r2"
SRC_URI = " \
${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
@@ -15,6 +15,7 @@ SRC_URI = " \
file://at-3.1.12-0005-Makefile.in-replace-IROOT-by-DESTDIR.patch \
file://at-3.1.12-0006-Makefile.in-make-install-fix.patch \
file://at-3.1.12-0007-getloadavg-fix.patch \
+ file://at-parallel-make-fix.patch \
file://init \
"
inherit autotools update-rc.d