aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/at
diff options
context:
space:
mode:
authorVladimir Sorokin <sorokin@altell.ru>2010-04-16 17:55:49 +0400
committerRoman I Khimov <khimov@altell.ru>2010-06-09 23:50:55 +0400
commiteb768a77fb354935eb3eeca57602924122934615 (patch)
tree76edf28ffb7803403c9ff2351e6bc3364f072eb2 /recipes/at
parent8122030e835a28591adc30a2dee0929e930f2a28 (diff)
downloadopenembedded-eb768a77fb354935eb3eeca57602924122934615.tar.gz
at: fix GNU hash QA error (force LDFLAGS)
Signed-off-by: Vladimir Sorokin <sorokin@altell.ru>
Diffstat (limited to 'recipes/at')
-rw-r--r--recipes/at/at-3.1.8/use-ldflags.patch18
-rw-r--r--recipes/at/at_3.1.8.bb7
2 files changed, 22 insertions, 3 deletions
diff --git a/recipes/at/at-3.1.8/use-ldflags.patch b/recipes/at/at-3.1.8/use-ldflags.patch
new file mode 100644
index 0000000000..57e411ddbc
--- /dev/null
+++ b/recipes/at/at-3.1.8/use-ldflags.patch
@@ -0,0 +1,18 @@
+--- a/Makefile.in 2010-04-16 17:35:22.000000000 +0400
++++ b/Makefile.in 2010-04-16 17:36:37.000000000 +0400
+@@ -70,13 +70,13 @@ LIST = Filelist Filelist.asc
+ all: at atd atrun
+
+ at: $(ATOBJECTS)
+- $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
++ $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB) $(LDFLAGS)
+ rm -f $(CLONES)
+ $(LN_S) -f at atq
+ $(LN_S) -f at atrm
+
+ atd: $(RUNOBJECTS)
+- $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS)
++ $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(LDFLAGS)
+
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
diff --git a/recipes/at/at_3.1.8.bb b/recipes/at/at_3.1.8.bb
index e6aaba4522..79b8557b10 100644
--- a/recipes/at/at_3.1.8.bb
+++ b/recipes/at/at_3.1.8.bb
@@ -1,15 +1,16 @@
DESCRIPTION = "Delayed job execution and batch processing."
SECTION = "base"
LICENSE="BSD"
-DEPENDS = "flex"
+DEPENDS = "flex-native"
RCONFLICTS = "atd"
RREPLACES = "atd"
-PR = "r1"
+PR = "r2"
SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}-11.tar.gz \
file://configure.patch \
- file://nonrootinstall.patch"
+ file://nonrootinstall.patch \
+ file://use-ldflags.patch"
inherit autotools