aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/atk
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/atk
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/atk')
-rw-r--r--recipes/atk/atk.inc14
-rw-r--r--recipes/atk/atk_1.18.0.bb8
-rw-r--r--recipes/atk/atk_1.19.3.bb14
-rw-r--r--recipes/atk/atk_1.20.0.bb6
4 files changed, 42 insertions, 0 deletions
diff --git a/recipes/atk/atk.inc b/recipes/atk/atk.inc
new file mode 100644
index 0000000000..5f81cdf67e
--- /dev/null
+++ b/recipes/atk/atk.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "An accessibility toolkit for GNOME."
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+
+DEPENDS = "glib-2.0 gtk-doc-native"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-glibtest"
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/atk/atk_1.18.0.bb b/recipes/atk/atk_1.18.0.bb
new file mode 100644
index 0000000000..116d8cabff
--- /dev/null
+++ b/recipes/atk/atk_1.18.0.bb
@@ -0,0 +1,8 @@
+require atk.inc
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/atk/1.18/atk-${PV}.tar.bz2"
+
+do_stage () {
+ oe_libinstall -so -C atk libatk-1.0 ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
diff --git a/recipes/atk/atk_1.19.3.bb b/recipes/atk/atk_1.19.3.bb
new file mode 100644
index 0000000000..28adc02ea9
--- /dev/null
+++ b/recipes/atk/atk_1.19.3.bb
@@ -0,0 +1,14 @@
+require atk.inc
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/atk/1.19/atk-${PV}.tar.bz2"
+
+CFLAGS_append = "\
+ -I${STAGING_INCDIR}/glib-2.0 \
+ -I${STAGING_INCDIR}/glib-2.0/glib \
+ -I${STAGING_INCDIR}/glib-2.0/gobject \
+ "
+
+do_stage () {
+ oe_libinstall -so -C atk libatk-1.0 ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
diff --git a/recipes/atk/atk_1.20.0.bb b/recipes/atk/atk_1.20.0.bb
new file mode 100644
index 0000000000..bb64492337
--- /dev/null
+++ b/recipes/atk/atk_1.20.0.bb
@@ -0,0 +1,6 @@
+require atk.inc
+
+SRC_URI = "http://download.gnome.org/sources/atk/1.20/${PN}-${PV}.tar.bz2"
+
+
+