aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aumix
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/aumix
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/aumix')
-rw-r--r--recipes/aumix/aumix-2.8/configure.patch28
-rw-r--r--recipes/aumix/aumix_2.8.bb13
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes/aumix/aumix-2.8/configure.patch b/recipes/aumix/aumix-2.8/configure.patch
new file mode 100644
index 0000000000..96f16a5a3c
--- /dev/null
+++ b/recipes/aumix/aumix-2.8/configure.patch
@@ -0,0 +1,28 @@
+--- tmp/base/aumix-2.8-r0/aumix-2.8/configure.in Sun Nov 24 19:04:16 2002
++++ aumix-2.8/configure.in Fri Oct 24 18:36:12 2003
+@@ -83,8 +83,7 @@
+ AC_ARG_WITH(sysmouse,
+ [ --without-sysmouse Compile only without sysmouse support],
+ AC_MSG_RESULT([Compiling without sysmouse support]),
+- dnl Checks for sysmouse availability.
+- AC_CHECK_HEADERS(sys/consio.h machine/console.h, break)
++ dnl AC_CHECK_HEADERS(sys/consio.h machine/console.h, break)
+ AC_CACHE_CHECK([for CONS_MOUSECTL],
+ aumix_cv_cons_mousectl,
+ [AC_EGREP_CPP([A mouse is a mouse is a mouse],
+--- tmp/base/aumix-2.8-r0/aumix-2.8/src/Makefile.am Mon Mar 18 19:09:17 2002
++++ aumix-2.8/src/Makefile.am Fri Oct 24 18:39:10 2003
+@@ -7,9 +7,10 @@
+ mouse.c common.h curses.h gpm-xterm.h gtk.h interactive.h \
+ mouse.h play.xpm record.xpm
+ localedir = $(datadir)/locale
+-INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\" -I@includedir@
+-CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ @GTK_CFLAGS@
+-LDADD = -L@libdir@
++#INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\" -I@includedir@
++INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\"
++AM_CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ @GTK_CFLAGS@
++#LDADD = -L@libdir@
+ LIBS = @LIBS@ @GTK_LIBS@ @INTLLIBS@
+ DEFS = @DEFS@
+
diff --git a/recipes/aumix/aumix_2.8.bb b/recipes/aumix/aumix_2.8.bb
new file mode 100644
index 0000000000..50f2cec07a
--- /dev/null
+++ b/recipes/aumix/aumix_2.8.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "A mixer for the terminal or X11, with mouse support."
+SECTION = "console/multimedia"
+LICENSE = "GPLV2"
+DEPENDS = "ncurses"
+
+SRC_URI = "http://jpj.net/~trevor/aumix/aumix-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-gpm --without-sysmouse \
+ --without-alsa --without-gtk \
+ --without-gtk1"