aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2009-08-27 00:09:18 -0700
committerChris Larson <clarson@mvista.com>2009-08-27 00:11:53 -0700
commit4e00d90a75f734c1bbf81a26e93e723a85a7329a (patch)
tree511b21a9380638ecc3e6e03ab298e72686e3f6e3 /recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
parent1482876c97c5bd79ac2cd6e2e32cecec1a4ae3e4 (diff)
downloadopenembedded-4e00d90a75f734c1bbf81a26e93e723a85a7329a.tar.gz
autofs: fix ldflags issue, missing debug info, duplicate opt flags.
Signed-off-by: Chris Larson <clarson@kergoth.com>
Diffstat (limited to 'recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch')
-rw-r--r--recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
index d8b3692efa..dd54dc187a 100644
--- a/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
+++ b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
@@ -6,15 +6,15 @@
ifdef DEBUG
-CFLAGS = -O2 -g -DDEBUG
-LDFLAGS = -g
-+CFLAGS += -O2 -g -DDEBUG
-+LDFLAGS += -g
++CFLAGS ?= -O2 -g -DDEBUG
++LDFLAGS ?= -g
STRIP = :
else
-CFLAGS = -O3 -fomit-frame-pointer -Wall
-LDFLAGS = -s
-STRIP = strip --strip-debug
-+CFLAGS += -O3 -fomit-frame-pointer -Wall
-+LDFLAGS += -s
++CFLAGS ?= -O3 -fomit-frame-pointer -Wall
++LDFLAGS ?= -s
+STRIP = ${TARGET_PREFIX}strip --strip-debug
endif