aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch')
-rw-r--r--recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
new file mode 100644
index 0000000000..d8b3692efa
--- /dev/null
+++ b/recipes/autofs/autofs-4.1.4/Makefile.rules-cross.patch
@@ -0,0 +1,30 @@
+--- autofs-4.1.4/Makefile.rules.orig 2006-04-06 16:47:33.000000000 -0500
++++ autofs-4.1.4/Makefile.rules 2006-04-06 16:49:16.000000000 -0500
+@@ -18,19 +18,19 @@
+ # The STRIP defined here *must not* remove any dynamic-loading symbols
+
+ ifdef DEBUG
+-CFLAGS = -O2 -g -DDEBUG
+-LDFLAGS = -g
++CFLAGS += -O2 -g -DDEBUG
++LDFLAGS += -g
+ STRIP = :
+ else
+-CFLAGS = -O3 -fomit-frame-pointer -Wall
+-LDFLAGS = -s
+-STRIP = strip --strip-debug
++CFLAGS += -O3 -fomit-frame-pointer -Wall
++LDFLAGS += -s
++STRIP = ${TARGET_PREFIX}strip --strip-debug
+ endif
+
+-CC = gcc
+-CXX = g++
++CC ?= ${TARGET_PREFIX}gcc
++CXX ?= ${TARGET_PREFIX}g++
+ CXXFLAGS = $(CFLAGS)
+-LD = ld
++LD ?= ${TARGET_PREFIX}ld
+ SOLDFLAGS = -shared -Xlinker -rpath -Xlinker $(autofslibdir)
+
+ # Standard rules