aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/avahi/avahi-ui_0.6.25.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-30 14:37:42 +0000
committerKoen Kooi <koen@openembedded.org>2009-11-02 11:14:00 +0100
commit86c5af3596d9e85b30bf5198575d8f360e0329c4 (patch)
tree0551cd55e2acd4c2e1b0b1f371b30624c69e40a3 /recipes/avahi/avahi-ui_0.6.25.bb
parentfd778a7191bd64655098ee1469079e9fce9eda4a (diff)
downloadopenembedded-86c5af3596d9e85b30bf5198575d8f360e0329c4.tar.gz
avahi: Bump packages to 0.6.25 (security fix) and add checksums.
Diffstat (limited to 'recipes/avahi/avahi-ui_0.6.25.bb')
-rw-r--r--recipes/avahi/avahi-ui_0.6.25.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/avahi/avahi-ui_0.6.25.bb b/recipes/avahi/avahi-ui_0.6.25.bb
new file mode 100644
index 0000000000..966958d597
--- /dev/null
+++ b/recipes/avahi/avahi-ui_0.6.25.bb
@@ -0,0 +1,20 @@
+require avahi.inc
+
+PR = "r1"
+
+DEPENDS += "avahi gtk+"
+
+AVAHI_GTK = "--enable-gtk"
+
+S = "${WORKDIR}/avahi-${PV}"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/avahi-ui
+ cp ${S}/avahi-ui/*.h ${STAGING_INCDIR}/avahi-ui/
+ oe_libinstall -C avahi-ui -a -so libavahi-ui ${STAGING_LIBDIR}
+}
+
+PACKAGES = "${PN} ${PN}-dbg"
+
+FILES_${PN} = "${libdir}/libavahi-ui*.so.*"
+FILES_${PN}-dbg += "${libdir}/.debug/libavah-ui*"