aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/avr-evtd/avr-evtd_1.7.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/avr-evtd/avr-evtd_1.7.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/avr-evtd/avr-evtd_1.7.2.bb')
-rw-r--r--recipes/avr-evtd/avr-evtd_1.7.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes/avr-evtd/avr-evtd_1.7.2.bb b/recipes/avr-evtd/avr-evtd_1.7.2.bb
new file mode 100644
index 0000000000..7d79b42467
--- /dev/null
+++ b/recipes/avr-evtd/avr-evtd_1.7.2.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "A simple and small user space interface daemon to the Linkstation/Kuro AVR micro-controller"
+HOMEPAGE = "http://sourceforge.net/projects/ppc-evtd"
+SECTION = "console/network"
+PR = "r1"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ppc-evtd/avr_evtd_${PV}.release.tar.gz \
+ file://dont-ignore-config.patch;patch=1 \
+ file://avr_evtd.conf \
+ file://EventScript \
+ file://init"
+S = "${WORKDIR}/usr/src/avr_evtd"
+
+inherit update-rc.d
+
+COMPATIBLE_MACHINE = "(lsppchd|lsppchg|lsmipsel)"
+INITSCRIPT_NAME = "avr-evtd"
+INITSCRIPT_PARAMS = "defaults"
+
+# This is a simple thing and we will only ever need this for powerpc and mipsel
+# on the platforms above. Pretty important though to stop death by watchdog.
+
+do_compile_powerpc() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o PPC/avr_evtd avr_evtd.c -DNO_MELCO -DUBOOT
+}
+
+do_compile_mipsel() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o MIPS/avr_evtd avr_evtd.c -DNO_MELCO -DUBOOT -DMIPS
+}
+
+do_install() {
+ install -D -m 0644 ${WORKDIR}/avr_evtd.conf ${D}${sysconfdir}/default/avr_evtd
+ install -D -m 0755 ${WORKDIR}/EventScript ${D}${sysconfdir}/avr_evtd/EventScript
+ install -D -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/avr-evtd
+}
+
+do_install_append_powerpc() {
+ install -D -m 0755 ${S}/PPC/avr_evtd ${D}${sbindir}/avr_evtd
+}
+
+do_install_append_mipsel() {
+ install -D -m 0755 ${S}/MIPS/avr_evtd ${D}${sbindir}/avr_evtd
+}