aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bacula/bacula-client_1.38.11.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bacula/bacula-client_1.38.11.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bacula/bacula-client_1.38.11.bb')
-rw-r--r--recipes/bacula/bacula-client_1.38.11.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes/bacula/bacula-client_1.38.11.bb b/recipes/bacula/bacula-client_1.38.11.bb
new file mode 100644
index 0000000000..0403d5d076
--- /dev/null
+++ b/recipes/bacula/bacula-client_1.38.11.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "Bacula filedaemon is the client to backup your device using Bacula a network based backup program"
+SECTION = "console/network"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.bacula.org"
+LICENSE = "GPL"
+PR ="r1"
+DEPENDS = "gmp openssl zlib readline"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/bacula/bacula-1.38.11.tar.gz \
+ file://findlib-attribs.patch;patch=1;pnum=1 \
+ file://bacula-fd.init"
+
+S = "${WORKDIR}/bacula-1.38.11"
+
+# Makefile is broken using ccache
+# No idea how to fix it so I turned ccache off
+CCACHE = ""
+
+inherit autotools update-rc.d
+
+LDFLAGS += "-L${STAGING_LIBDIR}"
+CFLAGS += "-L${STAGING_LIBDIR} -I${STAGING_INCDIR}"
+
+INITSCRIPT_NAME = "bacula-fd"
+
+do_configure() {
+ oe_runconf --enable-client-only \
+ --prefix=/usr \
+ --with-working-dir=/var/lib/bacula \
+ --with-fd-user=root \
+ --with-fd-group=bacula
+}
+
+do_compile() {
+ oe_runmake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+do_install() {
+ mkdir -p ${D}/${sbindir}
+ install -m 0754 ${S}/src/filed/bacula-fd ${D}/${sbindir}/
+
+ mkdir -p ${D}/${sysconfdir}/bacula
+ install ${S}/src/filed/bacula-fd.conf ${D}/${sysconfdir}/bacula/
+}
+
+# Add group
+pkg_postinst() {
+ grep -q bacula: /etc/group || addgroup bacula
+}
+
+do_install_append() {
+ mkdir -p ${D}/${sysconfdir}/init.d
+ install ${WORKDIR}/bacula-fd.init ${D}/${sysconfdir}/init.d/bacula-fd
+}