aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bacula
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bacula
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bacula')
-rw-r--r--recipes/bacula/bacula-client_1.38.11.bb54
-rw-r--r--recipes/bacula/files/bacula-fd.init43
-rw-r--r--recipes/bacula/files/findlib-attribs.patch50
3 files changed, 147 insertions, 0 deletions
diff --git a/recipes/bacula/bacula-client_1.38.11.bb b/recipes/bacula/bacula-client_1.38.11.bb
new file mode 100644
index 0000000000..0403d5d076
--- /dev/null
+++ b/recipes/bacula/bacula-client_1.38.11.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "Bacula filedaemon is the client to backup your device using Bacula a network based backup program"
+SECTION = "console/network"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.bacula.org"
+LICENSE = "GPL"
+PR ="r1"
+DEPENDS = "gmp openssl zlib readline"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/bacula/bacula-1.38.11.tar.gz \
+ file://findlib-attribs.patch;patch=1;pnum=1 \
+ file://bacula-fd.init"
+
+S = "${WORKDIR}/bacula-1.38.11"
+
+# Makefile is broken using ccache
+# No idea how to fix it so I turned ccache off
+CCACHE = ""
+
+inherit autotools update-rc.d
+
+LDFLAGS += "-L${STAGING_LIBDIR}"
+CFLAGS += "-L${STAGING_LIBDIR} -I${STAGING_INCDIR}"
+
+INITSCRIPT_NAME = "bacula-fd"
+
+do_configure() {
+ oe_runconf --enable-client-only \
+ --prefix=/usr \
+ --with-working-dir=/var/lib/bacula \
+ --with-fd-user=root \
+ --with-fd-group=bacula
+}
+
+do_compile() {
+ oe_runmake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+do_install() {
+ mkdir -p ${D}/${sbindir}
+ install -m 0754 ${S}/src/filed/bacula-fd ${D}/${sbindir}/
+
+ mkdir -p ${D}/${sysconfdir}/bacula
+ install ${S}/src/filed/bacula-fd.conf ${D}/${sysconfdir}/bacula/
+}
+
+# Add group
+pkg_postinst() {
+ grep -q bacula: /etc/group || addgroup bacula
+}
+
+do_install_append() {
+ mkdir -p ${D}/${sysconfdir}/init.d
+ install ${WORKDIR}/bacula-fd.init ${D}/${sysconfdir}/init.d/bacula-fd
+}
diff --git a/recipes/bacula/files/bacula-fd.init b/recipes/bacula/files/bacula-fd.init
new file mode 100644
index 0000000000..14f9013e6e
--- /dev/null
+++ b/recipes/bacula/files/bacula-fd.init
@@ -0,0 +1,43 @@
+#! /bin/sh
+#
+# bacula-fd init script for OpenZaurus
+#
+
+BACFDBIN=/usr/sbin
+BACFDCFG=/etc/bacula
+PIDDIR=/var/run
+SUBSYSDIR=/var/run/
+
+FD_PORT=9102
+
+FD_USER=root
+FD_GROUP=bacula
+
+case "$1" in
+ start)
+ [ -x ${BACFDBIN}/bacula-fd ] && {
+ echo "Starting the Bacula File daemon"
+ ${BACFDBIN}/bacula-fd $2 -u ${FD_USER} -g ${FD_GROUP} -v -c ${BACFDCFG}/bacula-fd.conf
+ }
+ ;;
+
+ stop)
+ # Stop the FD first so that SD will fail jobs and update catalog
+ [ -x ${BACFDBIN}/bacula-fd ] && {
+ echo "Stopping the Bacula File daemon"
+ killall bacula-fd
+ }
+ ;;
+
+ restart)
+ $0 stop
+ sleep 5
+ $0 start
+ ;;
+
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 1
+ ;;
+esac
+exit 0
diff --git a/recipes/bacula/files/findlib-attribs.patch b/recipes/bacula/files/findlib-attribs.patch
new file mode 100644
index 0000000000..6bf63a95d6
--- /dev/null
+++ b/recipes/bacula/files/findlib-attribs.patch
@@ -0,0 +1,50 @@
+diff -Naur bacula-1.38.11/src/findlib/attribs.c bacula-1.38.11_patched/src/findlib/attribs.c
+--- bacula-1.38.11/src/findlib/attribs.c 2005-09-24 15:11:31.000000000 +0200
++++ bacula-1.38.11_patched/src/findlib/attribs.c 2006-09-16 21:41:45.000000000 +0200
+@@ -135,12 +135,7 @@
+ p += to_base64((int64_t)ff_pkt->LinkFI, p);
+ *p++ = ' ';
+
+-#ifdef HAVE_CHFLAGS
+- /* FreeBSD function */
+- p += to_base64((int64_t)statp->st_flags, p); /* output st_flags */
+-#else
+ p += to_base64((int64_t)0, p); /* output place holder */
+-#endif
+ *p++ = ' ';
+ p += to_base64((int64_t)data_stream, p);
+ *p = 0;
+@@ -225,11 +220,6 @@
+ if (*p == ' ' || (*p != 0 && *(p+1) == ' ')) {
+ p++;
+ p += from_base64(&val, p);
+-#ifdef HAVE_CHFLAGS
+- plug(statp->st_flags, val);
+- } else {
+- statp->st_flags = 0;
+-#endif
+ }
+
+ /* Look for data stream id */
+@@ -377,21 +367,6 @@
+ attr->ofname, be.strerror());
+ ok = false;
+ }
+-#ifdef HAVE_CHFLAGS
+- /*
+- * FreeBSD user flags
+- *
+- * Note, this should really be done before the utime() above,
+- * but if the immutable bit is set, it will make the utimes()
+- * fail.
+- */
+- if (chflags(attr->ofname, attr->statp.st_flags) < 0) {
+- berrno be;
+- Jmsg2(jcr, M_ERROR, 0, _("Unable to set file flags %s: ERR=%s\n"),
+- attr->ofname, be.strerror());
+- ok = false;
+- }
+-#endif
+ }
+ pm_strcpy(attr->ofname, "*none*");
+ umask(old_mask);