aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/balsa
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2010-01-11 23:13:10 +0000
committerutx@penguin.cz <utx@penguin.cz>2010-01-11 23:13:10 +0000
commit48dc1e30a44ece75d7d19d7da0bde9de1051fcbb (patch)
treeaabdc458b3bf6802a551fb156d037423457d38fc /recipes/balsa
parent218e66bbb02bbc60d3d6b893623483e6e6a73107 (diff)
downloadopenembedded-48dc1e30a44ece75d7d19d7da0bde9de1051fcbb.tar.gz
balsa: Fixed corruption in gpe addressbook, fixed icon installation.
Diffstat (limited to 'recipes/balsa')
-rw-r--r--recipes/balsa/balsa-2.4.2/libbalsa-gpe-corruption.patch14
-rw-r--r--recipes/balsa/balsa_2.4.2.bb7
2 files changed, 18 insertions, 3 deletions
diff --git a/recipes/balsa/balsa-2.4.2/libbalsa-gpe-corruption.patch b/recipes/balsa/balsa-2.4.2/libbalsa-gpe-corruption.patch
new file mode 100644
index 0000000000..aa6635abfb
--- /dev/null
+++ b/recipes/balsa/balsa-2.4.2/libbalsa-gpe-corruption.patch
@@ -0,0 +1,14 @@
+https://bugzilla.gnome.org/show_bug.cgi?id=606676
+Index: balsa-2.4.2/libbalsa/address-book-gpe.c
+===================================================================
+--- balsa-2.4.2.orig/libbalsa/address-book-gpe.c
++++ balsa-2.4.2/libbalsa/address-book-gpe.c
+@@ -792,7 +792,7 @@ libbalsa_address_book_gpe_alias_complete
+ #endif /* HAVE_SQLITE3 */
+ if(err) {
+ printf("r=%d err=%s\n", r, err);
+- free(err);
++ sqlite3_free(err);
+ }
+ return gcc.res;
+ }
diff --git a/recipes/balsa/balsa_2.4.2.bb b/recipes/balsa/balsa_2.4.2.bb
index e0675c82ba..8cd91740b8 100644
--- a/recipes/balsa/balsa_2.4.2.bb
+++ b/recipes/balsa/balsa_2.4.2.bb
@@ -2,8 +2,9 @@ DESCRIPTION = "Robust and configurable e-mail client for GNOME"
HOMEPAGE = "http://pawsa.fedorapeople.org/balsa/"
SECTION = "x11/network"
LICENSE = "GPL"
-SRC_URI = "http://pawsa.fedorapeople.org/balsa/${P}.tar.bz2"
-PR = "r0"
+SRC_URI = "http://pawsa.fedorapeople.org/balsa/${P}.tar.bz2 \
+ file://libbalsa-gpe-corruption.patch;patch=1"
+PR = "r1"
DEPENDS = "glib-2.0 gmime gnome-icon-theme gtk+ intltool-native libesmtp libxml-parser-perl-native"
RDEPENDS_${PN} = "gnome-icon-theme"
@@ -61,7 +62,7 @@ DEPENDS += "gconf libgnome libgnomeui"
# FIXME: doc build requires docbook4 and gnome-doc-utils
-inherit autotools
+inherit autotools gtk-icon-cache
EXTRA_OECONF="--with-ssl \
--without-gnome \