aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/base-files
diff options
context:
space:
mode:
authorJason Kridner <jkridner@beagleboard.org>2010-08-19 12:17:44 +0000
committerDenys Dmytriyenko <denis@denix.org>2010-08-19 19:50:06 -0400
commitc323496195aaec26055da823a6c0166c7836c6b2 (patch)
tree73bf6fc1bb7e77e987f8c550a49486703df50b56 /recipes/base-files
parentf7635a8467bb23901c2cfb01fe2371d277be9af7 (diff)
downloadopenembedded-c323496195aaec26055da823a6c0166c7836c6b2.tar.gz
base-files: beagleboard: profile: use nano
If nano is available and EDITOR isn't otherwise set, then use it. Advanced users who would prefer vi will know how to set EDITOR anyway. I can clearly see myself being frustrated typing 'export EDITOR=vi' every time I start a BeagleBoard test ramdisk image, but better me have that than to try to explain to someone fresh how to use vi. Updated with feedback from Gary Thomas to avoid overwriting anyone else's preference. Signed-off-by: Jason Kridner <jkridner@beagleboard.org> Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'recipes/base-files')
-rw-r--r--recipes/base-files/base-files/beagleboard/profile41
-rw-r--r--recipes/base-files/base-files_3.0.14.bb2
2 files changed, 42 insertions, 1 deletions
diff --git a/recipes/base-files/base-files/beagleboard/profile b/recipes/base-files/base-files/beagleboard/profile
new file mode 100644
index 0000000000..301fc93078
--- /dev/null
+++ b/recipes/base-files/base-files/beagleboard/profile
@@ -0,0 +1,41 @@
+# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
+# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
+
+PATH="/usr/local/bin:/usr/bin:/bin"
+# EDITOR needed for packages like cron
+if [ -z "$EDITOR" ]; then
+ if [ -x /usr/bin/nano ]; then
+ EDITOR="/usr/bin/nano"
+ else
+ EDITOR="/bin/vi"
+ fi
+fi
+test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
+
+if [ ! -e /etc/localtime -a ! -e /etc/TZ ]; then
+ TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
+ # for an explanation of how to set this to your local timezone.
+ export TZ
+fi
+
+if [ "`id -u`" -eq 0 ]; then
+ PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin
+fi
+if [ "$PS1" ]; then
+# works for bash and ash (no other shells known to be in use here)
+ PS1='\u@\h:\w\$ '
+fi
+
+if [ -d /etc/profile.d ]; then
+ for i in /etc/profile.d/*.sh; do
+ if [ -r $i ]; then
+ . $i
+ fi
+ done
+ unset i
+fi
+
+export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM
+
+umask 022
+
diff --git a/recipes/base-files/base-files_3.0.14.bb b/recipes/base-files/base-files_3.0.14.bb
index f8d07781ba..ab554bb920 100644
--- a/recipes/base-files/base-files_3.0.14.bb
+++ b/recipes/base-files/base-files_3.0.14.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Miscellaneous files for the base system."
SECTION = "base"
PRIORITY = "required"
-PR = "r97"
+PR = "r98"
LICENSE = "GPL"
SRC_URI = " \