aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/batmand/batmand_0.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/batmand/batmand_0.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/batmand/batmand_0.3.bb')
-rw-r--r--recipes/batmand/batmand_0.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/batmand/batmand_0.3.bb b/recipes/batmand/batmand_0.3.bb
new file mode 100644
index 0000000000..c78f94d5e3
--- /dev/null
+++ b/recipes/batmand/batmand_0.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "https://www.open-mesh.net/batman"
+
+PR = "r0"
+
+RDEPENDS = "kernel-module-tun"
+
+SRC_URI = "\
+ http://downloads.open-mesh.net/batman/stable/sources/batman-0.3.tar.gz \
+ file://makefile-fix.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/batman-${PV}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 batmand ${D}${bindir}
+}