summaryrefslogtreecommitdiffstats
path: root/recipes/bazaar
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/bazaar
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/bazaar')
-rw-r--r--recipes/bazaar/bazaar_1.2.bb62
-rw-r--r--recipes/bazaar/files/import_dirarg.patch53
-rw-r--r--recipes/bazaar/files/no_archive_format_guess_msg.patch10
3 files changed, 125 insertions, 0 deletions
diff --git a/recipes/bazaar/bazaar_1.2.bb b/recipes/bazaar/bazaar_1.2.bb
new file mode 100644
index 0000000000..e64b442733
--- /dev/null
+++ b/recipes/bazaar/bazaar_1.2.bb
@@ -0,0 +1,62 @@
+# bazaar OE build file
+# Copyright (C) 2005 Chris Larson <kergoth@handhelds.org>
+# Released under the MIT license (see the COPYING file in this tree)
+#
+# NOTE:
+# * Does not have an LDFLAGS variable on its link lines, only the "libs"
+# variable, which makes it troublesome to add -L's to the link. For now,
+# we cheat and pass it in CFLAGS.
+
+DEPENDS += "neon"
+DESCRIPTION = "bazaar is an implementation of GNU Arch in C, based on tla."
+HOMEPAGE = "http://bazaar.canonical.com/"
+LICENSE = "GPL"
+PRIORITY = "optional"
+SECTION = "devel"
+PR = "r2"
+RDEPENDS_${PN} += "patch"
+RSUGGESTS_${PN} += "gnupg"
+
+SRC_URI = "http://bazaar.canonical.com/releases/src/bazaar_${PV}.tar.gz \
+ file://no_archive_format_guess_msg.patch;patch=1 \
+ file://import_dirarg.patch;patch=1"
+
+S = "${WORKDIR}/thelove@canonical.com---dists--bazaar--1.2"
+B = "${WORKDIR}/build-${HOST_SYS}"
+
+CFLAGS += "-I${B} -I${S}/src -I${S}/src/baz"
+EXTRA_OEMAKE = "'CC=${CC}' \
+ 'CFLAGS=${CFLAGS} ${LDFLAGS}' \
+ \
+ 'test-scripts=' \
+ 'test-progs=' \
+ 'prefix=${D}${prefix}' \
+ 'program-install-dir=${D}${bindir}' \
+ 'cgi-install-dir=${D}${libdir}/cgi' \
+ 'library-install-dir=${D}${libdir}' \
+ 'include-install-dir=${D}${includedir}/$(thispath)' \
+ 'etc-install-dir=${D}${sysconfdir}' \
+ 'libexec-install-dir=${D}${libexecdir}' \
+ 'info-install-dir=${D}${infodir}' \
+ 'man-install-dir=${D}${mandir}' \
+ 'scm-install-dir=${D}${datadir}/scheme' \
+ 'doc-install-dir=${D}${docdir}/$(thispath)' \
+ 'data-install-dir=${D}${datadir}/$(thispath)' \
+ 'locale-install-dir=${D}${datadir}/locale'"
+PARALLEL_MAKE = ""
+
+
+do_configure () {
+ ${S}/src/configure ${CONFARGS}
+
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake install-all
+ sed -e 's,^#!.*$$,#!/usr/bin/gawk -f,' ${S}/src/baz/=gpg-check.awk > \
+ ${D}${bindir}/bazaar-gpg-check
+}
diff --git a/recipes/bazaar/files/import_dirarg.patch b/recipes/bazaar/files/import_dirarg.patch
new file mode 100644
index 0000000000..101be58b56
--- /dev/null
+++ b/recipes/bazaar/files/import_dirarg.patch
@@ -0,0 +1,53 @@
+--- bazaar-1.2.orig/src/baz/tests/test-import-baz.sh
++++ bazaar-1.2/src/baz/tests/test-import-baz.sh
+@@ -23,7 +23,9 @@
+ tla init-tree --nested jane@example.com--2003/hello-world--mainline--1.0
+ tla id-tagging-method explicit
+ tla add hello-world.c README
+-tla import -L 'initial import'
++cd ..
++tla import -d hello-world--mainline--1.0 -L 'initial import'
++cd hello-world--mainline--1.0
+ tla categories -A jane@example.com--2003 >&2
+ test "$(tla categories -A jane@example.com--2003)" = "hello-world"
+ test "$(tla branches jane@example.com--2003/hello-world)" = "hello-world--mainline"
+--- bazaar-1.2.orig/src/baz/commands/import.c
++++ bazaar-1.2/src/baz/commands/import.c
+@@ -32,7 +32,7 @@
+
+
+
+-static t_uchar * usage = N_("[options] [directory] [archive]/version");
++static t_uchar * usage = N_("[options] [directory] [[archive]/version]");
+
+ #define OPTS(OP) \
+ OP (opt_help_msg, "h", "help", 0, \
+@@ -42,12 +42,14 @@
+ OP (opt_version, "V", "version", 0, \
+ N_("Display a release identifier string\n" \
+ "and exit.")) \
++ OP (opt_dir, "d", "dir DIR", 1, \
++ N_("Change to DIR first.")) \
+ OP (opt_log, "l", "log FILE", 1, \
+ N_("Commit with log file FILE.")) \
+ OP (opt_summary, "s", "summary TEXT", 1, \
+ N_("log with summary TEXT plus log-for-merge output") ) \
+ OP (opt_automatic, "a", "automatic", 0, \
+- N_("Initialise dir as a working tree, add all source-looking files in dir and import.") ) \
++ N_("Initialise dir as a working tree, add all source-looking files in dir and import. This requires version to operate.") ) \
+ OP (opt_log_msg, "L", "log-message TEXT", 1, \
+ N_("log with TEXT"))
+
+@@ -157,6 +159,12 @@
+ safe_printfmt (2, "ill-formed argument for `%s' (`%s')\n", option->opt_string, option->arg_string);
+ goto usage_error;
+
++ case opt_dir:
++ {
++ automatic = 0;
++ break;
++ }
++
+ case opt_log:
+ {
+ log_file = str_save (0, option->arg_string);
diff --git a/recipes/bazaar/files/no_archive_format_guess_msg.patch b/recipes/bazaar/files/no_archive_format_guess_msg.patch
new file mode 100644
index 0000000000..893f4e6002
--- /dev/null
+++ b/recipes/bazaar/files/no_archive_format_guess_msg.patch
@@ -0,0 +1,10 @@
+--- bazaar-1.2.orig/src/baz/libarch/archive-pfs.c
++++ bazaar-1.2/src/baz/libarch/archive-pfs.c
+@@ -240,7 +240,6 @@
+ else if (arch_pfs_file_exists (arch->pfs, meta_info_path))
+ {
+ /* most likely a mirror that's missing a .archive-version file */
+- safe_printfmt (2, _("Guessing archive format as tla 1.0. This is normal with old archives, you can ignore it unless other errors occur.\n"));
+ contents = str_save (0, arch_tree_format_1_str);
+ }
+ else