aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/beecrypt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/beecrypt
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/beecrypt')
-rw-r--r--recipes/beecrypt/beecrypt-native_3.1.0.bb9
-rw-r--r--recipes/beecrypt/beecrypt_3.1.0.bb28
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes/beecrypt/beecrypt-native_3.1.0.bb b/recipes/beecrypt/beecrypt-native_3.1.0.bb
new file mode 100644
index 0000000000..b056a0fb41
--- /dev/null
+++ b/recipes/beecrypt/beecrypt-native_3.1.0.bb
@@ -0,0 +1,9 @@
+# beecrypt-native OE build file
+# Copyright (C) 2004-2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+require beecrypt_${PV}.bb
+S = "${WORKDIR}/beecrypt-${PV}"
+
+inherit native
+EXTRA_OECONF="--enable-shared --enable-static"
diff --git a/recipes/beecrypt/beecrypt_3.1.0.bb b/recipes/beecrypt/beecrypt_3.1.0.bb
new file mode 100644
index 0000000000..f9a45e74df
--- /dev/null
+++ b/recipes/beecrypt/beecrypt_3.1.0.bb
@@ -0,0 +1,28 @@
+# Beecrypt OE build file
+# Copyright (C) 2004-2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="Beecrypt is a general-purpose cryptography library."
+HOMEPAGE="http://sourceforge.net/projects/beecrypt"
+SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz"
+
+PR = "r2"
+
+inherit autotools
+acpaths=""
+
+EXTRA_OECONF="--with-arch=${TARGET_ARCH} --enable-shared --enable-static"
+
+do_stage() {
+
+# oe_libinstall -a -C .libs libbeecrypt ${STAGING_LIBDIR}
+ cp .libs/libbeecrypt.a ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/
+ install -d ${STAGING_INCDIR}/beecrypt
+ for X in beecrypt.h beecrypt.api.h memchunk.h mpnumber.h beecrypt.gnu.h mp.h mpopt.h blockmode.h endianness.h
+ do
+ install -m 0644 ${X} ${STAGING_INCDIR}/beecrypt/${X}
+ done
+
+}
+