aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/beep/beep_1.2.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/beep/beep_1.2.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/beep/beep_1.2.2.bb')
-rw-r--r--recipes/beep/beep_1.2.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/beep/beep_1.2.2.bb b/recipes/beep/beep_1.2.2.bb
new file mode 100644
index 0000000000..759f74f8a0
--- /dev/null
+++ b/recipes/beep/beep_1.2.2.bb
@@ -0,0 +1,30 @@
+# beep: a console utility to "and allow a little more granularity
+# than you get with the default terminal bell"
+DESCRIPTION = "A console utility to make a beep noise"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR = "r2"
+DEPENDS = "install-native"
+
+SRC_URI = "http://johnath.com/beep/beep-${PV}.tar.gz"
+SRC_URI += "file://linux-input.patch;patch=1"
+
+S = "${WORKDIR}/beep-${PV}"
+PACKAGES += "${PN} ${PN}-doc"
+
+inherit autotools
+
+EXTRA_OEMAKE += 'CC="${CC}"'
+EXTRA_OEMAKE += 'FLAGS="${CFLAGS}"'
+
+# slugos requires beep in boot
+BINDIR = "${bindir}"
+BINDIR_slugos = "${base_bindir}"
+
+do_install() {
+ # this is easier than patching the Makefile...
+ install -d "${D}${BINDIR}"
+ install -c -m 755 beep "${D}${BINDIR}/beep"
+ install -d "${D}${mandir}/man1"
+ install -c -m 644 beep.1.gz "${D}${mandir}/man1/beep.1.gz"
+}