aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch')
-rw-r--r--recipes/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch b/recipes/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch
new file mode 100644
index 0000000000..bd519a1e69
--- /dev/null
+++ b/recipes/binutils/binutils-2.17/501-avr32-fix-pool-alignment.patch
@@ -0,0 +1,26 @@
+Index: a/gas/config/tc-avr32.c
+===================================================================
+--- a/gas/config/tc-avr32.c (revision 31496)
++++ b/gas/config/tc-avr32.c (revision 32014)
+@@ -3092,6 +3092,8 @@
+
+ /* Make sure the constant pool is properly aligned */
+ frag_align_code(2, 0);
++ if (bfd_get_section_alignment(stdoutput, pool->section) < 2)
++ bfd_set_section_alignment(stdoutput, pool->section, 2);
+
+ /* Assume none of the entries are discarded, and that we need the
+ maximum amount of alignment. But we're not going to allocate
+Index: a/bfd/configure.in
+===================================================================
+--- a/bfd/configure.in (revision 31496)
++++ b/bfd/configure.in (revision 32014)
+@@ -8,7 +8,7 @@
+ AC_CANONICAL_TARGET
+ AC_ISC_POSIX
+
+-AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.0)
++AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.1)
+
+ dnl These must be called before AM_PROG_LIBTOOL, because it may want
+ dnl to call AC_CHECK_PROG.