aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/binutils/binutils_cvs.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-20 11:51:17 -0700
committerKhem Raj <raj.khem@gmail.com>2009-03-20 11:51:17 -0700
commitc3c3af2895a810ab6ffc93ea73afb73a88c9246f (patch)
tree50c8f53d83a7f468c764264dc7ab8a9a9acf970b /recipes/binutils/binutils_cvs.bb
parent295488d84cc0b856e97a6fab0d725d33e5e55873 (diff)
downloadopenembedded-c3c3af2895a810ab6ffc93ea73afb73a88c9246f.tar.gz
binutils_cvs: Various fixes to get it building.
* Port patched needed from binutils 2.19. * Refresh the old patches. * Cover for bitbake fetcher lameness where it checks out the while src tree when we only asked for binutils module. So we have to build selective targets.
Diffstat (limited to 'recipes/binutils/binutils_cvs.bb')
-rw-r--r--recipes/binutils/binutils_cvs.bb36
1 files changed, 22 insertions, 14 deletions
diff --git a/recipes/binutils/binutils_cvs.bb b/recipes/binutils/binutils_cvs.bb
index 288450cf58..75c88867f1 100644
--- a/recipes/binutils/binutils_cvs.bb
+++ b/recipes/binutils/binutils_cvs.bb
@@ -1,27 +1,35 @@
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-cvs"
PV = "0.0+cvs${SRCDATE}"
-PR = "r3"
+PR = "r0"
require binutils.inc
S = "${WORKDIR}/src"
-
+EXTRA_OEMAKE = "configure-build-libiberty"
SRC_URI = "cvs://anoncvs:anoncvs@sources.redhat.com/cvs/src;module=binutils;method=pserver;localdir=src \
- file://build_fix.patch;patch=1 \
file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;patch=1 \
+ file://binutils-uclibc-100-uclibc-conf.patch;patch=1 \
file://110-arm-eabi-conf.patch;patch=1 \
file://binutils-uclibc-300-001_ld_makefile_patch.patch;patch=1 \
file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
- file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1"
-
-#EXTRA_OECONF = "--with-sysroot=/"
+ file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
+ file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
+ "
-do_configure_prepend () {
- # RP:
- # Remove rda and libgloss since they won't cross compile
- # we don't need them anyway...
- # Also remove gdb, we build that separately.
- rm ${S}/gdb -Rf
- rm ${S}/rda -Rf
- rm ${S}/libgloss -Rf
+do_compile () {
+ oe_runmake all-ld all-binutils all-gas
+}
+do_install () {
+ oe_runmake install-ld install-binutils install-gas
+}
+do_stage () {
+ oe_libinstall -so -a -C opcodes libopcodes ${STAGING_LIBDIR}/
+ oe_libinstall -a -C libiberty libiberty ${STAGING_LIBDIR}/
+ oe_libinstall -so -a -C bfd libbfd ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/include/dis-asm.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/include/symcat.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/include/libiberty.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/include/ansidecl.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/include/bfdlink.h ${STAGING_INCDIR}/
+ install -m 0644 bfd/bfd.h ${STAGING_INCDIR}/
}