aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/binutils
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-21 23:11:54 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-23 07:51:29 -0700
commite35d6a3ab40a1a34fe466c4dcf6519373fde8442 (patch)
treecded9a14c4c7fcf0b312ca689e51b4f45e77b39a /recipes/binutils
parentbafea11a8e5e5aea4f16789a780ca9f491f94ebe (diff)
downloadopenembedded-e35d6a3ab40a1a34fe466c4dcf6519373fde8442.tar.gz
binutils_2.20.1.bb: Add patch to fix ld sysroot
Fixes the issue seen on builds where libc.so is not being found Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/binutils')
-rw-r--r--recipes/binutils/binutils-2.20.1/binutils-2.19.1-ld-sysroot.patch36
-rw-r--r--recipes/binutils/binutils_2.20.1.bb3
2 files changed, 38 insertions, 1 deletions
diff --git a/recipes/binutils/binutils-2.20.1/binutils-2.19.1-ld-sysroot.patch b/recipes/binutils/binutils-2.20.1/binutils-2.19.1-ld-sysroot.patch
new file mode 100644
index 0000000000..b252196a79
--- /dev/null
+++ b/recipes/binutils/binutils-2.20.1/binutils-2.19.1-ld-sysroot.patch
@@ -0,0 +1,36 @@
+http://sourceware.org/bugzilla/show_bug.cgi?id=10340
+
+Signed-off-by: Sven Rebhan <odinshorse@googlemail.com>
+
+Always try to prepend the sysroot prefix to absolute filenames first.
+
+--- a/ld/ldfile.c 2009-06-14 12:46:19.000000000 +0200
++++ b/ld/ldfile.c.new 2009-06-14 12:46:04.000000000 +0200
+@@ -308,18 +308,24 @@
+ directory first. */
+ if (! entry->is_archive)
+ {
+- if (entry->sysrooted && IS_ABSOLUTE_PATH (entry->filename))
++ /* For absolute pathnames, try to always open the file in the
++ sysroot first. If this fails, try to open the file at the
++ given location. */
++ entry->sysrooted = is_sysrooted_pathname(entry->filename, FALSE);
++ if (IS_ABSOLUTE_PATH (entry->filename) && ld_sysroot && ! entry->sysrooted)
+ {
+ char *name = concat (ld_sysroot, entry->filename,
+ (const char *) NULL);
+ if (ldfile_try_open_bfd (name, entry))
+ {
+ entry->filename = name;
++ entry->sysrooted = TRUE;
+ return TRUE;
+ }
+ free (name);
+ }
+- else if (ldfile_try_open_bfd (entry->filename, entry))
++
++ if (ldfile_try_open_bfd (entry->filename, entry))
+ {
+ entry->sysrooted = IS_ABSOLUTE_PATH (entry->filename)
+ && is_sysrooted_pathname (entry->filename, TRUE);
+
diff --git a/recipes/binutils/binutils_2.20.1.bb b/recipes/binutils/binutils_2.20.1.bb
index d75dbb2569..c2a5dab174 100644
--- a/recipes/binutils/binutils_2.20.1.bb
+++ b/recipes/binutils/binutils_2.20.1.bb
@@ -1,7 +1,7 @@
require binutils.inc
LICENSE = "GPLv3"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
#COMPATIBLE_TARGET_SYS = "."
@@ -15,6 +15,7 @@ SRC_URI = "\
file://binutils-uclibc-gas-needs-libm.patch \
file://binutils-x86_64_i386_biarch.patch \
file://libtool-update.patch \
+ file://binutils-2.19.1-ld-sysroot.patch \
"
SRC_URI_append_nios2 =" \