aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/binutils
diff options
context:
space:
mode:
authorMartin Dietze <martin@the-little-red-haired-girl.org>2009-05-23 13:16:35 +0200
committerMartin Dietze <mdietze@gmail.com>2013-03-02 17:25:35 +0100
commitfc19c82b5f6ec732309aa6bcc6e1a913e64a4859 (patch)
treef405b7031b1ffced1cb8f8fda713fe49a135811e /recipes/binutils
parentff8d77e436f50623af2177cef58e90adfc90e09f (diff)
downloadopenembedded-fc19c82b5f6ec732309aa6bcc6e1a913e64a4859.tar.gz
Fixed broken configure script which lead to invalid prefix for cross executables in some cases * the sed substitutions for flags like `--program-transform-name' were not global, they are now
Diffstat (limited to 'recipes/binutils')
-rw-r--r--recipes/binutils/binutils-2.14.90.0.7/binutils-2.14.90.0.7-fix-broken-configure.patch78
-rw-r--r--recipes/binutils/binutils_2.14.90.0.7.bb3
2 files changed, 80 insertions, 1 deletions
diff --git a/recipes/binutils/binutils-2.14.90.0.7/binutils-2.14.90.0.7-fix-broken-configure.patch b/recipes/binutils/binutils-2.14.90.0.7/binutils-2.14.90.0.7-fix-broken-configure.patch
new file mode 100644
index 0000000000..30d4bcdf78
--- /dev/null
+++ b/recipes/binutils/binutils-2.14.90.0.7/binutils-2.14.90.0.7-fix-broken-configure.patch
@@ -0,0 +1,78 @@
+--- binutils-2.14.90.0.7/configure.in-orig 2009-03-30 13:12:57.000000000 +0200
++++ binutils-2.14.90.0.7/configure.in 2009-03-30 13:13:36.000000000 +0200
+@@ -1795,21 +1795,21 @@
+ # at the end of the argument list.
+ # These will be expanded by make, so quote '$'.
+ cat <<\EOF_SED > conftestsed
+-s/ --no[[^ ]]* / /
+-s/ --c[[a-z-]]*[[= ]][[^ ]]* / /
+-s/ --sr[[a-z-]]*[[= ]][[^ ]]* / /
+-s/ --ho[[a-z-]]*[[= ]][[^ ]]* / /
+-s/ --bu[[a-z-]]*[[= ]][[^ ]]* / /
+-s/ --t[[a-z-]]*[[= ]][[^ ]]* / /
+-s/ --program-[[pst]][[a-z-]]*[[= ]][[^ ]]* / /
+-s/ -cache-file[[= ]][[^ ]]* / /
+-s/ -srcdir[[= ]][[^ ]]* / /
+-s/ -host[[= ]][[^ ]]* / /
+-s/ -build[[= ]][[^ ]]* / /
+-s/ -target[[= ]][[^ ]]* / /
+-s/ -program-prefix[[= ]][[^ ]]* / /
+-s/ -program-suffix[[= ]][[^ ]]* / /
+-s/ -program-transform-name[[= ]][[^ ]]* / /
++s/ --no[[^ ]]* / /g
++s/ --c[[a-z-]]*[[= ]][[^ ]]* / /g
++s/ --sr[[a-z-]]*[[= ]][[^ ]]* / /g
++s/ --ho[[a-z-]]*[[= ]][[^ ]]* / /g
++s/ --bu[[a-z-]]*[[= ]][[^ ]]* / /g
++s/ --t[[a-z-]]*[[= ]][[^ ]]* / /g
++s/ --program-[[pst]][[a-z-]]*[[= ]][[^ ]]* / /g
++s/ -cache-file[[= ]][[^ ]]* / /g
++s/ -srcdir[[= ]][[^ ]]* / /g
++s/ -host[[= ]][[^ ]]* / /g
++s/ -build[[= ]][[^ ]]* / /g
++s/ -target[[= ]][[^ ]]* / /g
++s/ -program-prefix[[= ]][[^ ]]* / /g
++s/ -program-suffix[[= ]][[^ ]]* / /g
++s/ -program-transform-name[[= ]][[^ ]]* / /g
+ s/ [[^' -][^ ]*] / /
+ s/^ *//;s/ *$//
+ s,\$,$$,g
+--- binutils-2.14.90.0.7/configure-orig 2009-03-30 13:12:51.000000000 +0200
++++ binutils-2.14.90.0.7/configure 2009-03-30 13:13:25.000000000 +0200
+@@ -2556,21 +2556,21 @@
+ # at the end of the argument list.
+ # These will be expanded by make, so quote '$'.
+ cat <<\EOF_SED > conftestsed
+-s/ --no[^ ]* / /
+-s/ --c[a-z-]*[= ][^ ]* / /
+-s/ --sr[a-z-]*[= ][^ ]* / /
+-s/ --ho[a-z-]*[= ][^ ]* / /
+-s/ --bu[a-z-]*[= ][^ ]* / /
+-s/ --t[a-z-]*[= ][^ ]* / /
+-s/ --program-[pst][a-z-]*[= ][^ ]* / /
+-s/ -cache-file[= ][^ ]* / /
+-s/ -srcdir[= ][^ ]* / /
+-s/ -host[= ][^ ]* / /
+-s/ -build[= ][^ ]* / /
+-s/ -target[= ][^ ]* / /
+-s/ -program-prefix[= ][^ ]* / /
+-s/ -program-suffix[= ][^ ]* / /
+-s/ -program-transform-name[= ][^ ]* / /
++s/ --no[^ ]* / /g
++s/ --c[a-z-]*[= ][^ ]* / /g
++s/ --sr[a-z-]*[= ][^ ]* / /g
++s/ --ho[a-z-]*[= ][^ ]* / /g
++s/ --bu[a-z-]*[= ][^ ]* / /g
++s/ --t[a-z-]*[= ][^ ]* / /g
++s/ --program-[pst][a-z-]*[= ][^ ]* / /g
++s/ -cache-file[= ][^ ]* / /g
++s/ -srcdir[= ][^ ]* / /g
++s/ -host[= ][^ ]* / /g
++s/ -build[= ][^ ]* / /g
++s/ -target[= ][^ ]* / /g
++s/ -program-prefix[= ][^ ]* / /g
++s/ -program-suffix[= ][^ ]* / /g
++s/ -program-transform-name[= ][^ ]* / /g
+ s/ [^' -][^ ]* / /
+ s/^ *//;s/ *$//
+ s,\$,$$,g
diff --git a/recipes/binutils/binutils_2.14.90.0.7.bb b/recipes/binutils/binutils_2.14.90.0.7.bb
index b47c8e51b1..3447c4fea8 100644
--- a/recipes/binutils/binutils_2.14.90.0.7.bb
+++ b/recipes/binutils/binutils_2.14.90.0.7.bb
@@ -48,7 +48,8 @@ SRC_URI = \
file://binutils-uclibc-210-cflags.patch;patch=1 \
file://binutils-100_cflags_for_build.patch;patch=1 \
file://plt32trunc.patch;patch=1 \
- file://600-arm-textrel.patch;patch=1"
+ file://600-arm-textrel.patch;patch=1 \
+ file://binutils-2.14.90.0.7-fix-broken-configure.patch;patch=1"
S = "${WORKDIR}/binutils-${PV}"
B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"