aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/binutils
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-12-09 20:43:10 -0800
committerKhem Raj <raj.khem@gmail.com>2009-12-09 20:47:19 -0800
commite1334d5719f663e87eef07b95ea66ddc04189d31 (patch)
treea3b96df23669b6f70815fca5b6bfd317e1a75b6d /recipes/binutils
parent4da28a2fbb3ead466a81382970c976667e6ab6cc (diff)
downloadopenembedded-e1334d5719f663e87eef07b95ea66ddc04189d31.tar.gz
binutils-2.20: Dont apply binutils-arm-pr7093 patch.
* Delete the patches which are not applied to 2.20 recipes. Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/binutils')
-rw-r--r--recipes/binutils/binutils-2.20/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch39
-rw-r--r--recipes/binutils/binutils-2.20/binutils-arm-pr7093.patch19
-rw-r--r--recipes/binutils/binutils-2.20/uclibc-segfault.patch23
-rw-r--r--recipes/binutils/binutils_2.20.bb3
4 files changed, 1 insertions, 83 deletions
diff --git a/recipes/binutils/binutils-2.20/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch b/recipes/binutils/binutils-2.20/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch
deleted file mode 100644
index 8df5b1fea0..0000000000
--- a/recipes/binutils/binutils-2.20/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-# strip (and objcopy) fail to set the error code if there is no
-# output file name and the rename of the stripped (or copied) file
-# fails, yet the command fails to do anything. This fixes both
-# objcopy and strip.
-#
-# modification by bero: Ported to 2.16.91.0.6
-#
-#Signed-off-by: John Bowler <jbowler@acm.org>
-#Signed-off-by: Bernhard Rosenkraenzer <bero@arklinux.org>
----
-# binutils/objcopy.c | 8 +++++---
-# 1 file changed, 5 insertions(+), 3 deletions(-)
-#
-Index: src/binutils/objcopy.c
-===================================================================
---- src.orig/binutils/objcopy.c 2007-08-09 13:26:03.000000000 +0100
-+++ src/binutils/objcopy.c 2007-08-09 16:36:12.000000000 +0100
-@@ -2787,8 +2787,9 @@ strip_main (int argc, char *argv[])
- if (preserve_dates)
- set_times (tmpname, &statbuf);
- if (output_file != tmpname)
-- smart_rename (tmpname, output_file ? output_file : argv[i],
-- preserve_dates);
-+ if (smart_rename (tmpname, output_file ? output_file : argv[i],
-+ preserve_dates))
-+ hold_status = 1;
- status = hold_status;
- }
- else
-@@ -3411,7 +3412,8 @@ copy_main (int argc, char *argv[])
- if (preserve_dates)
- set_times (tmpname, &statbuf);
- if (tmpname != output_filename)
-- smart_rename (tmpname, input_filename, preserve_dates);
-+ if (smart_rename (tmpname, input_filename, preserve_dates))
-+ status = 1;
- }
- else
- unlink_if_ordinary (tmpname);
diff --git a/recipes/binutils/binutils-2.20/binutils-arm-pr7093.patch b/recipes/binutils/binutils-2.20/binutils-arm-pr7093.patch
deleted file mode 100644
index ad4a556e0f..0000000000
--- a/recipes/binutils/binutils-2.20/binutils-arm-pr7093.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: binutils/bfd/elf32-arm.c
-===================================================================
-RCS file: /cvs/src/src/bfd/elf32-arm.c,v
-retrieving revision 1.162
-retrieving revision 1.163
-diff -u -r1.162 -r1.163
---- binutils/bfd/elf32-arm.c 23 Dec 2008 09:01:45 -0000 1.162
-+++ binutils/bfd/elf32-arm.c 23 Dec 2008 11:46:17 -0000 1.163
-@@ -4608,6 +4608,10 @@
- Elf_Internal_Shdr *hdr;
- unsigned int i, localsyms;
-
-+ /* PR 7093: Make sure that we are dealing with an arm elf binary. */
-+ if (! is_arm_elf (abfd))
-+ return;
-+
- if ((abfd->flags & DYNAMIC) != 0)
- return;
-
diff --git a/recipes/binutils/binutils-2.20/uclibc-segfault.patch b/recipes/binutils/binutils-2.20/uclibc-segfault.patch
deleted file mode 100644
index 16a875f8eb..0000000000
--- a/recipes/binutils/binutils-2.20/uclibc-segfault.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-upstream: already committed
-
---- clean/binutils-2.19.51/bfd/elf32-arm.c 2009-05-22 12:58:44.000000000 +0100
-+++ binutils-2.19.51/bfd/elf32-arm.c 2009-06-08 21:29:49.000000000 +0100
-@@ -8960,7 +8964,7 @@ elf32_arm_fix_exidx_coverage (asection *
- struct bfd_elf_section_data *elf_sec = elf_section_data (sec);
- Elf_Internal_Shdr *hdr = &elf_sec->this_hdr;
-
-- if (hdr->sh_type != SHT_ARM_EXIDX)
-+ if (!hdr || hdr->sh_type != SHT_ARM_EXIDX)
- continue;
-
- if (elf_sec->linked_to)
---- clean/binutils-2.19.51/ld/emultempl/armelf.em 2009-05-22 12:58:45.000000000 +0100
-+++ binutils-2.19.51/ld/emultempl/armelf.em 2009-06-08 21:26:34.000000000 +0100
-@@ -309,6 +309,7 @@ gld${EMULATION_NAME}_finish (void)
- asection *out_sec = sec->output_section;
-
- if (out_sec
-+ && elf_section_data (sec)
- && elf_section_type (sec) == SHT_PROGBITS
- && (elf_section_flags (sec) & SHF_EXECINSTR) != 0
- && (sec->flags & SEC_EXCLUDE) == 0
diff --git a/recipes/binutils/binutils_2.20.bb b/recipes/binutils/binutils_2.20.bb
index 62f40f231a..5398688cfb 100644
--- a/recipes/binutils/binutils_2.20.bb
+++ b/recipes/binutils/binutils_2.20.bb
@@ -2,7 +2,7 @@ require binutils.inc
LICENSE = "GPLv3"
INC_PR = "r1"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
SRC_URI = "\
${GNU_MIRROR}/binutils/binutils-${PV}.tar.bz2 \
@@ -12,7 +12,6 @@ SRC_URI = "\
file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
- file://binutils-arm-pr7093.patch;patch=1 \
file://ld-stub-crash.patch;patch=1;pnum=0 \
file://binutils-arm-non-empty-know.patch;patch=1 \
"